This project has moved and is read-only. For the latest updates, please go here.

Email authentication

Oct 28, 2012 at 12:30 PM

Hi

Working with MCEbuddy 2.3.5, first of all congrats for a very good version.

One issue though, I cannot get email notifications to work. I am reasonably savvy on email and have gotten all kinds of clients (Outlook et al) to work with my various email accounts, I also understand port 587 and SSL and the like.

I however always get an error trying to set up MCEbuddy's email feature. The log then reads:

ERROR> 2012-10-28T12:10:57 MCEBuddy.Engine.Core --> Error sending eMail -> System.Net.Mail.SmtpException: Für den SMTP-Server ist eine sichere Verbindung erforderlich, oder der Client wurde nicht authentifiziert. Die Serverantwort war: authentication required for mail submission
   bei System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
   bei System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)
   bei System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
   bei System.Net.Mail.SmtpClient.Send(MailMessage message)
   bei MCEBuddy.Util.eMail.SendEMail(EMailOptions emailOptions, String subject, String message, Log& jobLog, Object context, SendCompletedEventHandler asyncCallback)

Can it be that MCEbuddy is not set up to authenticate itself to the email server before sending? All my providers require that.

Regards

Chris

Oct 28, 2012 at 2:09 PM

Chris,

 

For my ref I translated the error:

System.Net.Mail.SmtpException: The SMTP server requires a secure connection is required, or the client was not authenticated. The server response was: authentication required for mail submission

 

It looks like you need to check the SSL box and enter the SSL port. I'm using gmail for my notifications with SSL (authentication) and this is the config I'm using.

eMailServer=smtp.gmail.com
eMailPort=587
eMailSSL=True
eMailFrom=XXXXXXXXXXXXXXX
eMailTo=XXXXXXXXXXXXX
eMailSuccess=False
eMailFailed=True
eMailCancelled=True
eMailStart=False
eMailUsername=XXXXXXXXXXXXX
eMailPassword=XXXXXXXXXXXX

 

I've masked out some details. You'll need to post your configuration (open MCEBuddy.conf and copy paste the above section) to debug this further.

Have you tried the SSL option with the SSL port?

Oct 28, 2012 at 5:45 PM

Hi

Thanks for the extremely rapid reply. Yes I have tried SSL, but I think if you read “authentication required for mail submission” what it means is that you have to authenticate yourself before you can send an email. This is quite common now to avoid spam. Does MCEbuddy do that? I am not at the PC where MCEbuddy is installed but will send my config when I am next.

Regards

Chris

From: rboy1 [email removed]
Sent: Sunday, October 28, 2012 2:09 PM
To: christoph_jans@hotmail.com
Subject: Re: Email authentication [mcebuddy2x:401029]

From: rboy1

Chris,

For my ref I translated the error:

System.Net.Mail.SmtpException: The SMTP server requires a secure connection is required, or the client was not authenticated. The server response was: authentication required for mail submission

It looks like you need to check the SSL box and enter the SSL port. I'm using gmail for my notifications with SSL (authentication) and this is the config I'm using.

eMailServer=smtp.gmail.com
eMailPort=587
eMailSSL=True
eMailFrom=XXXXXXXXXXXXXXX
eMailTo=XXXXXXXXXXXXX
eMailSuccess=False
eMailFailed=True
eMailCancelled=True
eMailStart=False
eMailUsername=XXXXXXXXXXXXX
eMailPassword=XXXXXXXXXXXX

I've masked out some details. You'll need to post your configuration (open MCEBuddy.conf and copy paste the above section) to debug this further.

Have you tried the SSL option with the SSL port?

Oct 29, 2012 at 12:23 AM
Yes

That's what the username and password boxes are for.
>
Nov 4, 2012 at 9:10 PM

Hi

Tried another email provider and it worked. Thanks for the great program, hope you saw my donation.

Chris

From: rboy1 [email removed]
Sent: Sunday, October 28, 2012 2:09 PM
To: christoph_jans@hotmail.com
Subject: Re: Email authentication [mcebuddy2x:401029]

From: rboy1

Chris,

For my ref I translated the error:

System.Net.Mail.SmtpException: The SMTP server requires a secure connection is required, or the client was not authenticated. The server response was: authentication required for mail submission

It looks like you need to check the SSL box and enter the SSL port. I'm using gmail for my notifications with SSL (authentication) and this is the config I'm using.

eMailServer=smtp.gmail.com
eMailPort=587
eMailSSL=True
eMailFrom=XXXXXXXXXXXXXXX
eMailTo=XXXXXXXXXXXXX
eMailSuccess=False
eMailFailed=True
eMailCancelled=True
eMailStart=False
eMailUsername=XXXXXXXXXXXXX
eMailPassword=XXXXXXXXXXXX

I've masked out some details. You'll need to post your configuration (open MCEBuddy.conf and copy paste the above section) to debug this further.

Have you tried the SSL option with the SSL port?

Nov 5, 2012 at 1:57 AM

you're welcome and thanks

Jan 13, 2013 at 11:10 PM

Hi

I recently seem to get the service to crash frequently. I start it and then it rund for 10 secs and crashes:

Application: MCEBuddy.Service.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.AccessViolationException

Stack:

at MCEBuddy.VideoProperties.MediaInfoDll.MediaInfo_Open(IntPtr, System.String)

at MCEBuddy.VideoProperties.MediaInfoDll.Open(System.String)

at MCEBuddy.RemuxMediaCenter.RemuxMCERecording.RemuxFFmpeg()

at MCEBuddy.RemuxMediaCenter.RemuxMCERecording.Remux()

at MCEBuddy.Engine.ConversionJob.Convert()

at System.Threading.ExecutionContext.runTryCode(System.Object)

at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode, CleanupCode, System.Object)

at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)

at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)

at System.Threading.ThreadHelper.ThreadStart()

Any Ideas?

Chris

From: rboy1 [email removed]
Sent: Monday, November 05, 2012 2:57 AM
To: christoph_jans@hotmail.com
Subject: Re: Email authentication [mcebuddy2x:401029]

From: rboy1

you're welcome and thanks

Jan 13, 2013 at 11:17 PM

check the permissions on your video file, if SYSTEM and local Service do not have read/write access, it will cause this issue.

 

Alternatively try a clean install of MCEBuddy, but likely it's a file permission issue

Jan 19, 2013 at 11:24 AM

Hi

The problem seems that I was using the “M4V Apple Normal” conversion profile which has a 4 GB limitation. I now am trying “MP4 normal” where the comment doesn’t mention a 4GB limit. But it just sits there saying “Fast remuxing” and there is no %age bar like for the other tasks. I waited 30 mins now and it still looks the same. Any idea?

Christoph

From: rboy1 [email removed]
Sent: Monday, January 14, 2013 12:18 AM
To: christoph_jans@hotmail.com
Subject: Re: Email authentication [mcebuddy2x:401029]

From: rboy1

check the permissions on your video file, if SYSTEM and local Service do not have read/write access, it will cause this issue.

Alternatively try a clean install of MCEBuddy, but likely it's a file permission issue

Jan 19, 2013 at 3:58 PM

Upload your conversion log file, that will give the story

Mar 12, 2013 at 12:15 PM
There is another point to keep in mind.

There are 2 types of SSL authentication
  1. Implicit SSL
  2. Explicit SSL
MCEBuddy ONLY support Explicit SSL (.NET limitation) - that is it expects the server to support the STARTLS command

Yahoo SMTP Mail default SSL with port 465 is Implicit SSL and will not work with MCEBuddy

Instead use Yahoo SMTP mail WITHOUT SSL and on port 587 and that will work.

Gmail uses Explicit SSL so that works perfectly. Google Implicit SSL for more details.