Display converted files in MCE Recorded TV

Nov 30, 2012 at 5:01 AM

hi all.  Great product!  I hope this isn't an ignorant question, but is it possible to convert MCE recorded TV shows, and have the converted shows still show up in MCE's record TV show section?  Or some other location in MCE?

Coordinator
Nov 30, 2012 at 6:01 AM

If you're using the latest version 2.3.10, then convert to WTV and put it back (leave destination folder blank on conversion task assuming the monitor task has the source folder as the recorded TV folder) in your recorded TV folder, it'll show up in the recorded TV section of MCE.

Otherwise convert to MP4 and put it (set destination folder) in the folder for Video's or movies that's configured in MCE and it'll show up there.

Nov 30, 2012 at 6:17 AM

Thanks, I will give that a try.

Dec 7, 2012 at 4:00 AM

I tried the WTV output tonight. I'm using 2.3.10. I used the WTV NoRecode option with Comskip turned on, allowing it to 'replace' the original file (accidentally) since I didn't designate a separate output folder. The commercial-skipped file looks to be OK, but now the program isn't showing in WMC7's Recorded TV. What am I doing wrong? I did notice that the 'details' section of the new WTV file is empty (Description, Media, RecordedTV, Audio, Video, Origin, etc). Is that why WMC7 isn't showing it?

Coordinator
Dec 8, 2012 at 9:08 AM

I just tested it and it's working fine, I put the converted file back into the recorded TV folder and subfolders and it showed up perfectly with all details on the recorded TV section of Media Center.

 

Maybe the original file was missing some metadata. You'll need to post the log file to get more details.

Dec 9, 2012 at 2:52 AM

 

Uploaded under usahale Folder.

Coordinator
Dec 9, 2012 at 3:51 AM

the log file looks good. Can you upload the converted WTV file (you don't need to upload hte full 4GB, use a binary file splitter (lying in the MCEBuddy server) to cut it down to 20-30MB and then upload (or you can upload hte whole file).

 

I need to get into the file to see what properties it has (right click properties -> details). Would help to have the file.

Dec 9, 2012 at 9:47 PM

Could you point me to where I can learn how to do the split? I found a splitter in Extras, but have no clue how to utilize.

Coordinator
Dec 10, 2012 at 3:41 AM

Load the file, Select the size you want and destination folder and click split. I just need the 1st file.

Dec 10, 2012 at 4:37 PM

OK. I grabbed another splitter and loaded 30MB in the same folder.

Honestly, I didn't see how to utilize the splitter I installed from the Extras folder.

Coordinator
Dec 10, 2012 at 6:38 PM

that 'cause the splitter I was referring I had loaded for you on the MCEBuddy server. The splitter in the extras folder is a MKV codec.

Dec 10, 2012 at 8:38 PM
Edited Dec 10, 2012 at 8:53 PM

I also attempted this and WTV files won't play or be seen by media center. This is the latest version of MCEBuddy I just downloaded. Just doing straight WTV to WTV NO RECODE, using comskip on all default settings.  Unable to watch recording., does it with 4 different recordings and nothing shows up in media center.

Dec 11, 2012 at 2:27 AM

hehe. Uploaded first 30MB chunk. I'm also uploading another failed. I have the original WTV available, so I'll upload the log, 30MB of the original & 30MB of the 'norecoded'.

Coordinator
Dec 11, 2012 at 5:31 AM
chambonito wrote:

I also attempted this and WTV files won't play or be seen by media center. This is the latest version of MCEBuddy I just downloaded. Just doing straight WTV to WTV NO RECODE, using comskip on all default settings.  Unable to watch recording., does it with 4 different recordings and nothing shows up in media center.

What version of Windows / MCE are you using? Are the converted files placed in the recorded TV folder?

Coordinator
Dec 11, 2012 at 5:40 AM
usahale wrote:

hehe. Uploaded first 30MB chunk. I'm also uploading another failed. I have the original WTV available, so I'll upload the log, 30MB of the original & 30MB of the 'norecoded'.

The converted WTV file is corrupted - I'm not able to read it. Can you upload the entire original file so I can try to replicate the issue.

Are you able to play the converted WTV file in Windows Media Player or MCE? Also when you right click the file -> Properties ->  Details, what do you see?

Dec 11, 2012 at 2:44 PM

Original file is on it's way, I'm guessing at least 2 hours. First copy aborted and I can't delete the partial file, so the 2nd one has 'usahale' on the back of the filename.

Details on the bad converted files are empty all the way down to the filename. So far it looks like the bad conversions are all OTA HD recordings. SVideo-in recordings look to be converting OK.

Coordinator
Dec 11, 2012 at 3:48 PM
Edited Dec 11, 2012 at 3:48 PM

hmm interesting, I'll wait for the originnal OTA HD WTV recording to upload to debug this further

Dec 11, 2012 at 3:53 PM
Edited Dec 11, 2012 at 4:34 PM

It's uploaded already. The 'Frosty' file. :) 4.2GB

Coordinator
Dec 12, 2012 at 7:09 AM

Okay I tried it, converted to Wtv NoRecode, no renaming etc - same settings from teh log file.

It converts perfectly, replaces the original file and then shows up in Recorded TV in MCE. All the properties are there and metadata copied over.

This was on a 32bit system. Tomorrow I'll try the 64bit system.

Dec 12, 2012 at 8:14 AM

I am running windows 7 64 bit with 64 bit mcebuddy. Wtv no recode will not play at all. Wtv (without recode) plays but fast forward wouldn't work. So it rendered it useless. Haven't tried 32 bit mcebuddy yet. 

Coordinator
Dec 12, 2012 at 4:04 PM

Okay I'm able to replicate the issue, will try to see if can be fixed. It may be a FFMPEG limitation on the size of the file.

Dec 12, 2012 at 10:14 PM

I'm having the same problem.  Is it possible an older version doesn't have this issue?

Dec 14, 2012 at 2:32 PM

It looks like you said the 32-bit version of MCEBuddy worked. Should I switch to that?

Coordinator
Dec 15, 2012 at 3:38 PM

There is a bug in FFMPEG while prevents it from creating properly formed files (sometimes) with files > 2GB. I'm working with the ffmpeg forum to fix it, there's a partial fix in the next release 2.3.11 but will need to wait for a while here.

Coordinator
Dec 23, 2012 at 3:40 PM

This has been completely fixed in 2.3.11, WTV should work fine now.

Dec 23, 2012 at 6:05 PM

Sounds great! So the fast forward issue is fixed as well on wtv files? When can we download 2.3.11?

Coordinator
Dec 23, 2012 at 7:00 PM

YEs it's been fixed, it'll be out soon.

Dec 23, 2012 at 7:57 PM

Great! ! Thanks for the information! !

Dec 26, 2012 at 5:14 AM

Recorded TV HD is a program that runs in WMC just like the regular recorded TV strip, but will let you add loacations outside of where you record you wtv files (ie. where your post converted files are) and combines them all under one place with metadata.

http://www.recordedtvhd.com/buy/

Dec 26, 2012 at 8:22 AM

I downloaded the new MCEBuddy 64 bit for my windows 7 64 bit machine.  It seems to do the conversion correctly where media center will see and play the WTV files correctly.  I am stoked about this, however..The fast forward 3 or 4 times doesn't work.  So if I press the fast forward once to 2x fast forward it does it fine..but anything beyond that it doesn't work.  Just goes back to normal play....

Coordinator
Dec 29, 2012 at 3:49 PM

I'll look into - may need time

Jan 5, 2013 at 5:07 AM

I realize you are looking into the issue, but I would like to point out that I am having the same problem.  I am taking my recorded tv shows (WTV) and putting them through the WTV (Unprocessed) profile so I can remove the commercials.  The resulting file can only do x2 fast forward as stated by chambonito.  If I try to go any faster, it just goes back to play.  In addition, the rewind does not work at all - it simply pauses for a second, like it is trying to rewind, and then starts playing again.  I have gotten the same result with both comskip on and off.  I believe I also tried the processed version of the WTV profile and got the same result.

I am also on a windows 7 64 bit machine using the 64 bit version of MCEBuddy (release 11).

Coordinator
Jan 5, 2013 at 5:36 AM
Edited Jan 13, 2013 at 5:38 AM

I've posted this issue here, I would request folks who are facing a problem with this please VOTE for this issue with the ffmpeg team so they can fix the base code. Therafter I'll be able to integrate it back into MCEBuddy.

 

https://ffmpeg.org/trac/ffmpeg/ticket/2078

 

Click on Up Vote on the top of the page under the Roadmap button. More votes = faster fix. Add you comments if you'd like to speed it up even more.

Jan 12, 2013 at 10:59 PM
rboy1 wrote:

I've posted this issue here, I would request folks who are facing a problem with this please VOTE for this issue with the ffmpeg team so they can fix the base code. Therafter I'll be able to integrate it back into MCEBuddy.

 

https://ffmpeg.org/trac/ffmpeg/ticket/2078

 

Click on Up Vote on the top of the page under the Roadmap button. More votes = faster fix. Add you comments if you'd like to speed it up even more.


Thanks, added my vote.  But question, while this is being woked out, I'm really digging the MCE rename feature, how do I just use this to batch rename and sort shows into folders, with out doing any video processing or commercial removal? 

Coordinator
Jan 13, 2013 at 7:23 PM

I've added a feature only renaming files in 2.3.12, BETA release 01132013. You can get access to it using the EARLY ACCESS program

Jan 13, 2013 at 7:51 PM

Hello Rboy,

Is there a link somewhere on the website how to get access to the new beta version?
I'd love to get 'unsupported flag' fix. I've sent an email to ramitbhalla A T yahoo.com from wvladik A T gmail.com few days ago but did not receive any instructions so i was waiting for web site to instruct how and where to go :-)

Kind regards,
-vladimir 

Coordinator
Jan 13, 2013 at 8:25 PM

See the discussion thread on the EARLY ACCESS program

Jan 13, 2013 at 9:56 PM

To be honest I do not want to hijack this thread but I did read EARLY ACCESS thread and i've done all and more that was described in that thread. Am I being thick or missing something obvious here ?

Coordinator
Jan 13, 2013 at 10:07 PM

Did you send in a request for your login along with your donation details?

Jan 13, 2013 at 10:23 PM

Yes, as stated in my original post.

Jan 27, 2013 at 5:18 AM

I've been keeping an eye on the ticket you created over at ffmpeg.org and have not seen any activity.  Have you heard anything thats in the works for fixing the wtv issue?

Coordinator
Jan 27, 2013 at 1:34 PM

no, maybe some folks can post a request there to help move things along

Mar 8, 2013 at 11:49 PM
I am having exactly the same experiences with wtv described here. Updated count on ffdshow ticket. Have not yet tried to obtain beta version but would be interested in doing so because the new features described would probably do what I need..... 'sheds