Issues since upgrade to release 10 but perhaps unrelated

Nov 30, 2012 at 10:55 PM

Hi all. Great tool.

I had been happily using Build 8 which was working great. I saw the "new version available" line so decided to upgrade. Ever since I did conversions hang forever at remuxing.

Log snippet:

--> 11/29/2012 21:52:10.075 INFO  [util.WtvToMpeg] +0x13 (eng) AC3 2.0 48000 Hz 448 kb/s
--> 11/29/2012 21:52:10.075 INFO  [util.WtvToMpeg] -0x15 MS TV Caption
--> 11/29/2012 21:52:10.075 INFO  [util.WtvToMpeg] +0x14 MPEG-2 MP-HL 1280x720p fps: 60000/1001 AR: 16:9
--> Job cancelled, killing process
ERROR> 2012-11-29T23:36:33 MCEBuddy.RemuxMediaCenter.RemuxMCERecording --> ReMuxxSupp failed
INFORMATION> 2012-11-29T23:36:33 MCEBuddy.RemuxMediaCenter.RemuxMCERecording --> ReMuxing using FFMPEG

It hangs forever unless I cancel which you can see had been a awhile.  I have left it overnight too.  I'm quite sure it's not the shows because they convert just fine on another computer I left at release 8. I uninstalled 10 & put 8 back on but same issue.  I even deleted the backup config file from my profile folder (took awhile to find that) before installing 8 again to see if one of my settings was the issue but that didn't help.  

Any ideas?  I'd love to get converting working on my quad again.  I will say one thing I need to try is rebooting but I've been unable to due to busy processes I can't interrupt.  Also, changed the default path from C to D but not sure that should matter although I had not tried putting back on C. Another thing that has changed is I upgraded media player classic home cinema because playback of mcebuddy converted files were messed up (and it fixed that) so perhaps that is to blame somehow.
Thx
Bill 

Coordinator
Dec 1, 2012 at 1:45 PM

Please post the full log (Attach it, don't copy paste it). Part lines cannot help debug the isssue.

 

Is your priority set to Low? If so that can explain why it's running slow.

How large is your file to be converted? You had mentioned that there is some other stuff going on the computer - is that CPU or Disk intensive?

 

Since you're already tried reinstalling v8 with no difference I suspect it's some background process which is consuming resources and slowing down MCEBuddy. WTVtoMpeg is a VERY disk intensive process, so a loss in disk or IO performance will degrade MCEBuddy performance.

Try to set the priority to normal or high if not reboot the computer. FYI, v10 is definitely faster than v8 on the benchmark tests.

Dec 1, 2012 at 2:04 PM
Edited Dec 1, 2012 at 2:13 PM

Hi rboy1,
I'm running a conversion again & will post up the full log after I let it run for a few hours but here are some of your answers:

Priority was set to Normal. I have it set to High now as a test.  The other things running are not cpu or disk intensive, they just can't be interrupted.  As a matter of fact before I cancelled I checked task manager & almost everything as near idle, all 4 cores near idle.  There was not even a MCEBuddy-related task running above 0% cpu.  Is partly why I cancelled the process & posted up just the log snippet. There had been no MCEBuddy-related task busy for hours.  (ShowAnyalyzerMaster.exe was the last thing I saw busy but it goes idle once the ts is put in the working folder. MCE.BuddyService.exe is idle & so is the GUI. I do not see a task named WTVtoMpeg or anything near it.)

The file being converted is just over 2GB but you'll see the exact size in the log once it completes.

I'll let it run awhile to ensure I'm not interrupting any actual progress but as noted it appeared it was doing nothing & just stuck.
Thx
Bill 

Edit: Sorry I looked again it's actually RemuxSupp.exe that was consuming a lot of CPU but then goes idle.  It's idle now as are all processes & just waiting for awhile before I cancel to ensure it's not actually making any progress.  I see no new files in the working folder & no noticeable HDD activity sounds or LED.

Dec 1, 2012 at 4:39 PM

rboy1. I didn't see a way to attach to discussion so I created a new issue & attached complete log file & a screenshot of task manager to show cpu usage before cancelling MCEBuddy.
Thx
Bill 

Coordinator
Dec 1, 2012 at 7:24 PM

I understand, CodePlex has limitation, you can upload the log file to the MCEBuddy server and post he name of the log file here

Dec 1, 2012 at 9:26 PM

no problem just wasn't sure if I was missing something lol.  i ended up creating a new issue tracker entry & attached there but I can upload if that's easier.  I attached a screenshot of task manager too showing there was hardly any use on any of the 4 cores.

Dec 2, 2012 at 8:13 PM

Just thought I'd contribute in that I am having similar issues.  The hang, however, does progress for me although significantly slow.  Priority is Normal. Original file size is ~9G.  I'm converting WTV to MP4.  The system is really only running this process so there is little if any other CPU or disk usage.  I'll try and upload a log at my first opportunity.

Coordinator
Dec 3, 2012 at 1:19 AM

9GB will take some time and it depends on your IO speed. RemuxSupp is IO intensive. Are you using a network or USB disk?

is there an antivirus installed? All these impact hte speed of disk IO

Dec 3, 2012 at 4:06 AM

So rebooting solved my problem at least with getting build 8 working again.  My quad rolled right thru converting the exact same files that failed (even the one I showed log for) without changing anything, just rebooting.  I'll upgrade to build 10 & test again including a reboot if it hangs during conversion & report back.
Bill 

Coordinator
Dec 3, 2012 at 5:53 AM

don't ya just love windows...

Dec 3, 2012 at 1:56 PM

umm yeah I love gettin bit by such a n00b thing. especially when i even told myself I should reboot to test but held off because I had stuff that couldn't be interrupted.  The real kicker is I upgraded to build 10 without rebooting and it still works! What is that saying about doing the same thing over & over again expecting different results?  Yup i'm insane. lol  

The only thing I can think of different this time was I upgraded media player classic between build 8 & 10 without rebooting.  granted i often go few months without rebooting and all kinds of things go in & out on it but like I said build 8 had been working, I upgraded to 10 (uninstalled 8, then installed 10) and no workie. Same this time but workie. Go figure! lol

Guess it serves to remind people to reboot if sh!# doesn't work right and there is a CHANCE upgrading MPC between without rebooting caused it.

Sorry for wasting your time on this rboy1. ;(
Thx
Bill 

Dec 4, 2012 at 9:31 PM

Then 9GB took about 2 days to "complete".  No errors were reported but the file was not intact on completion.

I did this test on a single hard drive (which I know is not optimal) but figured it was one of the cleanest ways to test.  I'll bang around a few other files as time permits and report back.  As this is an HTPC I don't have any antivirus running.  Windows Defender is likely running in the background but I'd have to check to be certain.

Coordinator
Dec 4, 2012 at 11:06 PM

That's 2 long, my "laptop" iCore7 with 4GB ram it takes a few hours to finish using the MP4 Normal profile, High quality can be 50% more time but 2 days, something is hogging your resources.