Video unwanted resized from 16:9 to 4:3

Dec 4, 2012 at 5:05 AM

I've been playing with MCEBuddy 2.3 for a while now. I believe this allows me to convert .wtv files to a format that can be read using a Windows RT device.

If I convert a full HD file all seems well, but as soon as I convert a SD file it seems to convert from 16:9 to 4:3. The width of the converted file seems completely off. What setting can be used to change this? I tried changing the "maximum width" value, but that doesn't help.

Another, less important, question: while conversion is running I can add one file. How can I add single files rather than converting everything in a folder without a running conversion process?

Dec 4, 2012 at 5:35 AM

I've not used MCEBuddy a ton but did you try checking "disable cropping" under conversion task settings? (Hit the advanced button to show them after selecting the task & hitting change.)

To convert single files you click Add on main screen then browse & select the file but sounds like you found that already.  Not sure you can select a file if you have existing conversions waiting in the monitor folder..  Think you'd need to change our monitor path temporarily but I could be wrong.
Bill 

Dec 4, 2012 at 7:56 AM

I did a quick test this morning, but it doesn't seem to solve the issue. It must be something that can be fixed by changing a setting that I am missing otherwise definitely more people would be complaining about it! ;)

Apart from that it looks good and this app is definitely paving the way to a Windows RT tablet for me!

Coordinator
Dec 4, 2012 at 1:43 PM
Edited Dec 4, 2012 at 1:46 PM

Can you upload your log file to the mcebuddy server

 

to add to @Bill48105, you can also drag and drop the file(s) into the MCEBuddy status screen you want to convert manually.

Dec 4, 2012 at 1:49 PM

I'll do that as soon as I get home. There is probably a link in the tool to upload the log file...right?

I read the manual today and I saw the possibility to drag and drop files in the status screen to convert them manually. I. thought I already tried that this morning, but I will definitely give it another shot!

Coordinator
Dec 4, 2012 at 2:15 PM

Please check the REad this before Posting discussion thread to get the details for the server

Coordinator
Dec 4, 2012 at 2:28 PM

I had a question - when you say converted from SD file, SD files are inherently in 4:3 formats with black bars on the sides when displaying on a 16:9 screen.

Maybe you can upload the original video as well to teh server.

Dec 4, 2012 at 8:14 PM
Edited Dec 4, 2012 at 8:14 PM

The drag and drop works. Thanks!

I've checked the media info of the two files. The HD one has a width of 1280 and the SD one has a width of 720. So, that must be the explanation.

But still, if I watch the SD one using Windows Media Center or Windows Media Player before converting it is shown as wide screen 16:9. How is that done? Is there a way to maintain that aspect ratio, because the 4:3 just seems wrong!

The files are currently being uploaded (check folder "Plantje - Aspect ratio issue" for these). Thanks a lot for all cooperation so far!

Coordinator
Dec 4, 2012 at 10:50 PM

No need to upload the file, you've found the answer.

 

Regarding forcing the aspect ration, depending up onthe profile you're using (ffmpeg, mencoder or handbrake) you can modify the <encoder>-video (e.g. ffmpeg-video) section to for the aspect ratio. You'll have do some research on this. E.g with ffmpeg you can use a combination of -aspect 16:9, setsar and setdar to achieve this.

NOTE: If profile is using LibXvid codec with ffmpeg, MCEBuddy will overwrite the SAR settings to to ensure compatibility with the codec.

Dec 5, 2012 at 4:47 AM
Edited Dec 5, 2012 at 4:50 AM

Hmmm.... ok... I saw some people mentioning these profiles.

I've found the profiles.conf as well. Where can I find what the different options for this encoder are? Right now I just added -aspect 16:9, but that doesn't work. Euh...found that as well: http://ffmpeg.org/ffmpeg.html#AVOptions

I'll go and fiddle around with that a little bit.

Coordinator
Dec 5, 2012 at 5:00 AM

Google FFMPEG Documenattion. You need to be sure you're applying it to teh correct profile at the correct line

Dec 5, 2012 at 5:58 PM
Edited Dec 5, 2012 at 6:03 PM

Haha! I've been looking at the ffmpeg all the time, but in the end I just needed to make a change to the mencoder settings! I added -vf scale=1280:720 and now everything is just fine!

Thanks for your help!

As soon as I have things up and running on my mediacenter machine I will definitely remember to donate some money! Keep up the good work!

Edit: for the SD stuff that is. The HD stuff now just goes black. I'll just need to fiddle around with it a little more.