This project has moved. For the latest updates, please go here.

Application: MCEBuddy.Service.exe Description: The process was terminated due to an unhandled exception.

Dec 13, 2012 at 1:03 PM
Edited Dec 13, 2012 at 1:26 PM

Hello talented ones.

Started with fresh Windows 8 Pro with Media Centre 64bit system that also has Shark007 Win8 Codecs installed including 64bit components.

Installed MCEBuddy 2.3.10 32bit (I didn’t see the 64bit version below it.. doh!) but when prompted with option to install Haali Media Splitter I declined in case it messed with Shark007 stuff.

Changed MCEBuddy profile to ‘TS from WTV’ including comskip option, outputting to C:\Users\Public\Videos.

Attempted processing WTV file, but processing/MCEBuddy service crashes during ‘analyzing video info’ just after successful comskip processing.

Uploaded debug files to ftp://mcebuddy.dyndns.org/mcebuddy/tmr0#1

Read the forums and realised there is a 64bit version of MCEBuddy.

Uninstalled MCEBuddy 2.3.10 32bit.

Performed clean install of MCEBuddy 2.3.10 64bit as per directions.

Made the same profile changes as above.

Processing same WTV file failed as above.

Uploaded debug files to ftp://mcebuddy.dyndns.org/mcebuddy/tmr0#2

Changed profile to ‘MP4 Normal’ with comskip.

Same WTV file processed successfully to MP4 (although it didn’t remove any of the advertisements).

Read more forums and noted similar problem https://mcebuddy2x.codeplex.com/discussions/406111

Followed advice from forum, removing some contents from RemuxSupp folder to force use of ffmpeg.

Changed profile to ‘TS from WTV’ with ShowAnalyzer.

Processing same WTV file failed as above.

Uploaded debug files to ftp://mcebuddy.dyndns.org/mcebuddy/tmr0#3

Note that sample WTV and TS files uploaded were created using Shark007 create sample function.

Hope this info helps.

Any other suggestions?

Kind Regards,

Troy

Coordinator
Dec 13, 2012 at 2:37 PM
Edited Dec 13, 2012 at 2:38 PM

I went through you log files, it's crashing while trying to read profiles.conf

There is a bug in the TS from WTV/DVRMS/TS profile

 

Open the file profiles.conf (in the config directory) and replace the profile with this and it should start working. I'll fix it in the next release.

 

[TS from WTV/DVRMS/TS]

Description=Use this to copy the WTV/DVRMS files to TS format and to remove commercials from your TS videos. It does not recode the video and is very sensitive to errors in the video. CAUTION: Creates very large files

order=copy

copy-ext=.ts

copy-audiodelay=skip

FixedResolution=true

SkipCropping=true

 

regarding not removing commercials, do you have Skip Ad Removal checked in the Conversion Task GUI page?

Dec 14, 2012 at 7:58 AM

Thank you - that solved it.