This project has moved. For the latest updates, please go here.

All conversions stopped outputting audio

Dec 21, 2012 at 2:03 AM

I'm not sure when it happened except that it was sometime after the 2.3.10 upgrade. All the recordings that now convert are missing all audio. If I watch the original recording it has audio, and the conversions were working fine up to some point. I'm not exactly sure when the problem started, except that it has been a few weeks (I don't always watch the shows right away so it took me some time to realize there was a problem).

I am using the MP4 conversion of WTV files. I have been generally upgrading when new releases came out. I am tempted to go back to 2.3.9 to see if that fixes things, but I would rather just get things to work.

I'm not exactly sure what information or logs you would want to see to help. I am running on Windows 8 Pro with the Media Center package (64-bit). I am recording from a HDHomerun box with a cablecard (and used this configuration to record many shows and have them converted without problems). I don't see many long time logs, but I can upload them along with anything else that may be considered useful.

 

Thank you for your help

Brian

Coordinator
Dec 21, 2012 at 5:34 AM

You can start by uploading the conversion log file, it will give me all the information I need to get started. If possible upload the original video.

2.3.9 and 2.3.10 are the same from a conversion standpoint. If you're going to downgrade try 2.3.8 when ffmpeg was updated and could be the possible culprit.

Dec 21, 2012 at 11:48 AM

Here is a link to the file:

https://www.box.com/s/bebyhqdx66bcimqphkqu

It was 37M and I didn't see a way to attach here (I'm new to codeplex forums).

I'll try downgrading tonight and see if that fixes anything.

Thanks

Brian

Coordinator
Dec 21, 2012 at 2:23 PM

Okay I think you've run into the ffmpeg bug in 2.3.10 which has been fixed in 2.3.11

 

Try this, open profiles.conf in the mcebuddy installation directory (under the config directory). In the section MP4 Normal (which is the profile you're using). under the line ffmpeg-video, remove the -ss 3

 

 

It should fix your problem.

Coordinator
Dec 21, 2012 at 2:28 PM

Of MOST importantatly, DON'T use TRIM in 2.3.10 - it's broken because of the ffmpeg bug - that the reason you're getting the no audio.

Disable Start and End trim in 2.3.10 - again this has been fixed in 2.3.11

Dec 22, 2012 at 12:14 AM

Thanks. I have made the adjustments now to 2.3.10 and am trying them now. I will let you know what happens.

Brian

Coordinator
Dec 23, 2012 at 3:34 PM

All Audio issue have been fixed in 2.3.11

Jan 18, 2013 at 11:13 AM

Hmm... I'm using v2.3.11 and I seem to randomly suffer from videos without audio... I've managed to capture a WTV file where audio is working, and have an avi without audio that was created, along with the conversion log. I've uploaded the log to:

https://www.box.com/s/0ymxqx3nxqajdlsnd6v1

 

Coordinator
Jan 18, 2013 at 2:34 PM

That's because your video has a 0 channel audio track being reported:

-->     Stream #0:0[0x100](eng): Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16p (hearing impaired)

 

I will need need a copy of your original WTV file to fix this. Can you upload it the WTV file to the FTP server:

FTP: mcebuddy.dyndns.org

login: mcebuddy

password: mcebuddy

Jan 18, 2013 at 3:30 PM

Hi rboy1,

Thanks for the fast reply,

I've realised for the example conversion log I sent through I'd tidied the wtv file dammit. Luckily I have another example of a resultant avi with no audio which I've checked the conversion log for and it reports the same line you mention... I've uploaded the different logfile to the ftp site as:

The Adventures of Abney and Teal_CBeebies_2013_01_03_17_55_00.wtv-Convert to AVI-2013-01-04T21-18-05.3101000+00-00.rar

and am in the process of uploading the wtv in a rar archive as well... Apologies, but my upload speed isn't great and the file is approximately 445MB, so I'd expect the file to be uploaded (Filezilla reports) in the next hour or two.

[412772]AllConversionsStoppedOutputtingAudio.rar

Let me know if you need anything else... I'm not sure if you need the avi.

As I mentioned, my problem isn't happening every time, I get perhaps one in three files with no audio which is frustrating.

Nav

Jan 18, 2013 at 4:36 PM

Just to let you know, the upload is complete

Nav

Coordinator
Jan 19, 2013 at 11:31 PM

Okay couple of things:

 

1. the video has a 0 channel audio track, ie an audio track with no audio, which is kinda messing things up - you need to investigate why MCE is recording a zero hannel audio track

2. I've put a fix for this with the 01192013 BETA release of MCEBuddy which you can access via early release program. However this is a SLOW fix.

 

There is a faster way to fix this too but you need to be aware that the fast fix will  work if ALL your videos have the same issue, i.e. the audio channel layout is identical, ie 2 audio tracks, 1st audio track is a zero channel audio track (imparied) and the second one is a actual track OR if all your other videos are working using Fast Remuxing. Here is out how to try it and see if works:

Open mcebuddy.conf

After this line:

CopyRemux0=-vcodec copy -acodec copy -map 0:a -map 0:v -f mpegts

Add this line:

CopyRemux1=-vcodec copy -acodec copy -map 0:a:1 -map 0:v -f mpegt

 

What this does is that the regular remuxing fails (CopyRemux0), the next line CopyRemux1, it tells MCEBuddy to try to remux using the 2nd audio track (-map 0:a:1, the :1 after the 0:a refers to the 2nd audio track where as a :0 would refer to the 1st audio track), which the correct audio track in case of this corrupted video.

How this will impact videos with other audio track layouts I cannot predict, it or may not work depending upon the configuration because CopyRemux0 will first run on the other WTv's and will fail on this file, after which CopyRemux1 will run.

So a 99% chance if you add the CopyRemux1 line EVERYthing will work OK if your other videos are working fine, but then again you can only confirm after trying it. AGain, this is just to speed things up. If you use the latest BETA it should work out of the box

Coordinator
Jan 20, 2013 at 5:38 PM

Okay here's a better fix that will work with ALL files, I will make this permanent in the next release but you can do this. Ignore that's on top.

 

Open mcebuddy.conf

 

Replace

CopyRemux0=-vcodec copy -acodec copy -map 0:a -map 0:v -f mpegts

with

CopyRemux0=-probesize 100M -analyzeduration 300M -i <source> -vcodec copy -acodec copy -map 0:a -map 0:v -f mpegts

 

It will solve your problem. The issue is that your audio stream is corrupted and hence it's confusing ffmpeg, the answer above is the analyze the file for a longer duration till a better more accurate determination is done, which fixes the issue. You'll have fast and accurate conversion.

Again, use the latest BETA version, I have not tested this with 2.3.11

Coordinator
Feb 2, 2013 at 6:43 AM
I'm going to fix this impaired audio issue in the next release. However here is how it will work, WHEN and IF you select an Audio Language in the conversion task settings, MCEBuddy will prefer a non-impaired audio track over an impaired audio track.
However this will only work when an audio language is selected, so right click on the file, select MediaInfo and find the language if you want MCEBuddy to skip over impaired tracks here possible. (some file may have both tracks impaired, in which it will choose the audio track with the most channels in it)
Refer to the documentation -> common issues for more details.