WTV to MP4 audio sync issues

Jan 30, 2013 at 6:03 AM

Hi,  I just started using MCEBuddy 2.3 release 11 and it is very impressive.  I have some questions.

I have many SD and HD WTV files (unprotected cable recording) that I want to convert to an ipod touch compatible low profile/complexity MPEG 4 file.  I am currently NOT cutting out commercials.  Which profiles are best for this?
 I have tried the iPhone profile (with mencoder) and [M4V Apple Normal] profiles (with handbrake), but both have generated output files that have audio sync issues.  Again I am not cutting commercials and the source files do not appear to have any audio sync issues.  The audio always appears behind the video by a second or less. It's enough to be annoying.
 Does handbrake support the -ss 10 setting, like "handbrake-video=-ss 10"?  It didn't seem to work.
 Which encoders (mencoder, ffmpeg, or handbrake) handle audio sync the best?  I have been reading in the forums about settings like "ffmpeg-general=-async 1".

I am now trying to encode using a modified iPhone profile that uses ffmpeg instead of mencoder (with order=ffmpeg,mencoder).  It has "ffmpeg-general=-async 1", "ffmpeg-video=-ss 30", "ffmpeg-audiodelay=skip", and  "2ChannelAudio=true".   I'm hoping it works better than the default iPhone profile does.

Thank you.

-Chuck


Coordinator
Jan 30, 2013 at 1:16 PM

I would suggest you use the latest BETA releases which have fixed a few audio sync issues

Coordinator
Jan 30, 2013 at 1:41 PM

alos try the -async 1 option, it helps sometimes but only when the audio is "shifted", if it's progressively out of sync you need to let me konw

Jan 30, 2013 at 8:31 PM
I have tested 3 videos so far and have had very good results with my modified iPhone profile - "ffmpeg-general=-async 1", "ffmpeg-video=-ss 30", "ffmpeg-audiodelay=skip". I'm still using 2.3 release 11 and haven't switched to the BETA yet. Before the audio was always shifted, but now it seems correct. I have never seen audio going progressively out of sync with MCEBuddy (yet). Tonight I will try to reduce -ss 30 to -ss 10 and encode more samples. What is a good number in your opinion? Do handbrake and mencoder also support the -ss 10 and xxx-audiodelay=skip options?

Thank you.
Coordinator
Jan 30, 2013 at 9:17 PM
it really depends on how much corrupted video there is 10 should be good or maybe 15.

Mencoder supports
-ss 10

Handbrake uses the parameter
--start-at duration:10
Coordinator
Jan 30, 2013 at 9:18 PM
cmoidel wrote:
I have tested 3 videos so far and have had very good results with my modified iPhone profile - "ffmpeg-general=-async 1", "ffmpeg-video=-ss 30", "ffmpeg-audiodelay=skip". I'm still using 2.3 release 11 and haven't switched to the BETA yet. Before the audio was always shifted, but now it seems correct. I have never seen audio going progressively out of sync with MCEBuddy (yet). Tonight I will try to reduce -ss 30 to -ss 10 and encode more samples. What is a good number in your opinion? Do handbrake and mencoder also support the -ss 10 and xxx-audiodelay=skip options?

Thank you.
You should post your entire profiles for other to see also
Jan 31, 2013 at 2:21 AM
This is the profile that I am using with version 2.3 release 11. It is slow since it uses 2-pass, but the quality is good and the audio sync is perfect. It is 99% the normal iPhone profile. The generated MP4 files work on an ipod touch and multiple android devices with software decoding (through MPlayer or MoboPlayer).

[iPhone Chuck1]
Description=iPhone compatible (H.264 MP4 height 480 pixel video and AAC stereo audio).
2pass=true
order=ffmpeg,mencoder
mencoder-general=-ss 15 -vf pullup,softskip,pp=fd,scale=480:-2,hqdn3d,harddup
mencoder-video=-ovc x264 -x264encopts bitrate=800:subq=6:subme=7:frameref=6:qcomp=0.8:b_pyramid=strict:weight_b=yes:me=umh:partitions=p8x8,i4x4:nodct_decimate=yes:trellis=1:direct_pred=auto:level_idc=30:nocabac=yes:threads=auto
mencoder-audio=-oac faac -faacopts br=128:mpeg=4:tns=yes:object=2
mencoder-audioac3=-oac faac -faacopts br=128:mpeg=4:tns=yes:object=2
mencoder-ext=.avi
mencoder-remuxto=.mp4
mencoder-audiodelay=skip
ffmpeg-general=-async 1 -threads 0
ffmpeg-video=-ss 15 -vf yadif=0:-1,hqdn3d,crop=iw:ih:0:0,scale=480:trunc(480/dar/2)*2 -vcodec libx264 -b 800k -x264opts ref=6:subq=6:subme=7:qcomp=0.8:b-pyramid=strict:no-weightb=0:me=umh:direct=auto:level=3:partitions=p8x8i4x4:no-cabac=1:trellis=1:no-dct-decimate=1:threads=auto
ffmpeg-audio=-acodec libvo_aacenc -ab 192k
ffmpeg-audioac3=-acodec libvo_aacenc -ab 192k
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
2ChannelAudio=true
FixedResolution=true