File name matching

Feb 3, 2013 at 6:38 PM
I am trying to create two profiles. One that only renames h264 .wtv files and one that converts mpeg2 .wtv files.

Is there a way to set this? Because the formatting of the recordings I process have "HD" in the middle of the name, not at the end, or beginning like explained in the manual.

How can I get MCEBuddy to search the whole name for "HD". Or the windows detailed info: HDTV?
Coordinator
Feb 4, 2013 at 1:17 AM
you can do what one of the other users is doing, use the <encoder>-unsupported option in the profile, e.g. if you want a profile not to process h264 in WTV you can set <encoder>-unsupported=h264+wtv

Searching the name of HD can be done as HD
Marked as answer by rboy1 on 3/29/2014 at 2:45 AM
Feb 4, 2013 at 3:29 PM
I am trying to get this to work using the profile: TS Unprocessed. So I can only process my MPEG2 recordings and Leave h264 until you implement the ffmpeg fixes.

I have tried:

copy-unsupported=h264+wtv
ffmpeg-unsupported=h264+wtv

Just
copy-unsupported=h264+wtv

and just
ffmpeg-unsupported=h264+wtv

None of these work, still my HD recordings remux.

Here is the full profile:

[TS Unprocessed]
Description=Use this to copy the WTV/DVRMS files to TS format and to remove commercials from your TS videos. It does not remove black bars, resize the video, deinterlace or select audio language. Use this if you have HD recordings which don't need processing.
order=copy,ffmpeg
copy-unsupported=h264+wtv
ffmpeg-unsupported=h264+wtv
copy-ext=.ts
copy-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-vcodec copy -f mpegts -map 0:a -map 0:v
ffmpeg-audio=-acodec copy
ffmpeg-audioac3=-acodec copy
ffmpeg-ext=.ts
ffmpeg-audiodelay=skip
FixedResolution=true
SkipCropping=true
Coordinator
Feb 4, 2013 at 5:33 PM
check the video codec in the logs, I think in your video is yuv2 or something like that not h264. in which case it should be yuv2+wtv
Feb 4, 2013 at 5:56 PM
Edited Feb 4, 2013 at 6:51 PM
Stream #0:1[0x62]: Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 10000k tbn, 50 tbc

2013-02-04T15:35:17 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Video codec = h264
Coordinator
Feb 4, 2013 at 8:33 PM
Upload the log file to the mcebuddy server where the unsupported is not working.
Feb 4, 2013 at 8:42 PM
Edited Feb 4, 2013 at 8:49 PM
Tested with the file already up:
Great British Railway Journeys_BBC HD_2013_01_29_18_31_49.wtv.chunk001

The log shows i cancelled once it went in to slow remuxing.
Coordinator
Feb 4, 2013 at 9:59 PM
Double check your profile. They profile you're using

It works fine:

INFORMATION> 2013-02-05T04:54:20 MCEBuddy.Transcode.ConvertWithCopy --> Checking for Unsupported profile for container / codec combination
WARNING> 2013-02-05T04:55:33 MCEBuddy.Transcode.ConvertWithCopy --> Unsupported profile for container / codec combination wtv+h264 TS Unprocessed
INFORMATION> 2013-02-05T04:55:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> Checking for Unsupported profile for container / codec combination
WARNING> 2013-02-05T04:55:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> Unsupported profile for container / codec combination wtv+h264 TS Unprocessed
ERROR> 2013-02-05T04:55:59 MCEBuddy.Transcode.Convert --> Unsupported FFMpeg file formats
ERROR> 2013-02-05T04:55:59 MCEBuddy.Transcode.Convert --> Unable to convert file Great British Railway Journeys_BBC HD_2013_01_29_18_31_49.ts using profile TS Unprocessed
ERROR> 2013-02-05T04:55:59 MCEBuddy.Engine.ConversionJob --> Conversion failed

The unsupported will ONLY kick in during the conversion stage, not during remuxing.

That's because the unsupported can be used in multiple ways:

eg. you may want to use the copy converter for only h264+wtv and then use ffmpeg to convert the rest to h264 in which case it would look like
copy-unsupported=h264+wtv
ffmpeg-video = convert line to h264 video
ffmpeg-unsupported=mpeg2video+wtv
Feb 4, 2013 at 10:04 PM
Edited Feb 4, 2013 at 10:17 PM
So if I use the unsupported tag, at which point will my profile to just convert names kick in? Since I have that set to look for : HD

Hmm if i have to wait for each to slow remux, about 20 mins or so on average, then its faster for me just to add the mpeg files manually I think.

I wish there was an option to just skip it. Oh well, hopefully this will only be a problem until you fix the latest ffmpeg.
Coordinator
Feb 4, 2013 at 11:21 PM
if you're using the rename only option then no it won't work since teh unsupported tag is analyzed during the conversion stage
Feb 4, 2013 at 11:26 PM
So can I set it up so it avoids converting files with HD in and that job is passed to a different profile to just rename?
Coordinator
Feb 4, 2013 at 11:28 PM
There are many ways to do it, you can use the Showname filter, the filename filter or the unsupported option. your choice on how you want to configure it.
Feb 4, 2013 at 11:31 PM
But you just said the unsupported option doesn't work for rename only?

How can I set it up so it renames the h264 files and converts the mpeg2 ones?
Coordinator
Feb 5, 2013 at 12:22 AM
Go through the documentation, open Conversion Tasks and see the availble options.
Feb 5, 2013 at 12:31 AM
I tried using the file name option to exclude files with hd but didn't succeed.

What should I be using?

*.wtv;~HD because that doesn't work, presuming of course it happens before the remux?
Coordinator
Feb 5, 2013 at 12:42 AM
Read the documentation and common issues to understand how to use the features, you're not using them correctly
Feb 5, 2013 at 1:20 AM
The documentation states using only text that appears at the beginning of a filename. Will it look at the complete filename? I ask because I already have been through the documentation and common issues and haven't been able to get it to work. Sorry to be a pain. Your with and support on here is marvelous :-)
Coordinator
Feb 5, 2013 at 1:59 AM
Edited Feb 5, 2013 at 2:00 AM
you're not being very clear on how you want to segment your conversions.

if you're looking at filtering by filenames (assuming the word HD comes in a filename) then setup 2 conversion tasks
1. Filename Filter -> *.wtv;~*HD*
2. Filename filter -> *HD*.wtv
Filename and showname filters come before remuxing, unsupported comes during conversion
Marked as answer by rboy1 on 3/29/2014 at 2:45 AM
Feb 5, 2013 at 12:30 PM
Thanks, you were right I was using the filter on my renaming to include HD wrongly! Works like a charm and looking forward to being able to switch my renaming profile to a h264 stream copy one as soon as the fixes are available:)
Feb 6, 2013 at 9:00 PM
hi,


The special pattern characters are:
?             Any
*             Closure
[abc]         Set
[a-z]         Range set
[!abc]        Excluded set
\x            Quoted character (Unix only)
`x            Quoted character (DOS and Windows only)
!pat          Not
The Any pattern ? matches any single character (including dot).

find more details click here
Coordinator
Feb 6, 2013 at 9:16 PM
For advanced users you can also use regex expressions by prefacing the pattern with regex:
Marked as answer by rboy1 on 3/29/2014 at 2:45 AM