Read the FAQ, still no audio when converting Nikon .mov files

Mar 27, 2013 at 6:49 PM
I read the FAQ pertaining to this issue and did a search on the word "audio" to no avail.

I am trying to convert .mov files produced by a Nikon D7000 DSLR to mp4 files to be viewed on a Sony Blu-ray smart player. The converted file has the video, but no audio. I can play the original .mov file on my PC and there is audio. I have found this issue addressed in one of the FAQ's and think I have set up the conversion corrrectly. The audio information window says there is one audio channel with the language "English (eng)". In the "Advanced Settings" section of MCEBuddy Settings I have set the Locale to "English (United States)", the only setting I could find that relates to language. Any idea why there is no audio in the converted file?

Thanks
Coordinator
Mar 27, 2013 at 6:58 PM
post your conversion log


On Wed, Mar 27, 2013 at 2:49 PM, bmarsolais <notifications@codeplex.com> wrote:

From: bmarsolais

I read the FAQ pertaining to this issue and did a search on the word "audio" to no avail.

I am trying to convert .mov files produced by a Nikon D7000 DSLR to mp4 files to be viewed on a Sony Blu-ray smart player. The converted file has the video, but no audio. I can play the original .mov file on my PC and there is audio. I have found this issue addressed in one of the FAQ's and think I have set up the conversion corrrectly. The audio information window says there is one audio channel with the language "English (eng)". In the "Advanced Settings" section of MCEBuddy Settings I have set the Locale to "English (United States)", the only setting I could find that relates to language. Any idea why there is no audio in the converted file?

Thanks

Read the full discussion online.

To add a post to this discussion, reply to this email (mcebuddy2x@discussions.codeplex.com)

To start a new discussion for this project, email mcebuddy2x@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 28, 2013 at 5:20 AM
Edited Mar 28, 2013 at 5:59 AM
Sorry to seem so dumb, but I don't see on the webpage how to attach a file. Instead I created a new directory on the mcebuddy ftp site under "New directory" called "bmarsolais". I then copied the log file and .mov file into it. I hope that's okay.
Coordinator
Mar 28, 2013 at 1:11 PM
not a dumb quetsion - you can't attach here you'll need to upload a 3prd party website like mediafire and post the link here or upload to the mcebuddy ftp server
Mar 28, 2013 at 3:06 PM
You'll find the log file and the .mov video on the mcebuddy FTP site under \New directory\bmarsolais.
Coordinator
Mar 30, 2013 at 12:02 PM
I've repicated the issue and unfortunatley there's not much that can be done here. The MOV file is a malformed/corrupted H264 A+V file and ffmpeg is not able to parse it correctly and is losing the audio track in the conversion.

Sorry.
Coordinator
Mar 30, 2013 at 12:04 PM
Let me take that back slightly, it's not corrupted, it's unsupported combonation of PCM audio and H264 video that's throwing off ffmpeg. I'll come back with a temporary fix for you
Coordinator
Mar 30, 2013 at 12:36 PM
Okay I've put a patch for handling non standard audiovideo codec combinations.

Download the latest BETA build 03302013 (will be available in a few hours) for the fix.
Mar 31, 2013 at 5:19 PM
rboy1 wrote:
Okay I've put a patch for handling non standard audiovideo codec combinations.

Download the latest BETA build 03302013 (will be available in a few hours) for the fix.
Thank you for your work. I browsed through the ftp site and did not find the beta build. Am I missing something?
Mar 31, 2013 at 5:20 PM
Also, I have not received my Premium support login info. Is that the problem with not finding the beta download?

Thanks again
Coordinator
Mar 31, 2013 at 5:57 PM
Send me your donation details again. The new beta is not loaded yet. Some more testing under way

Coordinator
Apr 1, 2013 at 12:47 AM
There is a new parameter I've added to MCEBuddy.conf called SubtitleSegmentOffset

see the documentation on how to use it, you can tweak this parameter to correct the progressive sync issues. I think a value of 4.5 should work for you, but in the new build you can play with it.


Coordinator
Apr 1, 2013 at 12:56 AM
sorry wrong thread!


Apr 2, 2013 at 1:49 PM
Thank you. The 2.3.12 beta fixed the problem. I'm sure other Nikon users have the same problem. I'm going to direct them to MCEBuddy.