Losing 5.1 in WTV -> MP4 conversions

Jun 21, 2013 at 1:54 AM
Edited Jun 21, 2013 at 1:55 AM
I've tried both of the different commercial removal tools, I've checked the 'multichannel' box, and I've set the language to English (from a note in the beta changelog). I also tried customizing some of the ffmpeg/mencoder/handbrake options in the profile to make sure they all had 6 channels selected. No matter what I do, it gets dropped to 2 channels.

One thing I noticed is that using Comskip, this is what the log shows:

2013-06-17T09:35:25 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Audio channels = 2

When I switched to ShowAnalyzer, I get this:

2013-06-19T09:05:11 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Audio channels = 6

But at the end it becomes:

2013-06-19T10:38:33 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Audio channels = 2
Coordinator
Jun 21, 2013 at 12:48 PM
Post the conversion log.
Jun 21, 2013 at 1:31 PM
Edited Jun 21, 2013 at 1:31 PM
All of these logs are 30MB+, some are 55MB+.
Coordinator
Jun 21, 2013 at 11:07 PM
Yes I know. You can zip them to 5mb and post them on any file hosting site and post the link or upload it to the mcebuddy server. Without Logs I can't do much.

Jun 22, 2013 at 12:30 AM
Ok, just making sure that was expected.

http://www.mediafire.com/download/cqg847mz5tmolgk/log.zip

That should have a log from each of the two commercial skip applications
Coordinator
Jun 25, 2013 at 12:49 AM
This is like comparing Apple and Oranges, the 2 log files you've given are converting 2 different files.

Comskip -> Source File -> \192.168.2.45\RecordedTV\conversions\Counting Cars_HSTRYHD_2013_04_30_20_30_00.mp4
ShowAnalyzer -> Source File -> \192.168.2.45\RecordedTV\Counting Cars_HSTRYHD_2013_05_07_19_58_00.wtv

The 1st file has 2 audio channels and the 2nd has 6 audio channels.

For the ShowAnalyzer log, which I assume if the correct file you're running an old version of MCEBuddy which has some known issues with AAC and multi-channel audio. I.e. 2.3.12 does not support AAC with multie channel audio which has been docuemnted.

This has been fixed in the 2.3.13 BETA, so update and your problems should go away.
Jun 25, 2013 at 1:16 AM
When is .13 coming out of beta?
Coordinator
Jun 25, 2013 at 1:29 AM
I wouldn't hold my breath.


Jun 25, 2013 at 1:41 AM
That's...amazing. And ridiculous.
Jun 25, 2013 at 3:35 PM
this is happening to me too, even on the beta with the MP4 Fast Profile and the multichannel option checked. I right clicked on the file while it was in the queue and the media info showed 6 channels, I have never been able to get multichannel audio to work
Coordinator
Jun 25, 2013 at 3:41 PM
Post your log file. Guys have said it a Million time I can not do anything without seeing what's going on in the log files. Each case is different.

Jun 25, 2013 at 3:57 PM
Edited Jun 25, 2013 at 8:06 PM
see below
Coordinator
Jun 25, 2013 at 6:45 PM
this is incomplete, upload the log file to mediafire.com and post the link here.
Jun 25, 2013 at 8:05 PM
I tried both comskip and showanalyzer, same results



http://www.mediafire.com/?aquub318e0ovdpy

and

http://www.mediafire.com/?wyd029dxgdmss9v
Jun 26, 2013 at 5:37 PM
were they complete this time?
Coordinator
Jun 26, 2013 at 8:17 PM
yes got it and found the problem.

Handbrake by default (-6 auto) will downmix the 6 channel audio to stereo audio for AAC audio. The isssue is the profile is saying -6 auto for aac audio hence hte issue.

There are 3 options you have to fix this:
  1. I've fixes the issue with the latest build 06262013 (including fix to engine and profile.conf)
  2. You can hardcode the fix in older versions if you have handbrake 0.9.9, then replace -6 auto with -6 5point1 in your profile
  3. If you're using handbrake 0.9.8 and older then change -6 auto to -6 6ch in your profile
With the new build I've removed the -6 from the profile and it will be taken care by MCEBuddy but the user can always override it from the profile.

This should solve your problem.
Jun 27, 2013 at 5:05 PM
Thank you. That seems to have worked for shows that I record with my WinTV HD-PVR but not for the shows on my Hauppaugue 2250, please see the attached log. MediaInfo shows primary audio to be 6 channels but the converted file still shows 2.

http://www.mediafire.com/?dh6imln35sqkc1m
Coordinator
Jun 27, 2013 at 5:21 PM
That's because there are multiple audio tracks and mcebuddy will not isolate unless you specify it. This has been documented in the release notes.
Becuase there are multiple tracks MCEBuddy and the user has not specificed any track leaves it to the encoder to choose, in this case handbrake chooses auto and for AAC that downmixes to 2 channels.

Select the ENG audio track in the conversion settings and the problem will be resolved


Coordinator
Jun 27, 2013 at 5:22 PM
Here's a really neat trick, if you edit hte profile manually and add -6 5point1,auto it will create 2 audio tracks one with multi channel and the other with stereo AAC in the output file :)

See handbrake cli commands for more neat tricks using handbrake (adn same for ffmpeg)
Jun 27, 2013 at 5:30 PM
Edited Jun 27, 2013 at 5:32 PM
thanks again, I actually had ENG selected on the old version as the documentation states, I guess I assumed that setting carried over to the new version but it looks like it did not in my case. I switched it back and now it works
Coordinator
Jun 27, 2013 at 5:37 PM
that's wierd, let me see that.


Jun 29, 2013 at 4:30 AM
I used copy:ac3 on my Handbrake options and that ended up resolving my original issue in .12.
Coordinator
Jun 29, 2013 at 12:02 PM
That'll work and I personally prefer ac3 just that apple doesn't since it's a licensed codec an AAC I free. But support for AAC is just terrible out there