MCEBuddy created WTV files do not play on WMP or Windows MCE

Coordinator
Aug 6, 2013 at 3:44 AM
Thanks for DjJustin for researching and finding a solution to this problem.

Uninstall Windows Update KB2670838

This update breaks the way Windows Media Foundation codecs work with FFMPEG created WTV files. An issue has been opened with FFMPEG to fix this issue, you can vote to fix this here:
http://trac.ffmpeg.org/ticket/2835

Meanwhile uninstall KB2670838.

NOTE: This does not work with Windows 8 since Windows 8 comes with the fix built into it. So for now MCEBuddy created WTV files will not play on Windows 8.
Coordinator
Dec 24, 2013 at 2:23 AM
FYI update, for those facing this issue, the FFMPEG team has done an awesome job of fixing this and providing support for the latest WTV format. You can download the latest ffmpeg build from ffmpeg.org and replace it in your mcebuddy installation and it should work.

Alternatively wait for the next build of mcebuddy.
Coordinator
Jan 1 at 1:51 PM
This issue has been fixed with the latest 2.3.15 version
Marked as answer by rboy1 on 1/14/2014 at 9:30 AM
Jan 6 at 7:38 AM
Running 2.3.15 20140104 and still seeing this issue. Even after uninstalling KB2670838 from both the machine doing the encoding and the Media Center computer.

I get audio but no video on Xbox 360 extenders. I even tried re-encoding after uninstalling from both machines and rebooting - no dice.
Coordinator
Jan 6 at 2:27 PM
so to be clear, the video is working on Windows 7/8 MCE but not working while playing back on your XBox 360 extender?

BTW, the KB is for playback on your computer, nothing to do with encoding which is done by ffmpeg. The recent fix allows playback on computers with the KB installed.


Jan 6 at 3:23 PM
Correct. My problem is specifically related to H.264 it looks like. If I run comskip and only cut the commercials, the files play back. If I encode to H.264 then I get audio but no video.

I haven't tried a forced-reencode to MPEG2 after a commercial cut. My goal is a one-step comskip cut and H.264 encode... but I'm not there yet.

The other oddity is I can't even take the MPEG2 'cut' file and open it in VRD. A friend that owns VRD was over the other day and I asked him to open one of my cut files, and he said it was failing with "unknown catch error" - whatever that means.

So far, I have not gotten successful playback on an extender of any file I have encoded to H.264/WTV with MCE Buddy 2.x
Coordinator
Jan 6 at 9:08 PM
Okay 2 many things - we need to isolate where the issue is.

Can you explain which profiles are you using (stock or if customized, post the profile) and what settings are you using (post the conversion log) which are working and which ones arent.

I will need details (lots of them) to get the bottom of this, so please attach your conversion logs for the ones that succeed and those which dont. (upload zip to dropbox and post hte link here)


Jan 7 at 7:02 AM
Profiles I'm using are all stock. To just do a comskip/cut, I use the WTV Unprocessed profile. To do a comskip/cut and H.264 encode, I use the WTV profile.

All of the conversions 'succeed' in that the program completes what it says it is doing. It's just the files encoded by MCE Buddy (H.264) will not play on an extender.

I will run back through the cut only, encode only, and cut/encode scenarios and post logs to the FTP site under a different subfolder.
Coordinator
Jan 7 at 1:31 PM
Also let me know if MPEG2 in WTV is working or not.


Coordinator
Jan 7 at 1:35 PM
BACKING UP A BIT HERE:
Okay so WTV unprocessed is working - i.e. the WTV format created by mcebuddy IS working on the xbox extender
However the H264 file created by MCEBuddy does not work. So then it's essentially the codec options used are not compatible with XBox.

Open your profile.conf file, in the WTV profile change the ffmpeg-video this:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d,crop=iw:ih:0:0,scale=min(720\,iw):trunc(ow/dar/2)*2 -vcodec libx264 -b 1200k -subq 6 -x264opts direct=auto:level=4.0:partitions=p8x8,b8x8,i4x4:no-weightb=0:psnr=0:ssim=0:subme=7:ref=3:b-pyramid=none:no-mixed-refs=0:trellis=1:threads=auto -sn
Now try it and let me know if it works.

Also try this one:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1200k -map 0:v -sn
Let me know if this works.
Jan 7 at 3:01 PM
The first profile gives me a Decoder Error on my desktop. XBox 360 says Playback Error. Mediainfo says:

Complete name : E:\Video\Encoded\Peppa Pig\Peppa Pig-Flying a Kite; Muddy Puddles; Windy Castle; Hide and Seek; Cleaning the Car-NEW-PROFILE-1.wtv
Format : AC-3
Format/Info : Audio Coding 3
File size : 75.5 MiB
Duration : 27mn 29s
Overall bit rate mode : Constant
Overall bit rate : 384 Kbps

Audio
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Duration : 27mn 29s
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 75.5 MiB (100%)

That doesn't seem right.
Jan 7 at 3:13 PM
Second profile acts same as stock... audio but no video, FFW/RW doesn't work but shows proper time.

Complete name : E:\Video\Encoded\Peppa Pig\Peppa Pig-Flying a Kite; Muddy Puddles; Windy Castle; Hide and Seek; Cleaning the Car.wtv
Format : AVC
Format/Info : Advanced Video Codec
File size : 246 MiB

Video
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.0 Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Bit rate : 879 Kbps
Width : 528 pixels
Height : 400 pixels
Display aspect ratio : 16:10
Frame rate mode : Variable
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Writing library : x264 core 136 r2350 3361d59
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=abr / mbtree=1 / bitrate=879 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Jan 7 at 3:14 PM
Stock WTV profile, for comparison... same file, comskip and everything:

Complete name : E:\Video\Encoded\Peppa Pig\Peppa Pig-Flying a Kite; Muddy Puddles; Windy Castle; Hide and Seek; Cleaning the Car-MCEBUDDY-COMSKIP-ENCODE.wtv
Format : AVC
Format/Info : Advanced Video Codec
File size : 124 MiB

Video
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.0 Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Width : 528 pixels
Height : 400 pixels
Display aspect ratio : 16:10
Frame rate mode : Variable
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Writing library : x264 core 136 r2350 3361d59
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=22.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00

Original file is 280,320K, 29:56 long.
Coordinator
Jan 7 at 3:24 PM
I suspect it's the bframe which is causing an issue with xbox, try this:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1200k -subq 6 -x264opts direct=auto:level=4.0:partitions=p8x8,b8x8,i4x4:no-weightb=0:psnr=0:ssim=0:subme=7:ref=3:b-pyramid=none:no-mixed-refs=0:trellis=1:bframes=3:threads=auto -sn
Jan 7 at 3:30 PM
Mediainfo isn't even seeing a video codec in that one

Complete name : E:\Video\Encoded\Peppa Pig\Peppa Pig-Flying a Kite; Muddy Puddles; Windy Castle; Hide and Seek; Cleaning the Car.wtv
Format : AC-3
Format/Info : Audio Coding 3
File size : 75.5 MiB
Duration : 27mn 29s
Overall bit rate mode : Constant
Overall bit rate : 384 Kbps

Audio
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Duration : 27mn 29s
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 75.5 MiB (100%)
Coordinator
Jan 7 at 3:33 PM
try the new profile I just posted


Jan 7 at 3:43 PM
That was from the new profile you posted:

ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1200k -subq 6 -x264opts direct=auto:level=4.0:partitions=p8x8,b8x8,i4x4:no-weightb=0:psnr=0:ssim=0:subme=7:ref=3:b-pyramid=none:no-mixed-refs=0:trellis=1:bframes=3:threads=auto -sn
Coordinator
Jan 7 at 5:09 PM
I'm sorry. Bframes should be 0

Also can you upload the conversion log

Jan 7 at 9:41 PM
Same result (decoder error), logs uploaded.
Coordinator
Jan 8 at 8:08 AM
Edited Jan 8 at 8:10 AM
Okay I think I may have figured this out. You original WTV file has MPEG2 video which plays back fine on your Xbox extender when you use teh WTV Unprocessed profile (since it does not recode, the converted WTV has MPEG2).
Where as the WTV profile encode it to H264 which does not playback on your extender, so I'm suspecting XBox extender does not support H264 in WTV.

Try this in your WTV profile to confirm, replace ffmpeg-video with:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 6 -map 0:v -sn
Coordinator
Jan 8 at 8:09 AM
I'm assuming you're using the latest 2.3.15
Jan 8 at 9:12 AM
XBox as an extender does support H.264 in WTV. I'm uploading a file my buddy encoded while he was here.

It's from the stock "H.264 WTV" profile in VRD. Looks like the parameters it uses are:

Q MPEG-2 to H.264 - 70%

Level 1
VBV 4000000
Interlace Progressive
HRD maintain Yes
Entropy coding mode CAVLC
GOP size 32
Scene detection enabled Yes
Reordering delay 2
Use B slices No
Use B slices as reference frames No
Encoder determines B or P type Yes
Weighted prediction for P frames No
Subpixel motion search depth Full pixel only
IDR frequency Every I-frame is IDR
Number of reference frames 0
SPS every I-frame No
Field order Top field first
Minimum black level 0
Use Full video range No
Preset Faster
Tuning Film

If you need to see more I think they let you download a trial version. I'm trying to stick to one product though :)
Coordinator
Jan 8 at 9:31 AM
one key difference I notice is the profile, your stock wtv indicated above shows 3.0 where as mcebuddy encodes for 4.0, you can try changing that to 3.0 and see if it works.
some devices don't support higher profiles.


Coordinator
Jan 8 at 9:46 AM
Okay try this, a 3.0 profile with 0 reference frames, no weight-b or p with CAVLC would look like:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 3000k -subq 6 -x264opts direct=auto:level=3.0:8x8dct=0:no-weightb=1:weightp=0:psnr=0:ssim=0:subme=7:ref=0:me=hex:b-pyramid=none:no-mixed-refs=1:cabac=0:trellis=0:bframes=0:threads=auto -sn
If you have a WTV H264 that works, you can try to tweak the profile above further to meet the specifications that work and post it back here.
Jan 9 at 5:04 AM
That profile looks like it generated the exact same file as previous tries, just under 80MB. Uploading that file for comparison to the one from VRD.
Coordinator
Jan 9 at 8:46 PM
Where are you uploading it?
Is it working with the Xbox?

Jan 10 at 12:46 AM
I uploaded to your site, in a folder under my username.

I uploaded two files. One that has VAP in the filename that was encoded by VRD (and does work on Xbox 360) and the other was the latest profile you gave me above... and it does not work on Xbox 360. Or PC using Media Center.
Coordinator
Jan 14 at 3:33 PM
Okay I'm able to see the no video. Can you upload the original WTV file (first 100MB is enough) to the server so I can see why, where and what's going on
Jan 14 at 3:47 PM
Edited Jan 14 at 3:54 PM
Uploading now. I didn't have a quick way to cut it, and it's not a big file.

[Edit] Looks like I hit a file size limit. Let me know if it didn't come through cleanly or if you need something else.
Coordinator
Jan 14 at 3:54 PM
Are you sure you're using the right version and profile of MCEBuddy? I just used the WTV profile to convert the working VAP file you had uploaded and it's converted just fine and it's playing back fine. Double check what version of MCEbuddy you're using and what profile you're usin. Are you using a customized profile or the stock profile?
Jan 14 at 3:58 PM
The VAP file is already H.264 - not MPEG. I started using the stock WTV profile (not WTV unprocessed) and I'm using 64-bit 2.3.15 Debug 1 from the 7th. I've since tried all. the profiles you posted above, same results.

Try using the stock WTV profile on the file I uploaded, then try the profiles you posted above. I'll be happy to rerun the results if needed.
Jan 14 at 4:09 PM
I also uploaded a file from the 7th that I encoded with the stock profile, before any of the debug releases started coming out.
Coordinator
Jan 14 at 4:15 PM
:)) The debug releases were not the general public, it was a very specific to some users who were facing some point issues.
Anyways I'll check it out and post back here.
Coordinator
Jan 14 at 4:29 PM
I' used the latest 2.3.15 BETA 32bit build, Stock WTV and Stock WTV Unprocessed profiles and it's working just fine. I can play back the video in WMP and MCE (with KB2670838 installed). I've uploaded the file in a folder in your sub directory, download it and see if it plays back your MCE and Extender.

Then try to download the latest 2.3.15 BETA, use the stock WTV profiles and compare it.
Jan 15 at 2:50 AM
Downloaded 2.3.15 BETA 64-bit 20140114 and used the stock profile to encode the same source file. Profile used:

[WTV]
Description=Recodes the video to creates high quality WTV (H.264/AC3) files.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -crf 22 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
PreConversionCommercialRemover=true

I encoded my file and I downloaded your file. My encoded file acts the same as your encoded file on the extender... Audio but no video, FF/RW won't work (shows the 'length' bar but won't actually FF or RW).

I uploaded my encoded file and the logs.
Coordinator
Jan 15 at 4:49 AM
FF/RW is a known issue, only 1x works.

Is my file playing back on your WMP/WMC?
Jan 15 at 11:21 AM
Yes, bot your file and my file play back on WMP/WMC. Both act the same on extenders.
Coordinator
Jan 15 at 12:27 PM
Can you try this, for the same file you uploaded, use the WTV Unprocessed profiles with the latest BETA (that you downloaded). Let me know if it plays back on your WMP and then on the XBOX.
It there is no video on the XBOX please upload the conversion log to the server and I'll take it up with ffmpeg.


Coordinator
Jan 15 at 1:05 PM
I've uploaded one file called 360.wtv, can you let me know if that works on your xbox?


Jan 17 at 12:06 AM
360.WTV seems to be just fine on the extenders.
Coordinator
Jan 17 at 1:30 PM
that helps. That was just a simple ffmpeg repackaging of the wtv container, so that works.
Which means something is breaking during the conversion process.

download hte latest beta version and there in the Conversion Task -> Expert Settings you'll find an option for Skip Remuxing.

CHECK that option and then run the WTV UNprocessed profile.
For now ensure that Commercial Removal is set to NONE, Write Metadata is NOT checked, NO Subtitle Extraction and NO download series information.

See if that works on your extender (trying to narrow this down).


Coordinator
Jan 21 at 3:26 PM
@meklos - any luck trying the above?
Coordinator
Apr 30 at 8:19 PM
This has been fixed with the new builds after April 22nd
Marked as answer by rboy1 on 4/30/2014 at 1:19 PM