Crop 720/576 and encode to 16:9

Aug 9, 2013 at 7:09 AM
I tried everything I found on this and other forums but none of them worked for me. My DVR records in 720 x 576. I would like to have the video encoded to 16:9 and cropped around it. I tried the following.

ffmpeg-video=-ss 3 -vf pullup,softskip,crop=720:576:2:0,yadif=0:-1,hqdn3d -vcodec libx264 -b 1100k -x264opts me=hex:trellis=1:subq=8:partitions=all:8x8dct=1:ref=8:rc-lookahead=50:keyint=25:min-keyint=20:bframes=1:weightb=1:level=4.1:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=0:threads=auto

SkipCropping=true
FixedResolution=true

Am I missing something?
Coordinator
Aug 9, 2013 at 1:27 PM
Post your conversion log

Aug 9, 2013 at 7:55 PM
Here you go. Log
Coordinator
Aug 9, 2013 at 9:40 PM
Lots of things going on here:

First the profile you're using does NOT have the settings you've written above. here is the profile being used:
-ss 3 -vf pullup,softskip,crop=704:576:2:0,yadif=0:-1,hqdn3d -vcodec libx264 -b 1100k -x264opts me=hex:trellis=1:subq=8:partitions=all:8x8dct=1:ref=8:rc-lookahead=50:keyint=25:min-keyint=20:bframes=1:weightb=1:level=4.1:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=0:threads=auto
As you can see the crop is 704:576

That's not all, this conversion failing because of the pullup command which isn't a filter recognized by ffmpeg
2013-08-09T14:51:39 MCEBuddy.AppWrapper.FFmpeg --> [AVFilterGraph @ 0000000005d3f5a0] No such filter: 'pullup'
Next it falls back to handbrake and get the follwing:
--start-at duration:3 -e x264 -b 1100 -x me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=8:rc_lookahead=50:keyint=25:keyint_min=20:bframes=1:weight_b:level_idc=41:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=0:threads=auto
You can see thereis no crop setting here, since SkipCropping is defined, MCEBuddy sets the crop to 0
-i "C:\Program Files\MCEBuddy2x\working0\720 x 576.ts" --decomb --loose-anamorphic --verbose=2 -T -f mp4 -4 --start-at duration:3 -e x264 -b 1100 -x me=hex:trellis=1:subq=8:partitions=all:8x8dct:ref=8:rc_lookahead=50:keyint=25:keyint_min=20:bframes=1:weight_b:level_idc=41:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=0:threads=auto --crop 0:0:0:0 -E faac -R auto -B 160 -D 0 -6 stereo -o "C:\Program Files\MCEBuddy2x\working0\720 x 576-converted.mp4"
You have your answers.