Bug in latest beta with Network paths

Sep 18, 2013 at 4:10 PM
Hello,

I use MCEBuddy to monitor all MCE instances throughout the house and convert videos to file server. Up until 2.13 everything worked just fine but with lastest 2.14 MCEBuddy just wont work as before.

Since I handle my network shares with Windows ( I map the drives manually ), I left (per guide) network credentials empty in source and destination windows. Drives are mapped and visible with Drive letter in Explorer.

http://dl.dropbox.com/u/103938233/Screenshots/0_.jpg

As you can see in the screenshots shares are mounted and assigned letters and MCEBuddy does not have any credentials assigned yet I'm still unable to use those drives....

Any idea whats up ?

Kind regards,
-vladimir
Coordinator
Sep 18, 2013 at 4:31 PM
The handling of mapped drives changed in 2.3.14 due to a bug which didn't allow it to work with credentials.
Now all network files (mapped drive or not) are treated as network files. If they are being dragged and dropped or if being added via the add button then the network credentials under Expert Settings are used.

In your case since you have already mapped the drives the credentials have already been set by windows. Hence essentially MCEBuddy is trying to remap them with new credentials which is leading the error you are facing.

So, first when you map the drives, are you using any credentials? Are you using the same credentials with MCEBuddy under the settings -> expert settings?
Try you try to logoff and logon or reboot your computer and then try (this clears any mapped credentials) conflicts.


Sep 18, 2013 at 9:16 PM
Thanks.... reboot and new setup of shares helped.
Coordinator
Sep 18, 2013 at 10:11 PM
I will update the documentation also, thanks. It's alittle out of date.

In short if you're using a network path in the Monitor Task or Conversion Task you need to specify the credentials for the network path in those settings.
If you're using Add File or Drag and Drop, you need to specify the credentials for the network share in the Settings -> Expert Settings

If you're using mapped network drives, the credentials used must match what you're used on the Mapped Network drives (since windows only allows one set of credentials per network share).
Sep 18, 2013 at 10:52 PM
Edited Sep 18, 2013 at 11:27 PM
rboy1 wrote:
I will update the documentation also, thanks. It's alittle out of date.

If you're using mapped network drives, the credentials used must match what you're used on the Mapped Network drives (since windows only allows one set of credentials per network share).
Actually what i did was reboot the box, mount the drives as usual (manually), started MCEBuddy GUI, go to the monitor path=removed all credentials, go to the destination path=removed all credentials and started MCEbuddy again and it worked.

So in short, no i did not enter path credentials in MCEBuddy for (Windows) mapped drives.
Coordinator
Sep 19, 2013 at 1:43 AM
Is there a username and password for these paths or are they open to everyone/guest?


Sep 19, 2013 at 7:28 AM
Edited Sep 19, 2013 at 12:34 PM
Paths are SMB shares which password protected. Also shares are ALWAYS mapped as I use Network Drive Manager to keep monitoring network paths are always accessible.

Strange thing is that when i started MCEBuddy, shares were accessible to MCEBuddy but then all of the sudden Access Denied is in the logs. Please see MCEBuddy log.

Is there anyway to prevent MCEBUddy from being too smart and just accept mapped drives as if they were local ? (in case no credentials are supplied in MCEBuddy dont atempt to map it, just use local paths )

https://dl.dropboxusercontent.com/u/103938233/Screenshots/mcebuddy.log

So what exactly is recommended way to set up MCEBuddy to monitor password protected, Windows mapped, network drives ?
Coordinator
Sep 19, 2013 at 12:13 PM
Mcebuddy runs as a local service and not as a local user. There is no way for it to use the same credentials as the local user mapped drives since they are different logins. It's a windows limitation.

There are 2 ways out of this. Open the service manager and change the mcebuddy service run as user from local service to the local user. If the local user does not have admin privileges it will create a problem.

Simpler would be just to add the same credentials you are using for your mapped drives to mcebuddy. That way there is no conflict and everything works.

Where have you uploaded your log?

Sep 19, 2013 at 12:37 PM
Its in my post...

anyway, now i've done as suggested, started from scratch. rebooted PC, mapped the drives as usual , set up monitor and destination paths ( put Windows credentials into the path authentication boxes ) , rebooted PC one again and it seems to be working now...

Thanks. Hope the settings will stick :-)
Coordinator
Sep 19, 2013 at 12:37 PM
Okay I went through you log and got a little confused because some places I'm seeing it connect and monitor the file and other it's not able to. This does NOT appear to do with the mappings credentials (also if you notice it tries to authenticate in the beginning but is still able to access the files afterwards) but more likely to do with permissions on the remote network share. Couple of things:
  1. What OS is running on both the remote network shares, \VM-Mac and \UK-Server (I see the MCEBuddy machine is running Windows 7)
  2. Can you stop the MCEBuddy service from the Windows Service Manager, delete the mcebuddy.log file and then restart the service. Let it run for a few minutes and the upload the Entire log (I want to see from beginning to end what happens).
  3. Verify that the security permissions on the ALL the files on the network shares are identical.
If it's connecting to the network share ONCE, it will ALWAYS connect. If it stops for some files and not other it only means security permissions are off or the network connectivity is intermittent.

Also Windows Vista/7 has interop issues with XP and Mac (see this link http://support.microsoft.com/kb/947235). Will wait for your new log file.
Sep 22, 2013 at 9:50 PM
1, VM-Mac is running Mac but share is Samba. I use a admin user that has read and write rights for the shares to map them in Windows.
2, As previously notes in my post, I fixed the problem by adding Windows credentials to MCEBuddy's list in Settings/Expert Setting.

The reason why you saw in the log that it connected one and then lost connection was that I was trying around different things to see why its not working.

Thanks for your help and cheers.
Sep 23, 2013 at 7:24 AM
Edited Sep 23, 2013 at 7:38 AM
I've spoken a bit too soon. This morning I found none of the converted shows were transferred to destination drive. I will have to troubleshoot later today when I get back from work per your notes above.