This project has moved. For the latest updates, please go here.

Prevent secondary audio track?

Oct 14, 2013 at 9:33 PM
Edited Oct 14, 2013 at 9:36 PM
I've attempted to search through the documentation and discussions to see if this had already been answered, so apologies if it has. All of my recordings come from OTA broadcasts. Some channels have secondary audio (sometimes it is for audio in Spanish, sometimes it seems to be a weather broadcast). Until now, these haven't caused any problems because they have always been the second audio stream in the converted file. But recently one of these showed up as the primary stream. I use Plex for playback, so it was easy enough to switch the audio stream, but I was wondering if there was a way to prevent these from being in the conversion at all? They are always 2-channel, while the main audio is always 5.1-channel. I am currently using a profile that simply removes commercials and remuxes the original video/audio (MPEG-2/AC3) into an MKV container. Any ideas?

Here is my profile:
[MKV Unprocessed]
Description=Creates MKV files by copying the video directly. It does not resize, remove black bars, deinterlace your videos or select audio language. Use this if you have high quality HD recordings which don't need processing.
order=copy,ffmpeg
copy-remuxto=.mkv
copy-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vcodec copy -map 0:a -map 0:v
ffmpeg-audio=-acodec copy
ffmpeg-audioac3=-acodec copy
ffmpeg-ext=.mkv
ffmpeg-audiodelay=skip
FixedResolution=true
SkipCropping=true
Coordinator
Oct 14, 2013 at 10:59 PM
If the audio track you want has an language name on it (e.g. eng, you can find out by right clicking on the file during conversion and see the media info). then in the conversion task advanced settings enter the 3 digit language code for that audio track. It will only select that track.

If it does not work post back here then you'll need to modify the profiles.conf profiles to remove multi track selection.


Oct 15, 2013 at 4:36 AM
rboy1 wrote:
If the audio track you want has an language name on it (e.g. eng, you can find out by right clicking on the file during conversion and see the media info). then in the conversion task advanced settings enter the 3 digit language code for that audio track. It will only select that track. If it does not work post back here then you'll need to modify the profiles.conf profiles to remove multi track selection.
Unfortunately both audio streams show up as 'Unknown'. My best bet is if I can prevent the 2-channel audio from being processed.
Coordinator
Oct 15, 2013 at 4:47 AM
yes I was able to replicate the issue, for now just enter "und" in the language selection. That should also work for now.
If that works I'll add an option to select the best audio track in the next release.

Let me know how it goes.


Coordinator
Oct 15, 2013 at 4:50 AM
the other option is open profiles.conf, open the profile you're using and from the ffmpeg section remove "-map 0:a -map 0:v", this is what causes the encoder to choose all audio tracks, without this it only selects the "best" audio track only.


Coordinator
Oct 15, 2013 at 6:41 AM
done fixed, in the next build you'll find an option to select best soundtrack which should fix your problem. If you're still facing issues let me konw.
Marked as answer by rboy1 on 1/29/2014 at 9:13 AM
Oct 15, 2013 at 2:30 PM
rboy1 wrote:
done fixed, in the next build you'll find an option to select best soundtrack which should fix your problem. If you're still facing issues let me konw.
Outstanding, thanks for being so quick to help and implement an even better solution. I'll have to report back on how the options work out, I don't have any proper source material at the moment. Thanks again.
Oct 15, 2013 at 6:51 PM
I was just about to inquire about a similar configuration which this addresses. Great work as usual! Just keeps getting better!