This project has moved and is read-only. For the latest updates, please go here.

HW Acceleration

Feb 27, 2014 at 3:38 PM

My apologies in advance for the likely dumb question, but ... I am trying to get HW acceleration working in 2.3.15, on my Radeon HD5450 (supported device). However, I don't see HW Acceleration as an option, and don't see HandBrake profiles. Based on all the various threads about this, I likely need to do some configuration, but I admit - I haven't seen a clear picture in one place (which I may just be missing!) ... :-(.

Is there a "guide" of how to get HW Acceleration working?

Feb 27, 2014 at 5:17 PM
For QuickSync encoder, it's automatic, all you need to do is check the enable hardware encoding check box in the conversion task settings and mcebuddy will do the rest.

The part about handbrake is that only profiles which are based on handbrake will make use of the enable hardware accelleration automatic enabling checkbox

Also the automatic hardware accelleration works only for QuickSync it looks like your HD5450 does not support QuickSync.

However it does appear to support OpenCL so you will need to manually enabled some OpenCL features in your profile. Open the profiles.conf, find the profile you're using. Ensure that handbrake is the first encoder in the order. Then in handbrake-video add -P at the end of the profile (which will used hardware for cropping and scaling).

Marked as answer by rboy1 on 2/27/2014 at 9:17 AM
Feb 27, 2014 at 5:17 PM
Marked as answer by rboy1 on 2/27/2014 at 9:17 AM
Mar 1, 2014 at 3:24 AM

Trying to follow the instructions, but I don't even seem to have the checkbox for HW encoding (under Expert Settings). Do I need to do something for this to even show up?

Mar 1, 2014 at 1:53 PM
are you using hte latest 2.3.15?

Goto Conversion Task -> Advanced Settings -> Expert Settings
Mar 2, 2014 at 11:20 PM
Yep, that's where I'm at ... :-(.
Mar 3, 2014 at 1:55 PM
Then you're using an old version of MCEbuddy, download the latest 2.3.15

Mar 3, 2014 at 2:04 PM

Just checked, and 2.3.15 seems to be from Feb 20 ... is that right? I downloaded last week, so after this date.


Mar 3, 2014 at 2:33 PM
Try the latest one. The check box should show up - it is never disabled. If it isn't showing up then the build doesn't have the feature.

Mar 3, 2014 at 2:42 PM
OK, re-downloaded, and re-installed ... still the same. The file is from Feb 20 ... is that right?

FYI, I can't connect to the server from the Remote Client either (only in 2.3.15, it worked in 2.3.14).

Mar 3, 2014 at 2:55 PM
no the build is 1st March. The latest builds filenames are:

MCEBuddy 2.3.15 64bit - 20140301
MCEBuddy 2.3.15 32bit - 20140301
MCEBuddy 2.3.15 64bit - 20140301

Make sure your remote client is also updated to the same build

Mar 3, 2014 at 3:04 PM
OK, that was very odd ... closed and reopened IE and now I see the Mar 01 versions. Both installed ... same issues ... :-(.

It could be on my end! Just not sure what I'm doing wrong.
Mar 3, 2014 at 3:28 PM
Post your mcebuddy.log file (upload to dropbox)
Mar 3, 2014 at 8:20 PM
Sure, is there a place on Dropbox to put it?

Mar 3, 2014 at 8:30 PM
Create an account, it's free

Mar 4, 2014 at 3:00 AM
According to your log file it is enabled. Post a screenshot what your are seeing and where you don't see this check box?
Mar 4, 2014 at 4:14 AM
I don't you think read my note earlier correctly. I said goto Conversion Task -> Advanced Settings -> Expert settings and you'll find it there.
You went to Settings -> Expert settings
Mar 4, 2014 at 1:06 PM
Absolutely my fault, my apologies. I did read your comments, at least 5 times, but somehow I missed that part of the path through.

I really am sorry, didn't mean to waste your time ... :-(.
Mar 4, 2014 at 3:08 PM
no sweat. Give us a review.

Mar 5, 2014 at 12:22 AM
Done! And again, thanks.