just process commercials (and move/rename)

Mar 4, 2014 at 12:11 PM
I've got the donator versions of both comskip and mcebuddy and for the life of me I can't figure out what options to select to make this work. All I want MCEBuddy to do is watch the WMC 8 recording folder and kick off a comskip task when a recording shows up. Either before or after the comskip, I'd like MCEBuddy to also rename the file. It seems like no matter what options I select I end up with either a remuxing of the recording or a separate copy in the temp directory. Since I have the donators version of comskip I shouldn't have to remux the file and since my final location is on the same drive as the original file I should be able to just move/rename the file without having to read/write it again. I'm sure its something stupid that I'm missing, but could someone let me know what options would be appropriate to accomplish this?
Coordinator
Mar 4, 2014 at 2:07 PM
post your conversion log (upload dropbox and post the link)

Are you trying to convert the file or just remove the commercials?


Mar 4, 2014 at 11:52 PM
I don't want to change the file contents at all. I don't want to remove the commercials. I just want to generate the xml file for DTBaddin to use to skip commercials and move the file to a new location. In the log I posted below you will see that the file was remuxed to a TS then back to a wtv. This causes a ton of extra reading and writing from the disk, as I just want to use comskip to process the WTV file directly. I noticed in the expert settings for the profile in mcebuddy that I can select "skip remuxing files", but when I select it and click ok then come back into check that it was set it looks like it never stays selected. Not sure if that is a bug or what.

http://travisandliz.com/mcebuddy.log
Coordinator
Mar 5, 2014 at 3:05 AM
skip remuxing is your answer. Not sure why it isn't staying, try using the latest build, I just tested it and it's working there.
Set your commercial to Comskip, enabled Skip cutting commercials to only generate the EDL file.


Mar 5, 2014 at 11:44 AM
I grabbed the 20140304 release and tried again with it but got the same issue. It really seems like some kind of bug in the gui. When I go into the expert settings for my profile I can place a check mark in the box for "skip remuxing files" and I get the warning message. After acknowledging the warning I see that the box is checked so I click "ok". If I immediately click on "expert settings" again I see that the skip remuxing box is unchecked again. Its like the gui isn't saving the fact that I clicked the checkbox.

Is it possible that some other option is causing this checkbox not to be "saved"?

BTW...I'm running windows 8 in a virtualbox VM.
Coordinator
Mar 5, 2014 at 12:50 PM
Wierd. It working fine here all my test machines.

Try editing the mcebuddy.conf manually. Stop the engine. Open profiles.conf and change the value of skipremuxing from false to true. Save it. Click start engine.



Marked as answer by rboy1 on 3/10/2014 at 9:30 PM
Mar 6, 2014 at 1:18 AM
That worked. FYI for anyone else experiencing the same issue, you need to edit the mcebuddy.conf file directly and set the skipremux variable to true.

The GUI is still "broken" for me. It doesn't have a check on the skip remux box even though the functionality is working. This is the only setting that appears to have this issue.

Just a quick thanks....I couldn't have asked for better support. Thanks for your help!
Coordinator
Mar 6, 2014 at 2:05 AM
TRy a clean install. Maybe your MCEBuddy.gui.exe wasn't updated


Mar 6, 2014 at 12:19 PM
I did remove the previous version of mcebuddy through add/remove programs before installing the new version. Is there something else I should have done?
Coordinator
Mar 11, 2014 at 4:30 AM
not that I can think of, just uninstall reboot and then try to reinstlal