This project has moved and is read-only. For the latest updates, please go here.

WTV to MKV without fast remux?

Apr 29, 2014 at 3:04 PM
Before I go the route of posting large log files, I'd like to ask first if I'm even doing something that is supposed to be possible. I'm using the stock 'MKV Unprocessed' profile (with the addition of a PostCustomCommand) with no commercial skipping in an attempt to get the source WTV remuxed and renamed as quickly as possible. The source WTV is from US OTA broadcast, and has 1080p MPEG2 video and 5.1 AC3 audio. If I leave the fast remux step enabled, everything works fine. But if I turn it off (from what I've read, ffmpeg SHOULD be able to read a WTV as input), I wind up with an unplayable MKV that has 704x480 MPEG1 video. I've even tried running a separately downloaded version of ffmpeg from the command line with the same results. So, I guess this is perhaps more of an ffmpeg question, but maybe there is an MCEBuddy solution. Is there a way I can remux directly from WTV to MKV without having to go through the fast remux to TS step? This doubles the conversion time, and I would love to eliminate it if I could.
Apr 29, 2014 at 3:20 PM
Yes there are ways to do it. Before I get into it I am very interested in your log file. Reason being
1. You mentioned that you end up with a MPEG 1 file. Very curious as WTV only supports mpeg2 and mpeg4.
2. You are saying that with "skip remuxing" enabled it works but without that it doesn't. Are you using 2.3.15?
3. See exactly what's going on

Can you zip and upload your file to the mcebuddy server or to Dropbox and post the link here.

If it is working with skip remuxing what is the issue? (As I understand you don't want remuxing which appears to be your working scenario) or did I not understand your question.

With 2.3.15 with skip remuxing and MKV unprocessed it should do exactly what you are asking.

Apr 29, 2014 at 3:27 PM
I may have been confusing in my post. It's actually the opposite that works. With fast rumuxing enabled, the conversion from WTV->TS->MKV works fine. I was hoping I could turn fast remuxing off and just go from WTV->MKV. I'll have to track down (or re-create) a log file later and upload--I'll make sure it's a full debug log. Thanks for having a look at it.
Apr 29, 2014 at 3:57 PM
With 2.3.15 enable Skip remuxing option under conversion task expert settings and it should work. This will work if you aren't using comskip or are using the donator version of comskip.

Marked as answer by rboy1 on 5/4/2014 at 9:57 AM
Apr 29, 2014 at 6:01 PM
I'm using 2.3.15 and that is the setting that I used to enable/disable fast remux. I also use the donator comskip and have not had success using WTV directly without the TS remux. I've uploaded a file to the MCEBuddy UPLOADS folder, WTV_to_MKV.zip, that has two log files in it. One is the show converted using a modified 'MKV Unprocessed'' with the 'Skip remux' option off, and one with it on. They are labeled as such. You'll see mention in there that FFMPEG thinks the source WTV video is 704x480 MPEG1, which in actuality it is 1080p MPEG2. Hope this sheds some light on things for you.
Apr 29, 2014 at 7:18 PM
Don't worry about the video size. That's a known issue but has no impact on the conversion per se.

I see from your logs that both are successful in conversion. So what issue are you facing with the skip remixed version?

Apr 29, 2014 at 7:28 PM
According to MediaInfo, the MKV produced when skip fast remux is enabled has a single 704x480 MPEG1 stream. And it does not play in any player. With the fast remux enabled, the resulting MKV has a 1920x1080 MPEG2 stream (which is what the original WTV has), and works just fine. Perhaps the known bug does have an impact on conversion after all? Can I use the File Splitter app from your FTP to create chunk you can test with from the source WTV? If so, how big should it be?
Apr 29, 2014 at 8:17 PM
Yes upload 100mb to begin with so I can try to replicate it. First chunk only (subsequent ones are no good)

Apr 29, 2014 at 8:44 PM
Uploaded as Grimm_KXASDT_2014_04_25_19_57_00.wtv.chunk001. Thanks again for looking at it.
Apr 29, 2014 at 9:28 PM
you're right I'm seeing the same issue. BTW what is this ffmpeg bug you're referring to?


Apr 29, 2014 at 9:35 PM
I was just referring to your comment:
Don't worry about the video size. That's a known issue but has no impact on the conversion per se.
Apr 29, 2014 at 9:45 PM
No this appears to be something new. I'll investigate it but for now use it with remuxing.


Apr 29, 2014 at 10:50 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Marked as answer by rboy1 on 5/4/2014 at 9:57 AM