This project has moved and is read-only. For the latest updates, please go here.

DIVX Quality based conversion - Showanalyzer not working

May 3, 2014 at 3:09 AM
Hi again

I've updated to 2.3.15 and have been doing some experimenting.

On my old system I had some DIVX profiles for doing a quality based conversion using different values, these were based on mencoder.

As I had a new profile file I decided to try and create one based on ffmpeg as I've read that that it is quicker.

I've run some tests but I am unsure of the results.

I've used the same file in all four tests, a 68min mpeg-2 file in a .TS container (1.6GB) with a divx quality of 4. timings are approximate (hh:mm)

VirtualDub - 0:25
DIVX Normal - 1:30
mencoder profile - 1:15
ffmpeg - 0:09

The mencoder value is consistant with what I have had previously, the DIVX Normal was surprising, it's the ffmpeg against the Vdub results the have confused me, VDub is usually regarded as the fastest converter between video formats. I've checked the output file and it is consistent with the file size I was expecting to see.

The news is not all good, I seem unable to force a cbr bitrate for the audio and because neither comskip or showanalyser appear to be able to top and tale the file I am having to edit it in VDub, the vbr audio is causes a progressive loss of audio sync across the file. I am aware of a bug in FFMPEG from about two years ago where CBR was reported as VBR, are you running a version that old?

My profile looks like this

[DivX TEST]
Description=DIVX test profile.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vcodec mpeg4 -vtag xvid -qscale:v 3 -f avi -flags +mv4+aic -g 300 -dts_delta_threshold 0 -sn
ffmpeg-audio=-acodec ac3 -ab 160k
ffmpeg-audioac3=-acodec ac3 -ab 256k
ffmpeg-ext=.avi
ffmpeg-audiodelay=skip
PreConversionCommercialRemover=true
May 3, 2014 at 4:52 AM
you've lost me. What exactly is the issue? Is comskip not able to process the file?
Also please upload your conversion log file.


May 3, 2014 at 2:39 PM
Sorry it was later than I realised when I posted.

There are two problems.

Neither comskip or showanalyser seem to removing the start, commercials and end of the file.

The audio on the file is VBR, I have had this problem with a number of other converters, if the audio is not CBR is drifts as the file is processed so on a film it can be as much as 2 seconds out by the end of the file, you can't use an offset to fix it as there is no fixed amount.

The log file is on the following

https://drive.google.com/file/d/0B0c_ymiNgQNJVVJub2dzeTdVUk0/edit?usp=sharing
May 3, 2014 at 2:55 PM
Looks like Shownanalyzer is hanging
> ERROR> --> No response from process for 300 seconds, process likely hung - killing it


This happens with Shownanalyzer sometimes, try rebooting your machine.
Also do one pass with Comskip and upload the log file. You can cancel the conversion once the commercial detection phase is done and attach the log file.



Marked as answer by rboy1 on 5/4/2014 at 9:50 AM
May 3, 2014 at 6:16 PM
OK I've done some more testing.

Showanalyzer is now working, the test I uploaded was from last night after I had installed 2.3.15 and without a re-boot, after closing down overnight it is doing something , but both of them are only partially working.

They both appear to be removing a 2 1/2 minute section out of the middle of the start section but not the rest of it, the commercial in the middle and the end section.

The file is comprised of the following

00:00 - 05:30 lead in
05:39 - 13:00 part one
13:00 - 18:22 commercial
18:22 - 31:18 part two
31:18 - 38:05 lead out

Comskip run

https://drive.google.com/file/d/0B0c_ymiNgQNJc1E1S3Q1NDVNOU0/edit?usp=sharing

Showanalyzer run

https://drive.google.com/file/d/0B0c_ymiNgQNJV0Q4ZklRcTdqdmM/edit?usp=sharing

In regard the audio, I have done some more testing but with mixed results, it is possible, although I am not 100% certain that the audio is actually CBR even though it is reported as VBR. I've tested 4 files with no commercial removal.

1/2 hour - -1/2 second offset
1 hour - -1/2 second offset
1 hour - no offset
2 hour - no offset

all four files are from different channels I'll try and do some more testing with files of different lengths on the same channel to see if there is any consistency there
May 3, 2014 at 7:41 PM
aah so now it's a question of tweaking it. I would suggest that you need to look at the comskip log files and tweak the ini file to find the setting that works for you. There are other profile on the mcebuddy server uploaded by users for other channels/countries. you can see if any of those work for you.

Feel free to add your customized ini's back to the server also.