This project has moved. For the latest updates, please go here.

Selecting a certain audio stream lets conversion fail, error codes differ each time

May 30, 2014 at 4:15 PM
Edited May 30, 2014 at 4:17 PM
Within another thread, i got the below recommended parameters (at the bottom of this post)...


using a *.wtv input file with 2 audio streams (0.0, 0.1) and one video stream (0.2) the conversion to MJPG and audio 0.1 worked out fine right away-

now, changing the job settings to use video and audio 0.0 won't work, with varying error reasons;

first I got things like the following (there's the indication to changed probesize again which made me open the original thread, but it seems probesize is not the issue)-
014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [h264 @ 00000000024ff680] non-existing PPS 0 referenced
2014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [h264 @ 00000000024ff680] decode_slice_header error
2014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [h264 @ 00000000024ff680] no frame!
2014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [h264 @ 00000000024ff680] mmco: unref short failure
2014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo -->     Last message repeated 5 times
2014-05-30T15:24:20 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [wtv @ 00000000024fd760] Stream #3: not enough frames to estimate rate; consider increasing probesize
or a message log like this
:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> Setting Audio Channels to 6
WARNING> 2014-05-29T23:53:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> AC3 Codec not detected, FFMPEG may not support > 2 channels for other audio codecs. May lead to failure of conversion
INFORMATION> 2014-05-29T23:53:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> Setting up Output filename
INFORMATION> 2014-05-29T23:53:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> Replacing user specified parameters
2014-05-29T23:53:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> Command line parameters -> -threads 0 -y -i "H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE.ts" -ss 3 -vf yadif=0:-1,hqdn3d,crop=1920:1072:0:4,scale=min(480\,iw):272 -vcodec mjpeg -vtag MJPG -qscale 9 -r 15 -f avi -acodec libmp3lame -ab 96k -map 0:0 -map 0:2 -ac 6 "H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE-converted.avi"
INFORMATION> 2014-05-29T23:53:20 MCEBuddy.Transcode.ConvertWithFfmpeg --> Converting the video - Main conversion
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffmpeg.exe
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg --> Process arguments  -probesize 100M -analyzeduration 300M -threads 0 -y -i "H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE.ts" -ss 3 -vf yadif=0:-1,hqdn3d,crop=1920:1072:0:4,scale=min(480\,iw):272 -vcodec mjpeg -vtag MJPG -qscale 9 -r 15 -f avi -acodec libmp3lame -ab 96k -map 0:0 -map 0:2 -ac 6 "H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE-converted.avi"
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg --> ffmpeg version N-52523-g0fb64da Copyright (c) 2000-2013 the FFmpeg developers
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   built on Apr 28 2013 00:06:14 with gcc 4.7.3 (GCC)
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libavutil      52. 27.101 / 52. 27.101
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libavcodec     55.  6.100 / 55.  6.100
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libavformat    55.  3.100 / 55.  3.100
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libavdevice    55.  0.100 / 55.  0.100
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libavfilter     3. 61.100 /  3. 61.100
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libswscale      2.  2.100 /  2.  2.100
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libswresample   0. 17.102 /  0. 17.102
2014-05-29T23:53:20 MCEBuddy.AppWrapper.FFmpeg -->   libpostproc    52.  3.100 / 52.  3.100
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> Input #0, mpegts, from 'H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE.ts':
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->   Duration: 01:27:43.02, start: 1.400000, bitrate: 14271 kb/s
--> Video duration=5263.02
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->   Program 1 
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Metadata:
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->       service_name    : Service01
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->       service_provider: FFmpeg
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Stream #0:0[0x100](deu): Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, 5.1(side), fltp, 384 kb/s
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Stream #0:1[0x101](eng): Audio: ac3 ([129][0][0][0] / 0x0081), 48000 Hz, stereo, fltp, 384 kb/s
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Stream #0:2[0x102]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> Please use -q:a or -q:v, -qscale is ambiguous
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> [libmp3lame @ 0000000004743a80] Specified channel layout '5.1' is not supported
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> Output #0, avi, to 'H:\VideoConv\_WD\working0\Hotel Transsilvanien_DE-converted.avi':
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Stream #0:0(deu): Audio: mp3, 48000 Hz, 5.1, fltp, 96 kb/s
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->     Stream #0:1: Video: mjpeg (MJPG / 0x47504A4D), yuvj420p, 480x272 [SAR 68:67 DAR 120:67], q=2-31, 200 kb/s, 90k tbn, 15 tbc
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> Stream mapping:
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->   Stream #0:0 -> #0:0 (ac3 -> libmp3lame)
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg -->   Stream #0:2 -> #0:1 (mpeg2video -> mjpeg)
2014-05-29T23:53:38 MCEBuddy.AppWrapper.FFmpeg --> Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
ERROR> 2014-05-29T23:53:40 MCEBuddy.Transcode.ConvertWithFfmpeg --> FFMpeg conversion failed
the interesting point is that between converting with audio stream 0.1 and later stream 0.0 I didn't change anything on the parameters in the profile; when direct conversion with stream 0.0 failed I also tried to first remux *.wtv with TS Unprocessed profile (this worked fine) and then to MJPG...

btw, using Media Center to play the .wtv or VLC to run the remuxed .ts file renders both audio streams 0.0 and 0.1 perfectly, so it doesn't seem to be a recording issue-

if it helps I can upload complete logs of course-

Thx
RRRMO




rboy1 wrote:
Quick point:
If you want to continue this please start a new thread, your current issue is no longer related to probesizes etc.

Coming to your issue, your profile is setup incorrectly which is why MCEBuddy is failing
  1. Since you're using a custom scaling (scale=min...) you need to specify FixedResolution=true, otherwise MCEBuddy tries to set it own resolution and the conversion fails.
  2. Since you're specifying a custom scale/resolution you also need to include the crop information information BEFORE the scale or set SkipCropping=true otherwise the conversion will fail because MCEBuddy will add a custom crop at the end and by ffmpeg filter chain rules, crop needs to come before scale.
So the profile that works for you will look like:
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1,hqdn3d,crop=iw:ih:0:0,scale=min(480\,iw):272 -vcodec mjpeg -vtag MJPG -qscale 9 -r 15 -f avi
ffmpeg-audio=-acodec libmp3lame -ab 96k
ffmpeg-audioac3=-acodec libmp3lame -ab 96k
ffmpeg-ext=.avi
ffmpeg-audiodelay=skip
FixedResolution=true
Coordinator
May 30, 2014 at 4:58 PM
Edited Jun 2, 2014 at 10:58 PM
The issue is here [libmp3lame @ 0000000004743a80] Specified channel layout '5.1' is not supported You are using mp3 codec. MP3 does not support 5.1 audio. In your settings you've enabled Multi channel audio. One track is stereo so no issues there. The other track is 5.1 so when it tries to keep the 5.1 it fails due to incompatabity. In your profile add the line
2ChannelAudio=true
It should solve your problem.
Marked as answer by rboy1 on 6/2/2014 at 3:58 PM
May 30, 2014 at 7:13 PM
that would actually explain some failed conversions of the past since I use to record a lot of satellite broadcasts that come with a Dolby and a Stereo stream-

I noticed the 5.1 message but then FFMPEG comes with quite a bit of error messages and still converts, didn't consider this particular one as far as to think about the conflict with the mp3 format...

I'm giving the 2ChannelAudio a try now-

but in general, the support is admirable and shows the enthusiasm behind this-
think I'm going to join Early Adopter now -

will post on success of the conversion-

Thx
RRRMO
Apr 13, 2015 at 11:21 AM
a bit delayed but anyway...

the conversion actually worked and I actually joined EA now :-)