This project has moved and is read-only. For the latest updates, please go here.

Hardware encoding hanging

Jun 11, 2014 at 11:30 PM
Ok I have MCEBuddy working great on wtv, DVD (movies and tv) and home video conversions. The last thing I am trying to do is do Blu Ray m2ts to mp4. No matter what setting I try it keeps getting stuck at 3%.

Copy of the log file is here:

https://www.dropbox.com/s/6m38deu45qggu0p/00067.m2ts-mce%20tst%20files-2014-06-11T01-05-41.1379982-05-00.log

Handbrake with MCEBuddy should be able to handle this because I can use the same file in Vidcoder and I processes fine. Please let me know if you see what I need to do to fix this.

Thanks
Jun 12, 2014 at 12:15 AM
The problem if your driver version (you are using hardware encoding and your driver is hanging).

2014-06-11T01:06:00 MCEBuddy.AppWrapper.Handbrake --> [01:06:00] - driver version: 10.18.10.3621


This is an unstable driver. Search the forum another user recently had a similar problem and after update to the stable driver it started working fine.



Marked as answer by rboy1 on 6/11/2014 at 10:58 PM
Jun 12, 2014 at 1:49 AM
Ok I have search and search for the driver 10.18.10.3379 and Intel does not list it anymore. I would have thought there would be a link to older drivers on their site but I have had no luck finding it anywhere. I am sorry I have to ask but where would I get that one. I have a 4600 intel graphics running on windows 8.1 64 bit.
Jun 12, 2014 at 2:51 AM
Jun 12, 2014 at 3:27 AM
Thank you for the link but rboy is saying I need 3379 and that is driver 3574. I did search on softpedia but the only download for 3379 is a cab file. Rboy is the 3574 driver ok or do you have a link to 3379?
Jun 12, 2014 at 6:58 AM
It's available through the Windows Update. Uninstall and delete your existing Intel driver, then use Windows Update and it should automatically install this driver.
Marked as answer by rboy1 on 6/11/2014 at 10:58 PM
Jun 12, 2014 at 7:19 AM
Marked as answer by rboy1 on 6/11/2014 at 11:19 PM
Jun 12, 2014 at 3:51 PM
Edited Jun 12, 2014 at 4:01 PM
Ok I downloaded the 64bit cab. Thank you for the link. I placed it in d:\driver. Did some reasearch to find out how to install on windows 8.1 and typed the following

dism /online /add-package /packagepath:d:\driver\intel_10.18.10.3379_x64.cab

It did not install. Is there a different way to intall a cab file in windows 8.1?
Jun 12, 2014 at 6:16 PM
I ended up extracting the cab file and loading the driver. It would seem to be working now. Thanks for your help.
Sep 13, 2014 at 3:02 PM
Edited Sep 13, 2014 at 3:39 PM
To clarify for other users.
  1. Extract the CAB/ZIP file contents into a folder (x86 or x64 depending upon your system),
  2. Open Device Manager (from Control Panel).
  3. Look for Display Adapters,
  4. Expand it, (note the NAME of your graphics card you will need this in Step 12)
  5. Right click on your Intel graphics device and select "Update Driver Software".
  6. Select "Browse my computer for driver software",
  7. Select "Let me pick from a list of device drivers from my computer"
  8. Click on Have Disk
  9. Click Browse and select the folder where you extracted the file driver files in Step 1
  10. Select the setup information file "igdlh" and Click "Open"
  11. Click "OK"
  12. Select your Graphics card (see the name you noted in Step 4), name SURE you select the correct name here or it won't work
  13. Click "Next". If it gives a Update Driver Warning about "device driver is not recommended ..." go back and select the right Device Name. Do NOT proceed with the wrong device name as it may crash your system.
  14. It'll give a warning about "Windows can't verify the publisher...", Click "Install this driver anyway"
  15. It'll install the driver, you may need to reboot
Marked as answer by rboy1 on 9/13/2014 at 7:02 AM
Nov 23, 2014 at 1:00 AM
Edited Nov 23, 2014 at 1:47 AM
I'm trying to run MCEBuddy on a system with a Sandy Bridge CPU, and the latest driver is 3517 (which randomly crashes while encoding, and then MCEBuddy seems to have to start all over again with software encoding). If I try to download the setup file for 3621 it tells me my computer doesn't meet the minimum requirements (it appears that driver is only good for Haswell and Ivy Bridge CPUs.) If I try to extract the cab/zip of 3379 it doesn't show me any options for HD Graphics 3000, and if I try to force any other driver like 'HD Family Graphics' it insists the driver is not compatible with my hardware. Do you have a version of that driver with HD Graphics 3000 drivers included?

Edit: Found out it just didn't like the first video I tried to convert, once I tried a different show it successfully converted a file using hardware encoding.
Nov 23, 2014 at 2:15 AM
Unforunately no, try to google and see if you can get the stable versions from some websites or maybe even Intel's archive. I generally use the version provided by Windows update try it. Uninstall the display driver AND select the option to delete the driver. Refresh, you may need to repeat this step a few times until all installed versio of the intel driver are deleted then use Windows Update to get the latest WHQL driver. Unfortunately Intel is notorious for unstable drivers (for as long as I've been working with them - 20+ years now)
Nov 23, 2014 at 2:41 AM
Edited Nov 23, 2014 at 2:48 AM
I noticed even when it seemed to successfully go through hardware encoding, when it got to the phase where it remuxed the mpeg4 into wtv (profile: WTV) that it basically reconverted all over again with 2.4.1/beta so I went back to 2.3.15 and it seems like it's working more stably all around with hardware encoding.

The convert phase lasts about 7-10 minutes for every 30 minutes of show, and then it rolls that into an WTV file very quickly on 2.3.15. On 2.4.1 it would convert for 7-10 minutes, then when it got to the phase where it moves the mpeg4 into WTV and it would tell me 25-30 additional minutes for that step.

Edit: Looks like it might be a moot point anyway though - I was trying to use another computer other than my Media Center to convert with, one that has Quicksync support. The hope was that I could get the WTV profile to work, but even with 2.3.15, and even hardware encoded I still don't get any picture on extenders if the WTV file is compressed.
Nov 23, 2014 at 2:50 AM
Edited Nov 23, 2014 at 2:50 AM
Can you please upload/post link to conversion log files from 2.4.1 and 2.3.15 - I would like to see in depth what's going on between the two. It would help us figure out what's going on and why.

thanks
Nov 23, 2014 at 2:50 AM
conversion log files
Nov 23, 2014 at 3:06 AM
When I uninstalled 2.4.1 I uninstalled, and deleted the entire folder so the logs were lost for that one. I'll need to uninstall 2.3.15 and install 2.4.1 to reobtain some logs from it. I do still have the logs from 2.3.15 though where it seemed to succeed but then just presented a blank screen on the extender. Although I'm wondering now if I'm still misreading the post on WTV. It says WTV is working on 2.3.15 and later, and that hardware encoded h.264 should work on the Xbox now right? It says using mpeg4, and that's what the profile 'WTV' uses right?

Quote: 'WTV - Now stores H.264 as the encoded video in WTV' and 'Hardware encoded H.264 WTV (using MP4 profiles and handbrake-remuxto=.wtv option) can now be played back by Media Center and XBox 360'.

Or am I reading that wrong?
Nov 23, 2014 at 3:31 AM
You are reading it right. It works.
Nov 23, 2014 at 3:35 AM
Edited Nov 23, 2014 at 3:38 AM
Ok, I'll upload the log where it completes but then just presents in a black screen on the extender then. Is the upload folder in the donator section the appropriate place to upload it?

The file name is South Park_CCHD_2014_11_19_23_32_00.wtv-WTVRecode-2014-11-22T20-18-31.4115612-06-00.log.
Nov 25, 2014 at 11:33 PM
Sorry ignore my last message, that was for a different thread.
Nov 25, 2014 at 11:36 PM
I checked your logs and it looks pretty good. This is the one with 2.3.15, can you upload the log from 2.4.1 also to compare.