This project has moved and is read-only. For the latest updates, please go here.

Conversion from AVI file loses audio

Jul 13, 2014 at 7:05 PM
Using on Win7-64

The source AVI file plays and sounds fine in VLC and Media Player. I've tried all combinations that I can think of when converting to MP4 or WMV but there just isn't any audio. MCEBuddy reports the audio of the source file to be:

Audio 1
Language : <Default>
Codec : pcm_s16le
Channels : 2

Audio 2
Language : <Default>
Codec : pcm_s16le
Channels : 2

...and doesn't report any audio at all for the file after conversion to MP4 either using Handbrake or FFmpeg.

If I could attach a file to this discussion, I'd attach the conversion log. Please let me know how if it will be helpful.

Many thanks,
Jul 13, 2014 at 11:06 PM
upload hte conversion log to the mcebuddy server or to ahosting site like dropbox and paste the link here

Jul 29, 2014 at 7:13 PM
I've just tried again - still no audio - the log file is here:
Aug 7, 2014 at 8:23 PM
It looks like your original AVI file has an unsupported aac audio implementation

2014-07-29T18:59:34 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [aac @ 0000000000364ea0] channel element 0.0 is not allocated
2014-07-29T18:59:34 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [aac @ 0000000000364ea0] More than one AAC RDB per ADTS frame is not implemented. Update your FFmpeg version to the newest one from Git. If the problem still occurs, it means that your file has a feature which has not been implemented.

Can you upload a copy of your original AVI file to the MCEBuddy server for analysis.

Marked as answer by rboy1 on 8/11/2014 at 7:38 AM
Aug 11, 2014 at 3:38 PM
Were you able to upload the original video?
Aug 11, 2014 at 4:31 PM
Many thanks for your replies. I'm not sure I can upload the video itself as it's subject to all manner of confidentiality and privacy issues (it's a video of a therapy session, including toddlers) but if I can chop a clip which isn't actually showing people in it, I can try to upload that.
Aug 11, 2014 at 4:56 PM
That should be fine, on the server is a tool called FileSplitter, use that to Chop it up into 20MB blocks. I need to FIRST block (chunk001) to analyze.