This project has moved. For the latest updates, please go here.

Deleting failed conversions

Oct 13, 2014 at 2:15 AM
Edited Oct 13, 2014 at 2:17 AM
It appears that my MCE Buddy is deleting not only successful, but also failed conversions. I was just looking at why shows were backing up, and saw that a conversion was going to take over 24 hours to finish. So I hit the stop button and then startt, and the show disappeared out of recorded TV. It's been deleted even though the conversion failed. Is this normal behaviour?

Using 2.3.15 . There have been a few instances lately where shows have gone missing, i'm wondering if this is the culprit?
2014-10-13T11:59:26 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 33.70 % (24.20 fps, avg 0.83 fps, ETA 21h40m57s)
2014-10-13T11:59:26 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 33.70 % (24.20 fps, avg 0.83 fps, ETA 21h40m57s)
ERROR> --> Job cancelled, killing process
2014-10-13T11:59:27 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 33.71 % (24.20 fps, avg 0.83 fps, ETA 21h40m57s)
ERROR> 2014-10-13T11:59:27 MCEBuddy.Transcode.ConvertWithHandbrake --> Handbrake conversion failed
2014-10-13T11:59:27 MCEBuddy.Transcode.ConvertWithHandbrake --> Conversion: Percentage Complete 33.71
ERROR> 2014-10-13T11:59:27 MCEBuddy.Transcode.ConvertWithHandbrake --> Conversion of video failed
ERROR> 2014-10-13T11:59:27 MCEBuddy.Transcode.Convert --> Handbrake did not convert successfully, using fallback if configured
ERROR> 2014-10-13T11:59:27 MCEBuddy.Transcode.Convert --> Unable to convert file Scorpion_Ten Digital_2014_10_12_18_25_00.ts using profile MP4 Normal
ERROR> 2014-10-13T11:59:27 MCEBuddy.Engine.ConversionJob --> Conversion failed
INFORMATION> 2014-10-13T11:59:27 MCEBuddy.Engine.ConversionJob --> 
--> Performance Metrics for the Current Conversion
--> 

--> Source video duration (hh:mm:ss) -> 01:04:47
--> Source video codec -> mpeg2video
--> Source video height -> 576
--> Source video width -> 720
--> Pre-conversion video duration (hh:mm:ss) -> 01:04:47
--> 

--> <Start At>  <Duration (hh:mm:ss)>   <Activity>
--> <10/13/2014 00:47:09>   <00:00:00>  <Running custom commands>
--> <10/13/2014 00:47:09>   <00:00:03>  <Getting show information and banner from Internet sources>
--> <10/13/2014 00:47:13>   <00:00:00>  <Running custom commands>
--> <10/13/2014 00:47:13>   <00:00:00>  <Checking for disk space>
--> <10/13/2014 00:47:13>   <00:05:44>  <Remuxing recording>
--> <10/13/2014 00:52:58>   <00:00:00>  <Trimming video recording>
--> <10/13/2014 00:52:58>   <00:04:58>  <Comskip advertisement scan>
--> <10/13/2014 00:57:57>   <00:00:08>  <Analyzing video information>
--> <10/13/2014 00:58:06>   <00:00:00>  <Running custom commands>
--> <10/13/2014 00:58:06>   <00:00:08>  <Analyzing video information>
--> <10/13/2014 00:58:14>   <11:01:12>  <Converting>
--> 

INFORMATION> --> Total time taken by conversion (hh:mm:ss) -> 11:12:18
Coordinator
Oct 13, 2014 at 6:04 AM
No MCEBuddy does not delete source files if the conversion has failed. Attach your mcebuddy.log file (upload and post link) it'll show which files are being deleted by MCEBuddy.

Anyways, a stop is NOT a failure, it's a 'cancellation'. And when the engine isn't running MCEBuddy won't delete files. Again need to mcebuddy.log file to see what's going on.
Coordinator
Oct 13, 2014 at 6:12 AM
Also please upload the full conversion log, partial logs aren't helpful. There are many questions but we'd rather look at hte logs to figure out what's going on. First up, are you running multiple conversion tasks or a single conversion task ?
Oct 13, 2014 at 6:45 AM
Thanks for the awesomely quick reply. Sorry for not posting logs the first time :-)

I've zipped the mcebuddy.log and the full conversion log of the file that went missing
https://mega.co.nz/#!gQFi3Yxb!C7Cb2O8g6ZjxAPZ07fruRn2pciLD3saVkElrYUfN1RE

I'm only running a single conversion task. You might see a lot of interrupted conversions in the logs as i've had some weird issues lately where media player likes to use 100% of the CPU so there have been lots of reboots. It might be rebuild time already. Win 8.1 does some strange things.
Coordinator
Oct 13, 2014 at 4:06 PM
Couple of things I noticed in your logs:
  1. You've running a very old version of 2.3.15 BETA. Please upgrade to 2.3.15 release or 2.4.1 BETA (better yet). Lots of bugs fixes since then
  2. Importantly the mcebuddy.log file doesn't show that it is deleting Scorpion_Ten Digital_2014_10_12_18_25_00.ts (it has deleted other files but not this one) so it leads to think that something else is deleting these files apart from MCEBuddy
  3. To confirm the above, after updating to the latest build enable the option for use recycle bin in the expert settings. That way any file deleted (excluding temp folder) will be sent to the recycle bin. If you find the file in the recycle bin after a cancellation it was done by MCEBuddy otherwise it was done by some other program
Marked as answer by rboy1 on 10/28/2014 at 12:13 AM
Oct 16, 2014 at 2:58 AM
Thanks i've been giving 2.4.1 a run for the last couple of days and all seems good so far. Will monitor and report back.