This project has moved. For the latest updates, please go here.

ffmpeg-SubtitleBurn=true

Feb 22, 2015 at 8:35 AM
Since we got everything working fine with cutting commercials, synching the subtitles, and burning a new video file via MCEBuddy 2.4, I installed it on my other machine that I use only as a MediaCenter.

Everything is working fine.....except instead of having the subtitles burned into the resulting video files, I'm getting a separate SRT file.

Both computers have the exact same profile.conf and mcebuddy.conf files.

Looking at the log, I see a strange discrepancy. On the computer where everything is working fine, the log shows up like this:


--> ffmpeg-SubtitleBurn=true
--> ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libxvid -b 1400k -f avi -flags +mv4+aic -g 300 -bf 1 -sn -async 1
--> order=ffmpeg
--> PreConversionCommercialRemover=true
INFORMATION> 2015-02-10T18:21:39 MCEBuddy.Transcode.ConvertWithFfmpeg --> Checking for Unsupported profile for container / codec combination
2015-02-10T18:21:39 MCEBuddy.Transcode.ConvertWithFfmpeg --> FFMPEG subtitle burn (ffmpeg-SubtitleBurn) : True


In the one that is working incorrectly, it shows up like this:

--> ffmpeg-SubtitleBurn=true
--> ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libxvid -b 1400k -f avi -flags +mv4+aic -g 300 -bf 1 -sn -async 1
--> order=ffmpeg
--> PreConversionCommercialRemover=true
INFORMATION> 2015-02-21T00:29:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> Checking for Unsupported profile for container / codec combination
INFORMATION> 2015-02-21T00:29:59 MCEBuddy.Transcode.Convert --> Converting with FFMpeg
2015-02-21T00:29:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> Main conversion routine DEBUG

......THEN ABOUT THE USUAL 15 lines....and then this:

2015-02-21T00:29:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> FFMPEG subtitle burn (SubtitleBurn) : False
2015-02-21T00:29:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> Working Path : C:\Program Files\MCEBuddy2x\working0


So at some point, it's sending out SubtitleBurn=false.

The only difference between the two computers is that the one where everything is working fine is 64 bit. The one that is having issues is 32 bit.

I am uploading the log of the incorrect version so perhaps you can see where you think the problem is.

Thanks.
Coordinator
Feb 22, 2015 at 3:59 PM
That's likely because you're using different builds on the machines. In the 2.4 BETA versions the subtitle burn was limited to ffmpeg. The newer builds (and 2.4 release version) we've added support subtitle burning for all encoders and removed the ffmepg specific burn option (see the readme file).

The profile option now is:
SubtitleBurn=true


Marked as answer by rboy1 on 2/22/2015 at 9:00 AM
Coordinator
Feb 22, 2015 at 4:00 PM
Edited Feb 22, 2015 at 4:00 PM
See the difference, you're using different builds:
BETA Build:
2015-02-10T18:21:39 MCEBuddy.Transcode.ConvertWithFfmpeg --> FFMPEG subtitle burn (ffmpeg-SubtitleBurn) : True
Release Build:
2015-02-21T00:29:59 MCEBuddy.Transcode.ConvertWithFfmpeg --> FFMPEG subtitle burn (SubtitleBurn) : False
Different parameters
Feb 22, 2015 at 11:56 PM
Thanks - that solved the problem. I see what the problem was - when you gave me the custom coding for the profile I was using, I just cut and pasted that into the new conf file. Changed it and eliminated the ffmpeg part of that line and now it's working properly.

One more question - there are a few programs that I don't necessarily want subtitles on. Is there a way to configure the profile to burn in subtitles for some things but not for others? I wouldn't think so since its in the default, but figured I'd ask....
Coordinator
Feb 23, 2015 at 12:00 AM
no since it's linked to a profile for now you will need 2 separate profiles and 2 separate conversion tasks to do it.