Best quality transcode regardless of size

Mar 19, 2015 at 9:01 PM
I am working with MCE 2.4.1 with WMC and Plex Win 8.1 App.

The issue is, uncompressed files present an audio sync issue on Plex.

Transcoded files work fine but the quality is slightly degraded. I have tried all presets for handbreak and ffmpeg with -q 0 and -preset fast but its still degraded.

Does anybody have any ideas on how to produce the absolute best quality file? I dont care about space Ill just expand my raid. Looking for the cleanest picture possible.

Recording different channels so its probably a mix of 720p and 1080i.

Anybody got any thoughts?

Thanks
Mar 19, 2015 at 9:04 PM
So ideally it would be uncompressed thus the transcode would go fairly quick. But Im open to suggestions.
Coordinator
Mar 20, 2015 at 6:07 AM
Using preset fast isn't a good idea since it essentially is a lossy preset. You should use a slow or slowest preset to get the best quality. Also try using q 1 - not sure how we'll 0 works. Worth a shot. Also check the max resolution setting make sure it's all the way to the right in the conversion task settings.
I would suggest you start with the mp4 high quality profile as your base and go from there.
Post your entire profile to get ideas on how it can be improved (like trellis etc)

Marked as answer by rboy1 on 4/28/2015 at 12:32 PM
Mar 20, 2015 at 2:50 PM
The slowest preset gets you the best quality for the smallest file, but obviously is quite slow.
Under the "Lossless H.264" in https://trac.ffmpeg.org/wiki/Encode/H.264 it says: Lossless Example (fastest encoding) ffmpeg -i input -c:v libx264 -preset ultrafast -qp 0 output.mkv

For the best compression I would use very slow, but I don't care about file size. I want the best quality possible with no regard to file size. So lossless uncompressed should be the way to go but I still see quality loss. I can only assume from a 1080i source going to a progressive codec. But am not sure. Hell I'll even go to a MPEG2 codec to maintain quality. Just cant be uncompressed because of a timing issue.
Coordinator
Mar 20, 2015 at 3:03 PM
I don't believe that's correct. Ultra fast is the lowest quality where as slowest is best quality (and also consequently smaller size due to intra frame optimization and b frames)

But keep that aside create your own profile. Use the mp4 high quality profile. Move the quality slider all the way to the right and also the max resolution slider in conversion task settings. Try it and I think you'll be happy with the results.

Make sure you're using the latest beta build. There was a quality slider bug that was recently squashed.

Mar 22, 2015 at 4:59 PM
So the quality on the transcode had to do with MCEBuddy talking to handbreak/ffmpeg. Regardless of the quality slider, it was messing up the output quality. Once it off, the quality was perfect and fast using -q 0. Did a fresh install and the quality slider works now.

I am going to continue to use -q 0 since its fast and lossess. Ill do compression alter.


Thanks for you help rboy.
Coordinator
Mar 23, 2015 at 8:02 AM
Yes that's what I had said. We recently fixed a bug where mcebuddy was incorrectly calculating the quality with the slider. This only affected profiles which use quality and did not affect bitrate based profiles. Anyone using quality based profiles please update to the latest build.

Mar 23, 2015 at 3:35 PM
I did a uninstall of 2.4.1 and did an install of 2.4.1.

Must have been a bad installed first time around.
Coordinator
Mar 24, 2015 at 5:01 AM
The bug is there is 2.4.1. It was fixed in the recent 2.4.2 build. I would recommend you use the latest 2.4.2 build.

Marked as answer by rboy1 on 4/28/2015 at 12:32 PM
Mar 24, 2015 at 4:31 PM
son of a