This project has moved and is read-only. For the latest updates, please go here.

NAS credentials

Sep 26, 2015 at 1:45 AM
I've not had a problem converting and saving to and from my Synology NAS but for some reason, it no longer seems to work. It goes thru the conversion but when it goes to save the converted files, nothing happens.
The log states, "Moving converted file to destination failed" so I've tried both my computer log in and password as well as my NAS login and password and the same thing happens no matter which one.
I've yet to uninstall and reinstall but wondered what to try next. Any ideas?
Sep 26, 2015 at 3:10 AM
Any code with the error?

Sep 26, 2015 at 3:16 AM

Thanks for asking. This is what I see but I can say I’ve changed nothings from when it was working last weekend.

INFORMATION> 2015-09-25T20:14:40 MCEBuddy.Engine.ConversionJob --> Fallback to source path

WARNING> --> Fallback to Source Path is enabled, trying to move directory to source path -> \\BEERHOUSE\HDHomeRun\Dominion

INFORMATION> 2015-09-25T20:14:40 MCEBuddy.Engine.ConversionJob --> Moving converted file D:\Program Files\MCEBuddy2x\working0\S02E12-Day of Wrath.mkv to \\BEERHOUSE\HDHomeRun\Dominion\Dominion\Season 02\S02E12-Day of Wrath.mkv

ERROR> --> Unable to move file D:\Program Files\MCEBuddy2x\working0\S02E12-Day of Wrath.mkv to \\BEERHOUSE\HDHomeRun\Dominion

Error :System.IO.DirectoryNotFoundException: Could not find a part of the path.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

at System.IO.File.InternalMove(String sourceFileName, String destFileName, Boolean checkHost)

at MCEBuddy.Util.FileIO.MoveAndInheritPermissions(String source, String destination)

at MCEBuddy.Engine.ConversionJob.MoveConvertedFile(String subDestinationPath, Log jobLog)

ERROR> 2015-09-25T20:14:41 MCEBuddy.Engine.ConversionJob --> Moving converted file to destination failed

INFORMATION> 2015-09-25T20:14:41 MCEBuddy.Engine.ConversionJob -->

Sep 26, 2015 at 3:52 AM
check your mcebuddy.log file (thats where the NAS connections are authenticated)

Sep 26, 2015 at 4:14 AM
The log shows the correct login info, which I've never changed.
However, I can't seem to find the network credentials in the "Settings-Expert Settings" page. That page shows me nothing regarding credentials. I'm running 2.4.2. Is that the latest version?
Thanks for your help.
Sep 26, 2015 at 4:25 AM
The network credential are the monitor or conversion tasks respectively, if your destination is a NAS then it should be in the conversion task. The system setting is for Temp folders or manually added file locations

Sep 26, 2015 at 4:33 AM
Thanks for hanging in there with me.
Seems like I have it working when I show the Command Line Service. I'll monitor it over the next few nights and see how it runs.
Sep 26, 2015 at 5:09 AM
OK, I tried the same file 4 times. Twice without the CommandLIne Service started manually and twice without. Both times with the Service started manually (where I can see all the operations take place) the file is moved where it belongs. Twice without the Service started manually, it DID NOT move the file.
How can I fix it so that this works without me manually starting that service?
Sep 26, 2015 at 1:03 PM
When you're using the command line service it uses your login credentials (users's login context), when running as a service it doesn't have any credential so it falls back to the credentials you supplied. I would suggest a reboot of the machine to clear any credentials and to ensure you've entered the credetnials in your conversion tasks and monitor tasks.

Marked as answer by rboy1 on 10/15/2015 at 2:29 AM
Sep 26, 2015 at 3:26 PM
Reboot of computer and NAS didn't change anything. It's strange because it was working so well. I've run no Windows updates or even installed any new software.
I'll keep trying a few things and leave you alone but I appreciate all your time.