This project has moved and is read-only. For the latest updates, please go here.

Suggested profile changes to avoid commentary/narration channels in 2.4.3

Jan 21, 2016 at 4:37 PM
I recently upgraded from 2.3.13 to 2.4.3 to overcome issues I was having with converting NPVR video captures for my PLEX server.

I'm running Windows 10 and have a SiliconDust HDHomerun (original) which I use to capture over the air programming (NPVR). Video is captured as .ts.

I noticed that after upgrading, some of the programs which had been converted satisfactorily before now included annoying voice over narration (weather alert crawls, some action narration). After searching the documentation and forum I found that there was an old reference to a similar problem. It indicated that the voice over was coming from additional audio channels in the stream.

I tried the suggested fixes (deselecting best soundtrack, selecting audio language as <original>). None of this helped.

The documentation indicated that it is likely that the voice over was coming from one of the audio channels but I could not find a way to specify how to select the audio channels.

It occurred to me to compare the old profiles.conf to the new one. I found a change in the MP4 Normal configuration (which is what I normally use). There was an additional switch (-a 1,2,3,4,5) on each of the handbrake-audio parameters.

Old profiles.conf

handbrake-audio=-E faac -R auto -B 160 -D 0
handbrake-audioac3=-E faac -R auto -B 256 -D 0
handbrake-ext=.mp4


New profiles.conf

handbrake-audio=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 256 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4


I edited the new profiles.conf, removing the "-a 1,2,3,4,5" from both handbrake-audio parameters, and saved it.

I then restarted the MCEBuddy2x service. You need to do this from the system services console.

This seems to have corrected the problem.
Dec 10, 2016 at 8:33 PM
Edited Dec 10, 2016 at 8:35 PM
Follow up.

For some reason, this fix stopped working. The Narrative is back. I reviewed all the suggested fixes again and even upgraded from MCEBuddy version 2.4.3 to 2.4.6 (removing the -a 1,2,3,4,5 from the new profiles.com). No luck.

I selected Audio Language English (Eng) on the MP4 Normal conversion profile advanced settings as well as "Select best Soundtrack" (actually tried with and without, no diff).

I tried changing the profiles.conf [MP4 Normal] order=ffmpeg,handbrake,mencoder as it was suggested that ffmpeg might handle channel selection better. This had no effect and I changed it back to the orginal order=handbrake,ffmpeg,mencoder.

This only seems to occur on CBS prime time recordings (Blue Bolds, etc). Media info for Blue Bloods displays
Audio 1
  Language: English  (eng)
  Codec : ac3
  Channels : 6
Audio 2
   Language : Spanish (spa) (Impaired)
   Codec : ac3
   Channels : 1. 
I am at a loss as to what to try next. The narration is really annoying.
Jan 9 at 3:55 PM
Since you channels have a name (eng and spa), use the language filter in the conversion task to select the audio channel (eng). Also make sure you're on the latest release of MCEBuddy (2.4.6) as it has improved support for these issues.
Marked as answer by rboy1 on 1/9/2017 at 7:55 AM
Feb 25 at 4:38 AM
I was having the same issue as DWinx. I first tried updating my software from 2.4.3 to 2.4.6 and that did not resolve the issue. I then tried to uncheck the "Select best soundtrack" and that also did not fix the issue. I left the Select Best Soundtrack unchecked and then tried to set the Audio Language to eng as suggested by rboy1 and this so far as resolved my problem. I don't know if I would go back and select Best Sound Track to turn back on will affect this but I just left it unchecked since it was working.