This project has moved and is read-only. For the latest updates, please go here.

Adjust Quality While Using Hardware Accelaration

Sep 3, 2016 at 9:33 PM
I am using the HDHomeRun H.264 profile to remove commercials and reduce the size of video files. I recently upgraded from dedicated graphics to an nVidia GTX1060 and I am having trouble with the quality of the files when using hardware acceleration. I understand that the quality of the file with hardware acceleration will be less than if it is off, but I can't seem to adjust the kbps at all with hardware acceleration on. With HA on, I get a file that is about 800MB and right around 2200 kbps. This happens every time, no matter how I adjust the "Quality" setting. If I turn HA off, the changes in the "Quality" setting actually affect the final kbps.

The files I have are about 20,000 kbps and either 720 or 1080. My target is a file with the same resolution, but with something more like 5000 kbps.

So I guess my question is, am I supposed to be able to adjust the kpbs with HA on, or is the only way I can adjust it by turning off HA?
Sep 3, 2016 at 10:28 PM
You should be able to adjust the quality. Can you upload the conversion log

Sep 3, 2016 at 10:47 PM
Here are the log files from one with HA off and one with HA on, both set to 100% Quality. I added -HA to the one that had hardware acceleration on.

Log Files

Thank you!
Sep 4, 2016 at 2:56 PM
Thanks so had a look and the issue lies here:

 Codec AVOption crf (Select the quality for constant quality mode) specified for output file #0 (C:\Program Files\MCEBuddy2x\working0\Quantico S01E12 20160306 [20160307-0300]-converted.ts) has not been used for any stream. The most likely reason is either wrong type (e.g. a video option with no video streams) or that it is a private option of some encoder which was not actually used for any stream.

This indicates that either ffmpeg has a bug and it's not applying your user quality to the file or your video driver has an issue.

Can you download the latest build of ffmpeg from the ffmpeg site and replace it in the ffmpeg folder where MCEBuddy is installed. See if that fixes the problem. 

It would be great if another user with nvidia can try their nvidia setup with the same profile (HDHomeRun h.264) increase the quality all the way upto max in the conversion task settings and post their conversion log for a comparison. 

Sep 4, 2016 at 3:04 PM
Also can you upload your original video to the MCEBuddy server for analysis

Sep 4, 2016 at 3:18 PM
Okay, I think I did something wrong. The build of FFmpeg that I downloaded had a lot of files in it that were not in the MCEBuddy FFmpeg folder. I deleted the content of the MCEBuddy FFmpeg folder (I have a back up of it) and pasted all the files from the FFmpeg-master that I downloaded. I restarted the MCEBuddy service and tried to run the file again. Something didn't work because it only took 30 seconds. Let me know if I missed something.

I added the log file to the link below. I am also in process of uploading the original video file to the same location. It will take a little bit.

Log File

Thanks again for all the help.
Sep 4, 2016 at 5:04 PM
Should have mentioned Download the static x64 build of ffmpeg and replace the ffmpeg and ffprobe files. The reason it failed was because ffmpeg was missing.

Also I just noticed you're using an old build of MCEBuddy. Update to 2.4.5 and see if that fixes your issue.

Sep 4, 2016 at 7:52 PM
New build did not fix it, nor did the latest ffmpeg and ffprobe files. Logs in link below, "-new FFmpeg" added to the end of the one with the new FFmpeg files and the one that I screwed up from earlier has been deleted.

Log Files
Sep 5, 2016 at 1:00 AM
Can you upload the original file to the server

Sep 5, 2016 at 1:12 AM
I'm not sure how to do that. I currently have it uploaded to the same folder as the log files, but if you tell me how to upload it to your server, I will do that as well.

Just as an additional piece of information, I have tried this with different files with the same result. I was just using this episode of Quantico as a comskip test when I discovered the issue.
Sep 5, 2016 at 3:22 AM
See the read me before posting thread for details on how to upload. Please upload the entire file or the smallest file you can find to replicate the issue. How are you recording them?

Sep 5, 2016 at 6:02 AM
Sorry, there is just so much documentation that I am really not sure where to look. I feel like I have looked through it all and still haven't found a way to upload to your server. Could you point me in the right direction.


The recordings are from HDHomeRun DVR with a HDHomeRun Prime.
Sep 5, 2016 at 1:54 PM
Discussion Tab -> Sticky Posts

Sep 5, 2016 at 3:44 PM
Oh, that's where it is. Thank you.

So I uploaded the original file to the server. Title: Quantico S01E12 20160306 [20160307-0300].mpg. It was recorded with HDHomeRun DVR with a HDHomeRun Prime.

I also did a test on my brothers system using hardware acceleration with the same result. He has an NVidia GTX 1080. Is this possibly an issue with the new NVidia graphics card? Both machines have the same problem and one has the 1060 the other the 1080. Anyways, the log file has been added to the folder, it has "-1080" added to the end of it.

Thanks again for the help. Let me know if you need any additional information.
Sep 18, 2016 at 11:05 PM
Any progress on this issue? Anything else I can do to troubleshoot?
Sep 18, 2016 at 11:09 PM
We're working on it, just a little backlogged

Sep 18, 2016 at 11:11 PM
No problem. Just checking in. I really appreciate the time you are putting into it.

Thanks!