This project has moved and is read-only. For the latest updates, please go here.

New computer, conversion seems slow

Jan 18 at 7:52 PM
So I built a new computer over the weekend. I was pretty excited to see how well my computer would do with converting shows. It seems a little slow to me. I have an i7-6800k and asus 1070gtx. I have hardware acceleration enabled. it looks to be doing over 2 hours per tv show. These tv shows are 30 minutes long. My cpu usage is around 18% right now, but i'm sure it'll go up after the comskip advertisement scan. Earlier i noticed it getting stuck on analyzing show so i installed the beta version.

I'm using the HDHomerun H.264 profile since i use that device for DVR. I put max width all the way to the right for video quality and audio i keep at 0%. I also allow multi-channel bc i'm a snob and need my surround sound. Is there anything else i can look out for?
Jan 19 at 1:05 AM
try putting a check next to "Disable cropping" on the expert settings menu. Also try editing your profile in profiles.conf so ffmpeg is first. Also, add the following lines to your comskip.ini (donator version of comskip required):

lowres=10
hardware_decode=0
thread_count=4




the order line for your profile in profiles.conf should look like:

order=ffmpeg,handbrake


I also recommend a free tool called gpu-z. It will tell you if mcebuddy is using nvenc (nvidia gpu) for transcoding.
Jan 19 at 1:31 PM
Shouldn't be taking anywhere near that long. Need to look thru your logs to see if you are actually using hardware encoding.

I would think you would want to use the profile for the device that you are going to be displaying the content on, not from where you got the content.
Jan 19 at 2:46 PM
tsigwing wrote:
Shouldn't be taking anywhere near that long. Need to look thru your logs to see if you are actually using hardware encoding.

I would think you would want to use the profile for the device that you are going to be displaying the content on, not from where you got the content.
I checked logs and it's using hardware encoding. I do use hdhomerun to view the dvr'd shows. I've used this before the new computer no problem.
Jan 19 at 2:47 PM
techpro2004 wrote:
try putting a check next to "Disable cropping" on the expert settings menu. Also try editing your profile in profiles.conf so ffmpeg is first. Also, add the following lines to your comskip.ini (donator version of comskip required):

lowres=10
hardware_decode=0
thread_count=4




the order line for your profile in profiles.conf should look like:

order=ffmpeg,handbrake


I also recommend a free tool called gpu-z. It will tell you if mcebuddy is using nvenc (nvidia gpu) for transcoding.
where on gpu-z will it let me know what mcebuddy is using for transcoding?

I'll try the other things you said. I started converting 2 hours ago and now i'm seeing everything is stuck on "analyzing video information" I can post a log file if that would help.
Jan 19 at 3:23 PM
In gpu-z you will have an elevated "Video Engine Load" when converting with the gpu (nvenc). No log is necessary yet. Try "Disable cropping" first. Something tells me that that will make a difference.
Jan 19 at 4:47 PM
techpro2004 wrote:
In gpu-z you will have an elevated "Video Engine Load" when converting with the gpu (nvenc). No log is necessary yet. Try "Disable cropping" first. Something tells me that that will make a difference.
So i did that and it's still taking a really long time. the Comskip advertisement scan seems to be taking even longer. It's taking over an hour just for that.
Image
Jan 19 at 6:32 PM
At least the analyze step is much faster. Try reducing the number of concurrent conversions to one and using the donator version of comskip with the above comskip.ini modifications.
Jan 19 at 6:43 PM
techpro2004 wrote:
At least the analyze step is much faster. Try reducing the number of concurrent conversions to one and using the donator version of comskip with the above comskip.ini modifications.
any specific location in the comskip.ini file that i should place those changes?
Jan 19 at 7:31 PM
It really does not matter. I have the same changes at the bottom of my comskip.ini as it makes it easier to keep track of my changes. I hate to sound like a broken record but these changes will only work with the donator version of comskip which is NOT included in the donator version of mcebuddy.
Marked as answer by rboy1 on 2/5/2017 at 2:19 PM
Jan 19 at 7:53 PM
techpro2004 wrote:
It really does not matter. I have the same changes at the bottom of my comskip.ini as it makes it easier to keep track of my changes. I hate to sound like a broken record but these changes will only work with the donator version of comskip which is NOT included in the donator version of mcebuddy.
well i feel like an idiot. i thought the USA comcast .ini one that i downloaded after donating to mcebuddy was the one you were talkign about. There is another comskip that you have to donate for? I still dont know why it seems to take a heck of a lot longer on the new rig than my old 6 year one.
Jan 19 at 9:19 PM
i think it might be okay. i also selected the option to not reconvert videos. I think it was looking at TV shows that were already taken care of and getting stuck somehow. i did the donation for the comskip.ini and that has definitely sped things up. i'm going to test 4 or 5 conversions at the same time now. Thanks for your help
Jan 19 at 10:31 PM
You are welcome. I am glad to help. Please keep in mind that nvidia limits the number of videos you can transcode at once on their gtx series gpu.