This project has moved and is read-only. For the latest updates, please go here.

Comskip issue

Feb 25 at 3:43 PM
Edited Feb 25 at 5:31 PM
I am noticing now that I am missing the first 6 seconds of almost all shows.

I also miss the last clip of the show after last commercial.

How can I fix that?

Using standard comskip ini came with mce buddy.

The only other item I tried to see what it would do was setting the always keep firs and last tested with 30/60/90 but that didn't change anything.
Thanks

Chad
Feb 25 at 8:40 PM
Try removing "-ss 3" from the profile you are using in profiles.conf
Feb 26 at 6:33 PM
Edited Feb 26 at 7:14 PM
So in this profile what do I delete? Says handbrake first. so do I try and remove --start-at duration:3?

It cuts of the first part of the shows almost a minute - example show is Fresh off the boat.

[MP4 Fast]
Description=Fast MP4 (H.264/AAC) conversion. Fastest conversion but lower quality, more sensitive to errors in the source video.
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vcodec libx264 -b 1000k -x264opts cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec libfdk_aac -ab 128k -cutoff 18000 -map 0:a
ffmpeg-audioac3=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=--loose-anamorphic --verbose=2 -f mp4 -O
handbrake-video=--start-at duration:3 -e x264 -b 1000 -x cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto
handbrake-audio=-E faac -R auto -B 128 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
AutoDeinterlace=false
Feb 26 at 8:50 PM
Try this:




[MP4 Fast]
Description=Fast MP4 (H.264/AAC) conversion. Fastest conversion but lower quality, more sensitive to errors in the source video.
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-vcodec libx264 -b 1000k -x264opts cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec libfdk_aac -ab 128k -cutoff 18000 -map 0:a
ffmpeg-audioac3=-acodec libfdk_aac -ab 160k -cutoff 18000 -map 0:a
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
handbrake-general=--loose-anamorphic --verbose=2 -f mp4 -O
handbrake-video=-e x264 -b 1000 -x cabac=0:ref=2:bframes=1:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:b-adapt=0:threads=auto
handbrake-audio=-E faac -R auto -B 128 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E faac -R auto -B 160 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
AutoDeinterlace=false




I removed "-ss 3" from ffmpeg-video and --start-at duration:3 from handbrake-video
Feb 27 at 2:26 AM
Edited Feb 27 at 2:26 AM
That only adds 3 seconds on still missing the very first part of the show for certain shows. \

Like mentioned It cuts of the first part of the shows almost a minute - example show is Fresh off the boat.
Feb 27 at 5:01 PM
Good, we are headed in the right direction. Try adding the following to your comskip.ini


always_keep_first_seconds=120
always_keep_last_seconds=120



Make sure that you have mcebuddy set to use this comsip.ini in settings>task>expert settings>comskip ini
Feb 28 at 12:49 AM
Didn't help just added more of the show before/after. Still missing the intro to the show which is about 1 minute.
Feb 28 at 4:03 PM
try playing with the 120 value I gave you earlier. It may need to be higher but I am not sure how high in your particular case.
Mar 1 at 10:15 PM
Putting 180 value seemed to help with beginning but not end of show. Still misses the very last cut of the show.
Mar 1 at 10:23 PM
try this

always_keep_first_seconds=180
always_keep_last_seconds=200