This project has moved and is read-only. For the latest updates, please go here.

.TS Files & COMSKIP Issues

Oct 6, 2012 at 3:44 PM

With a .ts recording, if I run COMSKIP and tell it to just create an .EDL, it never gets created.  Why is this happening?

Oct 6, 2012 at 3:45 PM

Also, if .SRT files are created, the timing of them are way off no matter what offset I use.  If I don't use COMSKIP, I can set the offset to 15 which seems to work just fine.

Oct 6, 2012 at 3:55 PM

I just tested it and it appers to be working for me.


Can you please post your log file (the log file for the conversion where the EDL file is not getting created) to analyze this further.

Oct 6, 2012 at 3:56 PM

Could you upload the video to the MCEBuddy server for me to reproduce and analyze (also upload the log file for the conversion, I'll take the settings from there)

login: mcebuddy

password: mcebuddy

Oct 7, 2012 at 9:03 PM

I uploaded to /BTJustice/Chasing Classic Cars but yes .EDL files are not being created.

Oct 8, 2012 at 5:29 PM

Okay I just finished analyzing the issue:

1. Regarding the EDL file - it's being generated and also being copied to teh destination folder on my test run. I looked at your log file and I see the issue.

INFORMATION> 2012-10-06T18:22:14 MCEBuddy.Engine.ConversionJob --> Found EDL file, request to move to destination EDL:D:\Recorded TV\Chasing Classic Cars\Chasing Classic Cars_20120919_09301000.edl Destination:D:\Recorded TV\Chasing Classic Cars
WARNING> 2012-10-06T18:22:14 MCEBuddy.Engine.ConversionJob --> Unable to move EDL file to destination EDL:D:\Recorded TV\Chasing Classic Cars\Chasing Classic Cars_20120919_09301000.edl Destination:D:\Recorded TV\Chasing Classic Cars

For some reason, likely permissions in the desitnation folder, source folder and the temp working folder do not match. The EDL file is created in the source folder, copied to temp and then moved to destination. If the permissions have a conflict (e.g. user access in one folder but not the other it creates an issue). Since your MP4 file and SRT files are getting copies I would suggest a clean install of MCEBuddy (delete the installation folder and temp folders) and check the persmission on your source and destination folders.


2. Regarding the SRT file, what you're running into is a known issue (I will document it) with MEncoder and SRT files. The issue is MEncoder "compresses" the timeline as it encodes the video progressively, i.e. if the original video is 1 hr the converted video will be 56 minutes. It appears to speed up the timeline during conversion which reduces the time. This is a BUG in MEncoder, not MCEBuddy. The end result is that the SRT file is generated perfectly for 1 hour, but the converted video is 55 minutes so they keep getting out of sync progressively. No amount of "offset" can fix this.

However the good news is (and verified) that you can use a Handbrake based profile to do the conversion and it solves the problem. Handbrake converted the file perfectly w.r.t the timelines. So your 15 offset with a Handbrake profile (e.g. MP4 Fast or M4V High Quality) work PERFECTLY. I would suggest you create a new profile with a the MP4 Fast profile or M4V profile as a baseline using Handbrake as the encoder of choice. (or you could use the M4V High Quality profile and use the RenameExt=.mp4 directive at the end of the profile). This should solve your problem.


Let me know if the above solves your problems.

Oct 11, 2012 at 11:53 AM
Edited Oct 11, 2012 at 11:54 AM

I am having hit or miss luck using HandBrake and Comskip.  Sometimes the SRT files are spot on.  Sometimes the SRT gets messed up.  Things will be said and are not shown.  Sometimes the timing is WAY off and it is never the same amongst different files.  Sometimes it might be 6 seconds off.  Other times it might be 20 seconds off.  Here is the profile I came up with...

[.TS to .MP4 Cut Commercials]
Description=2 pass conversion of .TS to .MP4 with HandBrake using 1000 video and 160 audio bitrates.  Resolution is fixed at the same resolution used in NPVR and cropping is disabled.
handbrake-general=--decomb --denoise="medium" --loose-anamorphic --verbose=2 -2 -T -f mp4
handbrake-video=-e x264 -b 1000 -x cabac=0:ref=2:bframes=0:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex
handbrake-audio=-E faac -6 auto -R auto -B 160 -D 0
handbrake-audioac3=-E faac -6 auto -R auto -B 160 -D 0

Oct 11, 2012 at 12:03 PM

Also on the .EDL files they are still not being created.  I checked the folder permissions and they all look good.  And it would seem they are set correctly as the resulting .SRT (good or bad) and the .MP4 go to the folders just fine.

Oct 11, 2012 at 9:27 PM

regarding the EDL, the log file seems to indicate some problem while moving it:

Try the following:

1. Do a clean install (delete the install directory after uninstall)

2. Try to change the output directory


Regarding the SRT, can you try with a FFMPEG based profile and see if it make any difference?

Oct 20, 2012 at 8:18 PM
Edited Oct 21, 2012 at 1:56 AM

I am still fighting this.  I am using a HandBrake profile.  During conversion, I see these file extensions in the destination folder with the original .TS...


In the working0 folder is the .MP4 and .SRT files.

Once complete, those files will move over to the destination folder and the file extensions listed above disappear.  So all that is left are .MP4, .SRT, and .TS.

Oct 20, 2012 at 8:55 PM

BTJustice, I've tried this on 4 different laptops/computers I have and in every case the EDL file is getting copied to the output. Also your log is indicating that EDL file is there but it ends up with an error while trying to move it.

It's likely a permissions issue with your file system. Possibly the permission that comskip is using to create the EDL file is incomptaible with the destination file system (since Comskip is creating the EDL file).

The only thing I can suggest is try to install MCEBuddy on a different drive/folder and change your location of the videos/destination. You'll need to dig deeper to understand what permissions the EDL file and the destination folder have (try to right click and pull up the permissions on the EDL file and destination folder.


Also - I suspect one reason for this issue, the temp folder is created with special administrative rights so that MCEbuddy can write to them in the program files folder. It's possible that those special rights are incompatible with your destination folder and is impacting the EDL file.

Try this:  Change the temp folder location from the settings page and then try a conversion (put the temp folder on a different drive, like D: (not windows installation drive). I think this might solve your problem.

Let me know.

Oct 20, 2012 at 9:02 PM

Hold on a sec: I looked at the logs carefully, what I see:

Found EDL file, request to move to destination EDL:

D:\Recorded TV\Chasing Classic Cars\Chasing Classic Cars_20120919_09301000.edl


D:\Recorded TV\Chasing Classic Cars

It it moving the file into the SAME directory which is why it's failing. Let me try to replicate this scenario and see if it works for me.

Oct 20, 2012 at 9:37 PM

BTJustice, first up thanks for staying with this issue and pushing through it. My apologies, I should have studied the log file a little better.

You've hit a specific condition with TS files that had not anticipated it has helped exposed a similar but witih SRT files and also some TS files.

Anyways I've fixed it and it should now work in 2.3.4 which I'll release today.

Again, sorry for the run around.

Oct 21, 2012 at 1:56 AM

Nothing to be sorry for.  I'm glad I found something that made this awesome program even better.  I'll download and install 2.3.4 now and report back.

Oct 21, 2012 at 1:58 AM
BTJustice wrote:

Nothing to be sorry for.  I'm glad I found something that made this awesome program even better.  I'll download and install 2.3.4 now and report back.

Did you mean 2.3.3?  I see it was released today and nothing about 2.3.4.

Oct 21, 2012 at 2:29 AM
I released 2.3.4 today
Oct 21, 2012 at 3:21 AM
rboy1 wrote:
I released 2.3.4 today

It's not on the DOWNLOADS page.

Oct 25, 2012 at 9:51 PM

How is the SRT files in 2.3.5 with the handbrake encoder working along with Comskip? Are you still getting the offset problem?

Oct 26, 2012 at 4:45 PM

I haven't had time to fully mess with it, but it seems like the issue is still present unfortunately.  I'll report back in a few days when I have more time to try it.

Nov 5, 2012 at 12:45 PM

I have given up on Comskip altogether.  After trying everything you have recommended, .EDL files are still not generated.  So now I use Avidemux, cut the commercials out manually, re-save the .TS, then use MCEBuddy to save .TS recordings as .MP4 files.  HandBrake with it's file size limit gets kind of close to some auto races I have recorded.

Nov 15, 2012 at 5:34 PM

Can you let me know how you use the EDL files with AviDemux? I"m looking to see how I can use AviDemux to cut the files instead of Mencoder.

Nov 16, 2012 at 1:26 AM

I've figured out why your SRT files are out of sync with the cut video. The video when it is cut is cut along KeyFrames (IFrames) by Mecoder, FFMPEG and Handbrake.

However key frames are present every few seconds (at an average of 1 every 1/3rd of the frame rate). so the result is that when we are requesting a cut a say 1:23 the next keyframe will be present at say 1:28, it will cut at 1:28, this 5 seconds add's up over each cut and the resulting video is out of sync with the SRT (which are cut EXACTLY) at the EDL times specified.


Hence the SRT files will almost never be in sycn with the video files. If the video is cut at non KeyFRames this will lead to either audio sync issues or blank video (since any video decoding needs to start with an IFrame).


I'm experimenting with a few things but I wouldn't keep my hopes up on getting this fixed given the issue. There is one option to extracting the SRT files from the CUT  TS remuxed file, which is why I asking about how to use AVIDemux with EDL files.

Nov 16, 2012 at 6:46 AM

I'm not using Avidemux for EDL files.  I am simply loading the .TS video recording in Avidemux and manually cutting out commercials then re-saving the .TS file.  Doing this maintains the CC contained within the .TS file if it used.

I haven't set up MCEBuddy yet to convert the edited .TS files.  I might make that a weekend project.

Nov 16, 2012 at 8:51 AM

Any chance you can help write a script/template that MCEBuddy can use to cut and marge TS files with AviDemux. It's a good software for TS editing but I'm having a hard time figuring out how to script it with EDL files.

Nov 16, 2012 at 12:38 PM

I am not sure if that can be done.  You might have to ask on their forum at

Dec 15, 2012 at 11:05 PM

As of MCEBuddy 2.3.10 64-bit, I am still unable to create .EDL files :(

Dec 16, 2012 at 1:37 PM

Can you upload your mcebuddy.conf file to the server. It's definitely a configuration or security issue. I've had 2 other folks "accidentally" create EDL files so I konw it' working.

Jan 22, 2013 at 1:53 PM

For the target folder:


1. Set the owner  to your login

2. Check the permissions of the target folder, it should be set to inherit permissions from parent folder, on parent folder ensure you have full access

Mar 30, 2013 at 4:42 PM
Okay I found the problem :D

Sometime if the original file and destination file are in the same directory the EDL file and SRT file would get delete after a successful conversion. Fixed in the next BETA build