This project has moved and is read-only. For the latest updates, please go here.

Just upgraded and now fails to convert.

Dec 1, 2012 at 5:27 PM

Hi all.

Just upgraded from 2.3.8 to 2.3.10 and now fails when trying to convert to MP4. I converted the file before upgrade and worked okay apart from adverts were not stripped. So I thought I would upgrade and try again.

Now fails with the following error in the log:

--> [mpegts @ 000000000201e440] max_analyze_duration 5000000 reached at 5000000
--> [mpegts @ 000000000201e440] Could not find codec parameters for stream 1 (Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16): unspecified frame size
--> Consider increasing the value for the 'analyzeduration' and 'probesize' options
--> [NULL @ 000000000033da00] start time is not set in estimate_timings_from_pts
--> Input #0, mpegts, from 'F:\Temp\working0\Misfits_E4+1_2012_11_04_22_59_00.ts':
-->   Duration: 01:03:25.32, start: 3.050244, bitrate: 1680 kb/s
--> Video duration=3805.32
-->   Program 1 
-->     Metadata:
-->       service_name    : E4 +1
-->       service_provider: E4+1
-->     Stream #0:0[0x100]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p, 544x576 [SAR 32:17 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
-->     Stream #0:1[0x101](eng): Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels, s16 (hearing impaired)
--> [mpegts @ 000000000031a480] sample rate not set
--> Output #0, mpegts, to 'F:\Temp\working0\Misfits_E4+1_2012_11_04_22_59_00-temp.ts':
-->     Stream #0:0(eng): Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels (hearing impaired)
-->     Stream #0:1: Video: mpeg2video ([2][0][0][0] / 0x0002), yuv420p, 544x576 [SAR 32:17 DAR 16:9], q=2-31, 25 fps, 90k tbn, 25 tbc
--> Stream mapping:
-->   Stream #0:1 -> #0:0 (copy)
-->   Stream #0:0 -> #0:1 (copy)
--> Could not write header for output file #0 (incorrect codec parameters ?): Invalid argument
--> Failed to trim video at 0%
ERROR> 2012-12-01T17:05:01 MCEBuddy.Engine.ConversionJob --> Trimming failed
INFORMATION> 2012-12-01T17:05:01 MCEBuddy.Engine.ConversionJob --> 

Thanks for any help.


Dec 1, 2012 at 7:58 PM

attach the full log

Also upload the original file to the mcebuddy server for analysis

Dec 2, 2012 at 4:58 PM

The issue lies here:

Stream #0:0(eng): Audio: mp3 ([3][0][0][0] / 0x0003), 0 channels (hearing impaired)

Your video has no Audio channels. Again I need the original video and full log to take this any further.
Dec 12, 2012 at 10:36 PM

Sorry for the delay but I have unable to get any time to post. I have now uninstalled, rebooted and re-installed but no luck.

I have tried to convert a different file to MP4 (Normal). No crash but no sound in the MP4. So looks to be the same problem as I was having before. In the MP4 is shows no audio. I am uploading the wts file and log file to the ftp area as I type. Currently says 2 hours to go.

Thanks for any help you can give. Recording from 2012_12_08 and log from today.

Dec 13, 2012 at 2:47 PM

Looking into it - there's an internal issue reading the file, I'll try to fix it in my next release.

Dec 13, 2012 at 4:36 PM

For now disable Trimming and it should work fine.

Dec 13, 2012 at 5:22 PM

I also noticed your file is corrupted (audio is corrupted, it's showing 0 channel audio) and even after remuxing for correction some of the errors are still present which may be throwing off the program.

I will try to see if it cna be auto corrected.

Is this happening with all your recordings?

Dec 13, 2012 at 9:20 PM


It has happened on the 2 recordings I have tried so far. As an experiment I have downgraded back to the version I was working okay with, 2.3.8.

This version has converted the file to a MP4 with audio. Perhaps 2.3.8 is a bit more forgiving with audio problems?

I have ftp'ed the log onto the server. So both logs are now there: Log dated 12/12/12 is the 2.3.10 version with audio issue and 13/12/12 is the 2.3.8 version that converts okay, same video file used with both versions. I have tried to look through the logs myself to see if I can spot the problem but they look pretty simlar.

If I am having audio problems on the original recordings from WMC7 would that be software or the hardware(driver). I am treating myself to a new TV Card for Christmas so if you suspect H/W(Driver Issues) then I will wait until after xmas to try with the new card.


Dec 13, 2012 at 9:31 PM

Possibly a tv card issue (and related driver). MCE is standard in all machines.

I've fixed this in 2.3.11

Dec 13, 2012 at 11:40 PM

Okay try this, goto and download the latest Dec 13 STATIC Build of ffmpeg (64bit or 32bit depending upon your version) and extract the ffmpeg.exe file from there and put in your ffmpeg directory in the mcebuddy installation.


It should fix your problem. The newer FFMPEG seem to handle corrupted audio better