This project has moved and is read-only. For the latest updates, please go here.

MCEBUddy Service is unavailable Error

Dec 17, 2012 at 7:50 PM

I have tried upgrading to to 2.3.10 several times over the last couple of days and continue to run into the same error: MCEBuddy service unavailable. Please start from Windows Control Panel or check engine connection.  I have verified the service is started.  I have followed the upgrade instructions to the best of my ability but to no avail.  Any help you can offer would be greatly appreciated.



2012-12-17T13:42:57 MCEBuddy.Engine.Core --> Loaded MCEBuddy engine settings--> Windows OS Version -> Microsoft Windows NT 6.2.9200.0--> Windows 64Bit -> False--> MCEBuddy Platform -> 32 Bit--> MCEBuddy Current Version :> Locale Language -> ENG2012-12-17T13:42:57 MCEBuddy.Engine.Core --> MCEBuddy engine settings -> CONVERSION TASK OPTIONS ==>Task -> Convert to MP4Profile -> MP4 NormalSource File -> Destination Path -> C:\Users\Public\VideosWorking Path -> Fallback Destination -> FalseMax Width -> 720Quality Multipltier -> 1Volume Multipltier -> 0DRC -> TrueForce Stereo -> TrueProfile Audio Language -> Audio Offset -> 0Start Trim -> 0End Trim -> 0Closed Captions -> Closed Captions Offset -> 3.1Commercial Removal -> ComskipCustom Comskip INI Path -> Download Series Details -> TrueTVDB Series Id -> IMDB Series Id -> Rename by Series -> TrueAlt Rename by Series -> FalseCustom Rename by Series -> File Selection Pattern -> Show Selection Pattern -> Extract XML -> FalseDisable Cropping -> FalseTask Commercial Skip Cut -> FalseDomain Name -> User Name -> Password -> Task Enabled -> True
MONITOR TASK OPTIONS ==>Task -> Windows DefaultSearch Path -> C:\Users\Public\Recorded TVSearch Pattern -> [video]Domain Name -> User Name -> Password -> 
GENERAL OPTIONS ==>Wake Hour -> -1Wake Minute -> -1Start Hour -> -1Start Minute -> -1Stop Hour -> -1Stop Minute -> -1Days of Week -> Sunday,Monday,Tuesday,Wednesday,Thursday,Friday,SaturdayMinimum Age -> 0Max Concurrent Jobs -> 1Enable Job Logs -> TrueLog Level -> 3Delete Original -> FalseArchive Original -> FalseAllow Sleep During Conversions -> TrueSend eMails -> FalseeMail settings -> SMTP Server -> Port -> 25SSL -> FalseUser Name -> Password -> From -> To -> eMail On Success -> TrueeMail On Failure -> TrueeMail On Cancellation -> TrueeMail On Start -> True
Locale -> en-USTemp Working Path -> Archive Folder -> Space Check -> TrueApp Hang Timeout -> 300Scan New Files Poll Period -> 300Process Priority -> NormalEngine Running -> FalseLocal Server Port -> 23332UPnP Enabled -> False

Dec 17, 2012 at 9:07 PM

Try a clean install - the procedure is listed in the Documentation -> Installation Issues section. Make sure you delete all the back up files after uninstalling MCEBuddy and ensure that the service is also deleted.


Possibly there'a conflict from a previous installation.

Dec 17, 2012 at 10:07 PM



Thanks for the quick reply.  I have tried to do a clean install several times (I tried again after your message) without any success.  Can you suggest any other possible solutions.

Dec 17, 2012 at 10:24 PM

Click on Events on the MCEBuddy Status screen and post any errors log you see there. For some reason MCEBuddy App is not able to communicate with the MCEBuddy engine this usually happens for 2 reasons:

1. Some previous installation is  left behind which has blocked the MCEBuddy communication port/channel

2. Some 3rd party tool is blocking the MCEBuddy communication port / channel (e.g. Antivirus/Firewall or Seagate tools)

Dec 17, 2012 at 10:34 PM


Here are the events since my last install:

Error 17-Dec-2012   3:51 PMUnable to delete installation directory. Error:System.UnauthorizedAccessException: Access to the path 'MCEBuddy.Service.exe' is denied.   at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive, Boolean throwOnTopLevelDirectoryNotFound)   at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive, Boolean checkHost)   at MCEBuddy.Service.ProjectInstaller.DeleteDirectory(String dirPath)

Information 17-Dec-2012   3:51 PMService stopped successfully.

Information 17-Dec-2012   3:51 PMMCEBuddy engine service stopped

Information 17-Dec-2012   3:51 PMMCEBuddy OnStop called

Information 17-Dec-2012   4:03 PMService started successfully.

Information 17-Dec-2012   4:03 PMMCEBuddy engine service NOT started

Information 17-Dec-2012   4:03 PMMCEBuddy OnStart called

Dec 17, 2012 at 10:45 PM

All looks good here, looks like some 3rd party tool may be blocking the communication


try this:

Start windows in Safe mode. Start the MCEBuddy service from the control panel and then try to connect with the application. If that works then it's some firewall or app that's blocking MCEBuddy.

Dec 17, 2012 at 10:47 PM

Also have you tried disabling the Windows Firewall and Antivirus?

Dec 18, 2012 at 10:24 AM

Try this, open the GUI, click on the connect to button next to the Priority box.


Replace localhost with the IP address of your computer and click OK. (keep the port the same)

Dec 18, 2012 at 4:33 PM

I tried changing the localhost to the IP address to no avail.

On Tue, Dec 18, 2012 at 4:24 AM, rboy1 <> wrote:

From: rboy1

Try this, open the GUI, click on the connect to button next to the Priority box.

Replace localhost with the IP address of your computer and click OK. (keep the port the same)

Read the full discussion online.

To add a post to this discussion, reply to this email (

To start a new discussion for this project, email

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at

G. Scott Caudle
929 North Trenton, PMB 142
Ruston, LA 71270
Ph: 214.764.1237 | Fax: 208.988.5535
"Trying is the first step towards failure" - H. Simpson

Dec 19, 2012 at 5:36 AM

hmm, try the safe mode option and let me konw.

Dec 25, 2012 at 4:28 PM

Ahh I think I know what's going on, do you have ShowAnalyzer installed?


If so uninstall it, reboot the computer and then try MCEBuddy. There's a bug in showanalyzer which causes it to hang, MCEBuddy User App makes a call to check the status of showanalyzer which causes it to hang and it presents itself as not able to connect to service issue.


Reinstalling Showanalyzer usually solves the problem.