This project has moved and is read-only. For the latest updates, please go here.

Unplayable >2GB WTV Output in 2.3.11

Feb 21, 2013 at 8:06 PM
Hello -

I'm trying out MCEBuddy 2.3.11 for my WMC box and appear to be running into a problem in which WTV output files >2GB are unplayable through the "WTV" or "WTV Unprocessed" profiles. Behavior occurs whether Comskip is active or not; also occurs both in 32- and 64-bit versions of MCEBuddy. Something similar appears in the changelog for 2.3.11, but I can confirm that I'm using the latest non-beta. Data follows...
  • OS: Win7 x64 SP1
  • MCEBuddy 2.3.11 x64 (also tried w/ i686 version -- same issue)
  • WTV inputs are captured digital TV through an HDHomeRun device
  • HD & SD programming both affected; seems to be strictly a file-size thing
Can provide debug log(s) and/or post samples of the non-functioning WTV output if that would be of assistance.

Any advice or suggestions welcome. Thanks...
Feb 24, 2013 at 8:22 PM
try the latest beta
Feb 25, 2013 at 8:11 PM
Thanks. Looks like the betas are behind a paywall, so I will make a note to try your next release when it occurs. (Happy to pay, but I need to know that the program in question will be useful to me before I do so.)
Feb 28, 2013 at 4:47 PM
Edited Feb 28, 2013 at 6:15 PM
I'm having the same issue with the same machine config. The only difference is, it doesn't matter the size of the file. I tested both a 1 hour show and a 2 minute show with same results. I will gladly pay for the beta, if you say that it will fix the problem.
Feb 28, 2013 at 7:47 PM
Upload a copy of the ORIGINAL WTV recording and the log file. I will test it with the latest build and let you know if it works or not.
Feb 28, 2013 at 11:23 PM
Edited Feb 28, 2013 at 11:25 PM
OK. I uploaded a 368mb zip file to my server. Go ahead and download. It contains both a WTV file as recorded and as output (wtv unprocessed) by MceBuddy (with com skip). This is the 64 bit version. (I tried the 32 bit version yesterday with same results). When I first installed MceBuddy I allowed the installation of FFdShow. When playing on WMC, it played a few seconds of audio only, then WMC crashed. I then uninstalled ffdShow and WMC flat out refused to play the new wtv file with a codec error. All originally recorded WTV files still play fine. FYI I use a Ceton tuner.
Feb 28, 2013 at 11:39 PM
I need the original file which was used to create the >2GB output WTV file along with the log file so I can replicate it. I don't see how the 368MB file is going to help.

Often 3rd party codecs cause things to break and that's what I need ot ensure it's not a 3rd party codec (I only use a clean windows install with ffdshow and haali media splitter).
Feb 28, 2013 at 11:49 PM
Hi rboy. You're confusing me with your other user, "tdz0934". He's the one with the 2gb file. Because he and I have a similar issue, I tagged onto this discussion. Was that a bad thing to do?
Mar 1, 2013 at 12:14 AM
No it's okay.

I just tested both your files, the converted and the original and both are playing just fine in WMP. I suspect you're got some 3rd party program/codec interfering.
Mar 1, 2013 at 1:12 AM
3rd party stuff... no doubt. I have Plex, XBMC, WMC, Sony Vegas (whatever that installed) and Remote Potato. I guess it's time for a house cleaning. Thanks rboy for humoring me.
Apr 11, 2013 at 4:47 PM
Edited Apr 11, 2013 at 4:54 PM
I have the same exact problem. When I play the wtv files generated by mcebuddy NO Recode profile , windows media closes unexpectedly. ( event viewer logs the crash in ffdshow )
all the original files play fine .
I susspect that the ffdshow installation got corrupted somehow . any idea on how to troubleshoot that??
show I install some other 3-rd party codec?
so far I have :
  • upgraded to latest beta ( 2.3.12 )
  • ran "sfc /scannow" to check wms files .
  • unistalling/reinstalling ffdshow and all the components that came with mcebuddy.
Apr 11, 2013 at 4:53 PM
If you haven't already, install the latest version 2.3.12, released just a few days ago.
Apr 12, 2013 at 12:26 AM
Try to uninstall ffdshow after upgrading and see this that helps

Apr 16, 2013 at 6:28 AM
Nothing helped.
I restored a earlier windows backup and now got all working again...
i know I am NOT the only one affected because ofothers other posts.
May 1, 2013 at 1:41 PM
Hello -

OP here. I recently installed the latest release version of MCEBuddy (2.3.12) and continue to experience the same behavior as described in the initial post.

I have posted a sample conversion log to the MCEBuddy FTP site for review under the tdz0934 folder, and a sample of the unplayable output is in the process of uploading now (big file >3GB). Would appreciate any input anyone might have to help resolve the issue.

Thank you...
May 1, 2013 at 4:09 PM
The audio is playing fine for me through I don't see any video. I will need the Original WTV file (not converted) to replicate the issue. Like a ffmpeg issue.
May 1, 2013 at 4:40 PM
It's likely the ffdshow that interfering with the playback, I tried another computer fresh window installation no fddshow and it's playing fine. Try to uninstall ffdshow and see if that helps.
May 2, 2013 at 5:25 AM
Okay for those folks who are not able to play back WTV files encoded by MCEBuddy I've found out why. It's FFDSHOW, somewhere ffdshow is breaking WTV playback.

I've isolated part of it, ffdshow video decoder configuration ->MPEG2 -> set to Disabled (this is what causes the crash). Now it should not crash WMP or MCE anymore.
However I have noticed on 1 computer this causes the video playback not to work. That's something ffdshow has broken. I haven't found a workaround for it but you can try uninstaling ffdshow and see if it helps otherwise the best bet is to reinstall windows (it works perfectly on a clean installation) and DO NOT INSTALL FFDSHOW as it it break WTV playback.

i will be removing the prompt to install ffdshow in the next build of mcebuddy
May 3, 2013 at 7:59 PM
Hello -

Thank you for having a look at this. I can confirm portions of the scenario you describe in your note above, though I have not yet had time to spin up a clean Win7 install and test under those circumstances.

I converted another hourlong show using the "WTV Unprocessed"profile in MCEBuddy, and the resulting WTV file was unplayable under the following scenarios I tried:
  • Original HTPC - ffdshow as originally installed
  • Original HTPC - ffdshow video decoder configuration ->MPEG2 -> set to Disabled
  • Original HTPC - ffdshow-x64 uninstalled
  • Original HTPC - bleeding-edge ffdshow-x64 (v4587) installed
  • Separate Windows XP machine -- WTV file in question was unplayable using fresh VLC install
Interestingly (perhaps), both on the HTPC and the separate box (which is a clean XP install and has never had ffdshow) the unplayable WTV file does not seem to even be recognized as a video -- at least Windows does not replace the default WTV icon with a video thumbnail as usual.

Separately, while reviewing the log I posted on Wednesday, I did note the following errors, seemingly whenever ffmpeg is called:

--> [mpeg2video @ 0000000001fe7c00] mpeg_decode_postinit() failure
--> Last message repeated 13 times

This may or may not have any bearing here but was the only error I noted while reviewing the log.

Per your note on Wednesday, if you would still like an original WTV file for comparison purposes, I can send it and along with another converted/unplayable version to your FTP site. I no longer have the original of the first WTV file I posted.

In any case, I appreciate your effort to get to the bottom of this.
May 4, 2013 at 4:02 PM
It's 3rd Party codecs. I tried a fresh installation of 64bit yesterday and worked fine for now.
May 5, 2013 at 2:58 AM
Edited May 5, 2013 at 2:58 AM
Count me in as experiencing the same issue. The WTV files fail when larger than some amount. Hope there's a resolution soon.

My setup is

Windows 8 x64
MCEBuddy 2.3.12

What do you mean by fresh 64 bit install? Windows or MCEBuddy? I just upgraded from 11 to 12 of MCEBuddy and still have the issue.

May 5, 2013 at 1:55 PM
:) - Windows. 3rd Party codecs like ffdshow and shark break WTV playback (ffmpeg created).
May 5, 2013 at 2:31 PM
Spinning up another Win7 instance now to test -- MCEBuddy install also suggests installing Haali Media Splitter. Would it be good to leave that out as well?
May 5, 2013 at 2:54 PM
Well it sounds like you detected the issue.

For what it's worth I see this clipping message in the log files of failed wtv files.

--> frame=86240 fps=2797 q=-1.0 size= 2755784kB time=00:23:58.44 bitrate=15694.3kbits/s
--> frame=88178 fps=2815 q=-1.0 size= 2812355kB time=00:24:30.77 bitrate=15664.4kbits/s
--> st:0 PTS: 132815808 DTS: 132775267 < 132809803 invalid, clipping
--> frame=89318 fps=2805 q=-1.0 size= 2849783kB time=00:24:50.19 bitrate=15666.0kbits/s
--> frame=90584 fps=2799 q=-1.0 size= 2890574kB time=00:25:11.31 bitrate=15668.2kbits/s

Is there any chance that there may be a way of fixing this without a complete Windows reinstall?
May 5, 2013 at 4:13 PM
That really doesn't have anything to do with the codecs.

May 6, 2013 at 8:43 PM
I also have 2.3.12 and it worked fine to convert into processed WTV format. However, it lost closed captioning in conversion. Has anyone else have this issue?
May 6, 2013 at 9:40 PM
Closed Captioning is only retained in the WTV Unprocessed profile. Limitation of ffmpeg.
May 7, 2013 at 2:18 AM
Sorry to say it, but I spun up a clean instance of Win7-64 and unfortunately am still experiencing the WTV issue as described above with the latest MCEBuddy stable 4.3.12. Have posted a conversion log along with "before" and "after" samples to the MCEBuddy FTP site under the "tdz0934-new" directory. The samples may take awhile, as I have no way to trim large video files on the new box.

As before, would appreciate any input anyone might have to help resolve this.

May 8, 2013 at 12:18 AM
So if ffdshow is broken for converting from WTV to WTV Unprocessed, what would you suggest? I saw that WTV converting WTV is broken for Dec 2012 version of ffdshow. Does that mean that I should install an earlier version of ffdshow to get this to work?

FYI, I uploaded my files with logs and sample WTV files.

Currently, I am using 64-bit version of MCEBuddy 2.3.12.
May 8, 2013 at 7:10 AM
It may be related to this issue (remember WTV is a closed format).

Request the ffmpeg team to fix the issue and it may fix this problem:

May 8, 2013 at 3:30 PM
I voted. Had to register, but it was easy to register at the site.