This project has moved and is read-only. For the latest updates, please go here.

My MCEBuddy got Alzheimer's, ignores history and converts videos all over again

Mar 17, 2013 at 5:40 PM
Hello all,

First of all, I love MCEBuddy. Especially my gf loves to view the recordings on the mobile.

But I have an annoying issue I can't get rid off and hopefully you can help me.
My MCEBuddy finds the videos to process, converts them and moves them into the right destination. But then, he adds the just converted files again to the queue and converts them again.
As far as I can see, the converted files are added to the history file, but the queuemanager seems to ignore the history and adds the original video again to the queue.

Logs can be found here Link

Thanks in advance for your help.

Best regards
Mar 17, 2013 at 5:55 PM
:)) - wow I never thought I would see this. Anyways, anything's possible.

The reason it's picking up all over again is because of the ] in the name of the file, it's messing up the history file.

LEt me explain, the history file is a windows INI file (i.e. using Windows INI api's to store and retrieve the data).
In INI file, the sections (in this case each converted file has it's own section) start with a [ and end with a ]

So in your filename the ] is prematurely cutting off the section name so the name returned from the history file (when read by Windows INI API's) is

[F:\Recordings\Gute Zeiten, schlechte Zeiten\Gute Zeiten, schlechte Zeiten - S - E.]

Instead of

[F:\Recordings\Gute Zeiten, schlechte Zeiten\Gute Zeiten, schlechte Zeiten - S - E.]_1.ts]

Hence the filenames don't match and the conversion starts over again.

Remove the [ and ] from the filenames and you're good.

Question - why would you use [ and ] in your file names?
Mar 18, 2013 at 8:08 PM
Hi There,

many thanks for the quick answer !

removing the ] solved the problem. Thanks for your help and the explanation.

The ] in my filename came from my messed up setting in MediaPortal for custom filenames. The brackets mark optional naming fields and i messed up one field. Within MediaPortal i've never recongnized this issue before
Now i fixed it :-)

Thanks for your help!

Best regards