Destination can be NAS, but WTV files can't be added from NAS

Dec 9, 2013 at 5:13 PM
Edited Dec 10, 2013 at 2:29 AM
I posted this early today, but have made some discoveries and am editing my original post in hope for assistance.

Greetings,
I donated and upgraded to the V14, very cool new features.
Adding a file from my local drive works just fine and it moves the converted file to my NAS (entered credentials)

However, when I go to add a file, i can navigate to my NAS mapped as a V: drive (share on the NAS) just fine and click the file I want to convert, but nothing happens in the MCE screen. Since it works with a local file, it must be the network issue, but it's just a one way problem (MCE can write to the NAS but I cant drag a file from the NAS or use the "add" function to get WTV from the NAS).

I read the install notes and known issues and a good thread on this discussion and I've done all that, or at least I think i have done it correctly.
:not read only
:credentials set
:tried using the mapped drive as well as with IP address
:no known process using the files
:tried adding different files

I'm not sure if this is the right log file, but I put what I came up when I clicked the "log/event" button.
https://docs.google.com/document/d/1HEkjamxdsLmP-bnTyh0g-lBTIAI1r2-DzrUblsUgaoE/edit?usp=sharing


Any help on this network configuration would be great.
Dec 9, 2013 at 9:38 PM
Edited Dec 10, 2013 at 2:30 AM
A
Coordinator
Dec 10, 2013 at 5:13 AM
If you are using a mapped drive enter the credentials under Settings -> Expert settings.
Windows service accounts do not share credentials with local accounts hence mcebuddy needs to authenticate (as it runs under a service account)

Coordinator
Dec 10, 2013 at 5:16 AM
Your log file indicated that you are using a mapped drive. Do not use mapped drives instead use a UNC style \\xxx\x\x and enter the credentials (username and password). Then try to reboot the computer once (or log off and logon) and if it still doesn't work attach the mcebuddy.log file and we can analyze it.

Coordinator
Dec 10, 2013 at 5:23 AM
BTW in your case. The conversion is not starting because the file is locked by another process. Search the log file for the work locked.

Check your NAS permissions (no permissions can also lead to this issue, and permissions may again be linked to authentication issues) or if its locked.


Marked as answer by rboy1 on 1/29/2014 at 8:44 AM
Dec 10, 2013 at 5:42 AM
Thank you for the reply.
I'm using the \\192.168.x.x\x\ method now for the destination, and put in the user/pass credentials so if I can get a file in MCE, it converts great and put it at the network location. I still can't drag and drop or "add" a file from the network location; thanks for pointing out the "locked" problem. I'll google for what could be causing it to look "locked by another process", but there isn't any other process that i'm aware of. These were OTA PBS recordings moved from my C drive to this NAS location. I reloacted a few to another directory in the NAS, but still no love.

Any suggestions on how to solved the "locked by another process" issue?

Newst log file

super thanks for your time...
Coordinator
Dec 10, 2013 at 5:56 AM
For the drag and drop and add button use the settings -> expert settings credentials.

Marked as answer by rboy1 on 1/29/2014 at 8:44 AM
Dec 10, 2013 at 6:25 AM
I'm not sure what exactly you mean by "use the settings -> expert settings credentials".

I go to Setting then open advanced then at the bottom, expert. In there I click Network Authentication and in there I leave domain blank and put in admin for the user name and the password i use for access to the nas (same user/pas i used to map the drive and to log into my nas). I think the credentialing works as it does move the locally converted files to the nas... maybe i don't know what you mean in your last reply about "using" the credentials...
Coordinator
Dec 10, 2013 at 8:50 AM
That's correct. So it working. You only need to figure out the locking. You can find some tools on the Internet that can help you figure this out

Coordinator
Dec 10, 2013 at 8:50 AM
It's possibly a permissions issue

Dec 10, 2013 at 7:52 PM
rboy1, thanks again for your time.

I used a program called LockIT and it told me the files I can't move into MCE are not locked by any process.
I also followed a tutorial to ensure that whole folder and all children are all set to "allow" for all possible users.
I can delete the file, move it, play it from it's NAS location, so it doesn't seem to be locked in a process either.

From what I see, MCE says a file is locked in another process but LockIT says it's not.

For now i'm moving the files little by little from the NAS to a local drive where MCE does a good job on the convert and move back to the NAS... unless you have any new ideas...

Coordinator
Jan 8, 2014 at 8:32 AM
Sorry for the delay here - been busy racking up new features in MCEBuddy., your settings look fine to me (as per the log file), just ensure you're using the correct password in both conversion settings authentication and general expert settings authentication.

What I'm seeing in your file is this:
Unable to queue file for conversion - file locked by another process V:\TV WMC\To be converted\Curious George_KTCADT_2013_11_26_15_00_00.wtv

There I see that you're using a mapped drive V:. You cannot use mapped drives to add files. You need click on add, navigate to \192.x.x.x and then add your file. mapped drives dont' exist outside the user space (session 1), and mcebuddy engine runs in the service space (session 0), hence when the engine it tries to access it it fails. Your GUI runs in the user space, while the engine runs in the service space (windows protection design - sigh!).

Try the above, open the folder in explorer using \192.x.x.x, then drag and drop your files into MCEBuddy. Then see and if you're facing issues post back the mcebuddy.log file.
Marked as answer by rboy1 on 1/29/2014 at 8:46 AM