This project has moved. For the latest updates, please go here.

Subtitle Extract Commercial Removal Issues

Mar 2, 2014 at 12:37 AM
I have been trying to find the best way to extract captions and remove commercials. If anyone has any insights on how to do this without a lot of maintenance please respond. Currently if I do not remove commercials the captions stay in sync but as soon as I cut commercials the captions fall out of sync. I see there is an option to try and resolve this but didn't seem to help me much. Didn't know if I could do this with a couple passes on the same video like process the video and convert it into mkv and re-embed the captions into the mkv...then have another monitor folder watching for the output and then strip the commercials. I cannot seem to get these two processes to play nice.
Coordinator
Mar 2, 2014 at 2:00 AM
Search the forum for the caption sync issues (and this has been documented under known issues with workaround also), when you cut commercials the video goes out of sync due to GOP frame alignment (encoder issue). To work around there are 2 settings you can play with.

1. Under Conversion Task -> Expert Settings there is an option for Closed Caption offset. This is a one time adjustment, as in if the caption are off by say 2 seconds CONSISTENTLY then you can use this offset to correct it.
2. If your closed captions are going out of syn progressively (2 sec after the 1st commercial, 4 seconds after the 2nd, 6 after the 3rd etc) then under Settings -> Expert Settings there is an option for Subtitle Segment Offset. This is used to compensate for cumulative subtitle sync issues after each commercial segment is cut. So if after each commercial segment there is a 2 second additional correction required, then this value should be set to 2. Remember this is a cumulative correction, not one time. It applies after EACH commercial segment is cut.

Once you've got this fixed you can use the Write chapters and subtitle option under Covnersion Task -> Expert Settings.

Remember all of the above only work with the latest 2.3.15 (older version have bugs in them). or later


Marked as answer by rboy1 on 3/1/2014 at 8:33 PM
Mar 2, 2014 at 3:49 AM
I am currently running the 2.3.15. Trying to get it straight. With pervious versions some shows didn't seem to be an issue where others had the progressive issue. My wife is hearing impaired and would like to have a method that doesn't need much attention or maintenance. hoping the 2.3.15 gives us that stability.