This project has moved and is read-only. For the latest updates, please go here.

Video stuttering / jittering on HD conversion to MP4 via FFMPEG

Mar 15, 2014 at 4:32 PM
Just tried converting some high definition videos (8GB) recorded from my stream and turning them into HD MP4s.

It converted them after a very long time (several hours) and I thought everything was fine until i played them. The conversion is successful but the product video stutters where the original DVRMS has a smoooth framerate. Basically it keeps jittering throughout the video and is very distracting.

This is all on 2.3.14 using defaults which I think is the FFMPEG encoder
Mar 15, 2014 at 5:33 PM
:) please update to 2.3.15 and it should fix your problem. That uses direct show streams to extract the video. This was a minor bug in 2.3.14 which used ffmpeg instead of streams

Mar 15, 2014 at 10:47 PM

Just updated to 2.3.15 - it's now using the handbreak encoder, but it says 20 hours to convert (let alone every other step in the process) which is very troubling.

Is there anything I can do to speed it up? Since this PC also records the TV i have it using 4 cores out of 8 from an i7 3.4GHZ processor.

Mar 16, 2014 at 1:28 AM
so depending upon how much CPU is free it will take more or less time. encoding is a VERY intensive process so usually I ensure when MCEBuddy is running nothing else is running if I want a timely conversion. Otherwise I usually set it background and continue using it.

Also the conversion time depends a lot on your configuration. Can you upload your conversion log file to dropbox and post the link here. I'll look into it and see where you can optimize it and why' it may be taking so long.

Mar 17, 2014 at 5:24 PM
Edited Mar 17, 2014 at 5:24 PM
Just updated. It's using handbreak now, but now it takes 20-30 hours per file?! Any idea how to speed things up? It used to only take an hour or two at most for one file.
Mar 17, 2014 at 7:39 PM
Once a single conversion is complete upoad the conversion log (click on the logs link on the main GUI page) or post the link here to it. I need to see why and where it's taking time and what settings you're using. There could be many reasons.

Have you set the priority to Nomal or low? Have you limited the CPU's that MCEbuddy can use?
Also open your task manager, sort by CPU utilization and post a screenshot here. Are you running any other services/programs in the background.

Apr 2, 2014 at 11:49 AM
There will be a new build later today with a new ffmpeg. See that works for you. If not upload your original WTV file along with the conversion log.
Apr 5, 2014 at 6:25 AM
I'd like to chime in and state I experience the same issue when attempting the HD mp4 conversion with 2.3.15. The video is jittery/choppy when the original source is smooth. I can send you my source video and conversion log. The video itself is around 3GB
Apr 5, 2014 at 2:17 PM
Are you using hte latest build? If so please upload the original video and conversion log to dropbox or the MCEBuddy server.
Apr 6, 2014 at 1:46 AM
I noticed your original video is H264, by using the MP4 profile you will be reducing your video quality (slightly since you're using High Quality MP4 with 100% quality increase) but essetially more time also to recode it.

Have you tried using hte MP4 unprocessed profile?
Apr 6, 2014 at 3:04 AM
I have not tried it. I will do that now and post results
Apr 6, 2014 at 3:29 AM
MP4 unprocessed gives the same jittery video
Apr 6, 2014 at 2:33 PM
Okay found the issue, AVIDemux is not able to process your file correctly.

for now there are 2 solutions (until I figure out why AVIDemux is choking).

In your profile either set
OR add

Second option is better and FASTER and will also fix the root cause of the problem.

Let me know if that works for you.

Apr 7, 2014 at 1:30 AM
I've put a permanent fix for this in the next mcebuddy build. Also updated avidemux and put some control checks for the issue.
The issue was your orignla file has a annexb requirement which avidemux could not handle and hence it messing up the video while merging it. This is now handled by falling back to ffmpeg to merge the video is this issue in encountered.
Marked as answer by rboy1 on 4/6/2014 at 5:30 PM
Apr 9, 2014 at 3:55 AM
Sorry for the delayed response. I tried the 2nd option since it seemed to be the better of the two and MAN, you were not kidding how much faster it is; especially if ComSkip is disabled. Anyway, I ran it on the MP4 unprocessed as you suggested and the jittery video is gone. I ran it a second time with ComSkip enabled. It took longer (understandably) and again, no jittery video.
Thanks for looking into this!