This project has moved and is read-only. For the latest updates, please go here.

2.3.15 beta mpeg-2 playback problem

Mar 16, 2014 at 10:25 PM
Edited Mar 16, 2014 at 10:27 PM
I have the latest donator version just downloaded today and all i am trying to do to my WTV files is create comskip files and move the WTV to the renamed directory /show/series/blah.wtv

the comskip and moving/renaming is working BUT MCEBuddy always tries to convert the file from MPEG-1 to MPEG-2 ( dragging them into g-spot to show me that info ) the original files work file the MPEG-2 converted files don't play at all.

I have uninstalled the KBxxxxxx that interfered with ffdshow and rebooted. here is my conf

Mar 16, 2014 at 11:17 PM
and or maybe convert then back to mpeg1
Mar 17, 2014 at 5:44 AM
I'm confused as to what problem you're facing.

First up, DVRMS files only use MPEG2 and WTV only MPEG2 and MPEG4. Neither use MPEG1. Second MCEBuddy remuxes (not convert, but remux) WTV files to TS files to that other programs can use them. You can disable remuxing with the skip remuxing option.

If you just want to Rename/Move the file without converting it, then Check the option that says Move without converting. You can still run comskip and generate the EDL file.
Mar 17, 2014 at 3:41 PM
Edited Mar 17, 2014 at 3:51 PM
ok I will try the move without converting and see what that does. the ones that are already done are not playable anymore. can I upload one?


with the "move without Converting" checked i still get the fast remuxing

I will let one complete and upload the logs and configs

Mar 17, 2014 at 3:54 PM
IF i click on the red "Skip remuxing files" in the expert section and I say OK it gets automatically unchecked when the "Move without converting" IS checked. if I UNcheck "Move without converting" then I can check "Skip remuxing files" in the expert section and it stays.
Mar 17, 2014 at 4:00 PM
ffmpeg -i info before MCEbuddy and playable by MCE


ffmpeg -i info AFTER MCEbuddy and NOT playable by MCE

Mar 17, 2014 at 4:03 PM
dpackham wrote:
IF i click on the red "Skip remuxing files" in the expert section and I say OK it gets automatically unchecked when the "Move without converting" IS checked. if I UNcheck "Move without converting" then I can check "Skip remuxing files" in the expert section and it stays.
Ofcourse, that's they way it supposed to work. When you're renaming and moving file only without conversion why would you have remuxing (or skipping). Forget remuxing, your intent is to just rename and move it and get the EDL files right? If so use that option.

What would be helpful is if you can upload one of the original WTV files AND the conversion log. If you dont' have the original upload the converted file AND the conversion log.
Mar 17, 2014 at 4:20 PM
ok Ill do that right now. Ill upload the before and after WTV files to your FTP site
Mar 17, 2014 at 9:23 PM
Edited Mar 17, 2014 at 9:40 PM
uploading now. weird that the log files look empty... but i zipped the whole dir

too big... uploading two and zips
Mar 17, 2014 at 10:10 PM
logs was on error. changed it and now it will be debug. will be uploaded soon
Mar 17, 2014 at 10:36 PM
logs uploaded with debug on
Mar 18, 2014 at 4:04 AM
So couple of points:
1. I found a needless remuxing taking place which is probably slowing down the conversion process, I'll fix this (nothing to do with your output, it's just a useless artifact)
2. Your output WTV file plays just fine on all my computers. I'm guess it's some codec on your computer which is preventing it from playing back.
3. You've enabled rename only, so teh original and output WTV files are identical expect for the name, MCEBuddy does nothing to it. It just copies it over and renames it. So if you original is working, then your output should also work.

Marked as answer by rboy1 on 3/24/2014 at 3:49 AM
Mar 18, 2014 at 12:38 PM
I've played the "After" WTV file, assuming that's the one which was giving your grief.
Mar 18, 2014 at 4:15 PM
yeah... after is the one. and codec reinstall's that I can use to get it back to default? i tried to install powerdvd13 for bluray playback and maybe that nuked it

yeah all I need/ant is rename/move to folders with a comskip file

Mar 18, 2014 at 4:27 PM
your configuration is fine, nothing wrong with it. You'll need to figure out hte codec, unfortunatley that's beyond the scope here. Tehre are a few dicsussion here on this forum where we've shared pointers about how to fix it. You can try those out.

Mar 18, 2014 at 5:54 PM
so id this the remux you are talking about? its creating a TS file to work on I think. Comskip donator

Mar 19, 2014 at 6:06 AM
That's correct, I missed it out, it's creating a TS file for comskip to work. I will see how to optimize the code, if you're using the donator version and only using comskip it can skip remuxing to TS which should make it much faster (since I noticed some of your files are slow remuxing).

I'll also fix the skip remuxing option, as I can see that you will need that option here too, even if you only renaming with comskip enabled.
Mar 19, 2014 at 6:08 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Marked as answer by rboy1 on 3/24/2014 at 3:50 AM