This project has moved and is read-only. For the latest updates, please go here.

How to set ffmpeg probesize and analyzeduration

Apr 18, 2014 at 6:33 PM
For one of my HD WTVs I get massively unsynced video so that in a 90min output file the sound stream is running fine and to the end while video is ending up at about 60%, so 40% have not been transcoded.

The profile I use transcodes to MJPG via ffmpeg (which until now has worked flawlessly).
Log shows almost 50% of duplicate frames reported during conversion and - looking up at the start of the log - I find a note on not enough frames for calculating the rate-
2014-04-18T19:05:46 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Launching process C:\Program Files\MCEBuddy2x\ffmpeg\ffmpeg.exe
2014-04-18T19:05:46 MCEBuddy.AppWrapper.FFmpegMediaInfo --> Process arguments  -probesize 100M -analyzeduration 300M -i "\\MEDIACENTER\VideoConv\MCEB_In\_Test\Frankenweenie_EN.wtv"
...
2014-04-18T19:05:47 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [wtv @ 000000000242d7e0] Stream #3: not enough frames to estimate rate; consider increasing probesize
2014-04-18T19:05:47 MCEBuddy.AppWrapper.FFmpegMediaInfo --> [wtv @ 000000000242d7e0] Stream #4: not enough frames to estimate rate; consider increasing probesize
I'd like to set probesize and analyzeduration to a higher value for a test but don't find any hint on where to put this in the MCEBuddy profiles -

I tried mcebuddy.conf in the FFMpegBackupRemux section
SlowRemux0=-ss 2 -probesize 300M -analyzeduration 700M -i <source> -vcodec mpeg2video -qscale 0 -r auto -acodec copy -map 0:a -map 0:v -f mpegts
and the profiles.conf in the respective section
ffmpeg-general=-threads 0 -probesize 300M -analyzeduration 700M
but in either case after Slow Remuxing starts the log tells me that ffmpeg still is called with probesize 100M and analyzeduration 300M...

That's as far as I get, any help on how to set these parameters via MCEBuddy?
Apr 18, 2014 at 7:03 PM
That is one parameter that current' isn't configurable and hardcoded based on our test sample.

What values work for you? Can you post the ouput.


Apr 25, 2014 at 11:57 AM
For this type of conversions I am using this custom profile
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1,hqdn3d,scale=min(480\,iw):272 -vcodec mjpeg -vtag MJPG -qscale 9 -r 15 -f avi
ffmpeg-audio=-acodec libmp3lame -ab 96k
ffmpeg-audioac3=-acodec libmp3lame -ab 96k
ffmpeg-ext=.avi
ffmpeg-audiodelay=skip
this time I couldn't get it to work and the change in probesize was just a shot in the dark, not sure if it had worked at all-

Since I can't change probesize I used the TS Unprocessed profile first (no problems there) and send the resulting .ts file through the above process-
Apr 25, 2014 at 3:23 PM
Edited May 30, 2014 at 5:59 PM
Quick point:
If you want to continue this please start a new thread, your current issue is no longer related to probesizes etc.

Coming to your issue, your profile is setup incorrectly which is why MCEBuddy is failing
  1. Since you're using a custom scaling (scale=min...) you need to specify FixedResolution=true, otherwise MCEBuddy tries to set it own resolution and the conversion fails.
  2. Since you're specifying a custom scale/resolution you also need to include the crop information information BEFORE the scale or set SkipCropping=true otherwise the conversion will fail because MCEBuddy will add a custom crop at the end and by ffmpeg filter chain rules, crop needs to come before scale.
So the profile that works for you will look like:
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1,hqdn3d,crop=iw:ih:0:0,scale=min(480\,iw):272 -vcodec mjpeg -vtag MJPG -qscale 9 -r 15 -f avi
ffmpeg-audio=-acodec libmp3lame -ab 96k
ffmpeg-audioac3=-acodec libmp3lame -ab 96k
ffmpeg-ext=.avi
ffmpeg-audiodelay=skip
FixedResolution=true
2ChannelAudio=true
Marked as answer by rboy1 on 4/25/2014 at 7:23 AM
May 30, 2014 at 4:50 PM
Thx for the advice-

I'll open a new thread since changing to the recommended parameters won't lead to stable conversion-