This project has moved and is read-only. For the latest updates, please go here.

Ceton Echo and Linksys DMA2100 Media Extender WTV not working and metadata in MP4

Apr 30, 2014 at 4:53 PM
If I use the WTV profile encode using handbrake as mp4 remux to WTV all the metadata gets copied... Including channels episode name etc... but if I encode to MP4 only the genre Title and description gets populated is this a limitation of MP4? Also playing the encoded WTV I see the details when playing MP4 only shows the title no Actors or details.... etc.
Apr 30, 2014 at 5:13 PM
that's correct, it's a limitation of MP4. Infact there is more metadata embedded in the MP4 file but unfortunately the standard is not very clear about which ATOM's are used for what which makes different software "see" or display the metadata differently. The most compatible program to extract metadata would be iTunes (or apple products).

MKV is even worse from that perspective in terms of standard and compatability for metadata.


Apr 30, 2014 at 5:16 PM
Edited Apr 30, 2014 at 5:16 PM
Ok Thx I am trying to find the best of both worlds if I encode to WTV I get all my Metadata but when I play them on my Ceton Echo I get sound but no video. If I encode to MP4 it works fine on my Ceton Echo but of course the Metadata is limited.

PS the WTV play fine if I use WMC and not the Echo.
Apr 30, 2014 at 5:18 PM
Are you using the latest build? There some fixed put recently to make the WTV compatible with extenders and 3rd party devices


Apr 30, 2014 at 5:21 PM
INFORMATION> --> Windows OS Version -> Microsoft Windows NT 6.3.9600.0 (WIN_8_1_2013_SERVER_R2, Professional)
INFORMATION> --> Windows Platform -> 64 Bit
INFORMATION> --> MCEBuddy Build Platform -> 64 Bit
INFORMATION> --> MCEBuddy Build Version : 2.3.15.0
INFORMATION> --> MCEBuddy Build Date : 04/29/2014 15:35:36
INFORMATION> --> MCEBuddy Running as Service : True
Apr 30, 2014 at 5:47 PM
1. Does the original playback on the Ceton Echo?

2. Also try this, open your WTV profile, change the codec from -vcodec x264 to -vcodec mpeg2video. Now try it and see if it plays on the Ceton Echo. It's possible the Ceton does not support h.264 video in WTV only supports Mpeg2.

3. Also have you tried using the WTV unprocessed profile, let me know if that plays back on your Ceton.


Apr 30, 2014 at 6:09 PM
  1. Yes the originals play fine on Echo ... I will do all your steps above and report back after completion thx for your patience.
Apr 30, 2014 at 8:01 PM
Edited Apr 30, 2014 at 8:02 PM
This worked ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -crf 22 -map 0:v -sn .... but the quality was awful.

original (3,839,885,312 bytes) encoded ffmpeg (502,267,904 bytes)... WTV unprocessed worked fine. I will have to create a profile that will give me good quality but reduce the file size. WTV with h.264 no video blank just audio.
Apr 30, 2014 at 9:24 PM
Okay that solves the issue, your Ceton Echo does not support WTV with h.264 and only supports wtv with mpeg2.

The reason the quality is abysmal is that -crf only works with x264 for mpeg2 it's -qscale to control quality (and the ranges are different). So your ffmpeg-video line should look like:
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn
Marked as answer by rboy1 on 4/30/2014 at 1:25 PM
Apr 30, 2014 at 9:36 PM
BTW this also applied to other Media extenders such as Linksys DMA2100 which don't support h.264 in WTV.

Alternatively you can also use the WTV Unprocessed profile if your original video plays back on the extender
Marked as answer by rboy1 on 4/30/2014 at 1:37 PM
Apr 30, 2014 at 10:38 PM
What is the benefit of using WTV unprocessed?... Isn't that the same as just playing the recorded WTV file... which plays fine on the Echo Extender?
Apr 30, 2014 at 10:44 PM
You remove the commercials but retain the original quality of the video (useful when you're going from mpeg2 to mpeg2, no need to trancode)
Apr 30, 2014 at 10:46 PM
Plus it's 10x faster also. In your case the goal is to remove commercials not change the underlying codec from mpeg2 to h264, that's where the unprocessed profiles excel in reducing processing while removing commercials.
Apr 30, 2014 at 11:38 PM
This worked perfectly on the echo extender... It cut file to 1/3 of original.

order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
handbrake-general=--decomb --denoise --loose-anamorphic --verbose=2 -f mp4 -4
handbrake-video=--start-at duration:3 -e x264 -q 22
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.wtv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true

Maybe you can Include a profile for Extenders.
May 1, 2014 at 2:01 AM
This Profile uses Handbrake and is much faster... but works on the Echo Extender.

order=handbrake
ffmpeg-general=-threads 0
ffmpeg-video=-ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
handbrake-general=--loose-anamorphic --verbose=2 -f mp4 -4 --start-at duration:3 -e ffmpeg2 -q 5
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.wtv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
May 1, 2014 at 3:48 AM
Great. I see you're encoding to mpeg2 using handbrake and then remixing to wtv. Bravo!

May 1, 2014 at 2:25 PM
Edited May 1, 2014 at 2:25 PM
This is my final profile.

Description=Recodes the video to MPG in WTV Container.. Works on Extenders
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
handbrake-general=-f mp4 -4 --decomb --loose-anamorphic --modulus 2 -e ffmpeg2 -q 5 --vfr
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.wtv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
May 1, 2014 at 3:12 PM
your handbrake-video line is missing and I'm guessing it should contain
handbrake-video=--modulus 2 -e ffmpeg2 -q 5 --vfr
Settings not in the right places could have unintended consequences while mcebuddy parses the profiles.
May 1, 2014 at 3:21 PM
Thanks I posted it so you can edit and improve it :-)
May 1, 2014 at 4:42 PM
The -e ffmpeg2 has to be in the handbrake-general otherwise it gets overridden and it tries to encode with H264.


[WTVNORMAL]
Description=Recodes the video to MPG in WTV Container.. Works on Extenders
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
handbrake-general=-f mp4 -4 --decomb --loose-anamorphic -e ffmpeg2
handbrake-video=--start-at duration:3 --modulus 2 -q 5 --vfr
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.wtv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
May 1, 2014 at 6:48 PM
Edited May 1, 2014 at 6:51 PM
So couple of things here, your ffmpeg-video line is incorrect, you've repeated the header twice.

Yes you're correct about the -e ffmpeg2 getting replaced and that's a bug which has been fixed, thanks for reporting it.
That's why it's important to keep it in the correct section, to ensure it works as intended and not have any side effects, so yes it needs to back into the handbrake-video section.

So here's the final profile (that works with the new build today). Also BTW, thanks to your efforts we decided to put a NEW profile into the next build to support older WTV extenders. You'll find this in the next build but anyways here's the profile FYR:
[WTV Legacy]
Description=This is primarly for older Media Extenders (like Ceton Echo and Linksys DMA2100) which don't support h.264 in WTV. Recodes the video to creates high quality WTV (MPEG2/AC3) files.
order=handbrake,ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec mpeg2video -qscale 5 -map 0:v -sn 
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
handbrake-general=--decomb --denoise --loose-anamorphic --verbose=2 -f mp4 -4
handbrake-video=--start-at duration:3 -e ffmpeg2 -q 5
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.wtv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
Marked as answer by rboy1 on 5/1/2014 at 10:48 AM
May 2, 2014 at 4:44 PM
Edited May 2, 2014 at 4:45 PM
Any reason why in the latest beta you made ffmpeg the first option in the profile?
May 2, 2014 at 5:45 PM
its faster than handbrake for mpeg2 (since mpeg2 does not support hardware encoding with quicksync)


May 2, 2014 at 6:14 PM
In all my testing I found just the opposite... Handbrake is much faster. I changed it so I just have to remember to change it in future releases.
May 2, 2014 at 6:24 PM
Can you look at hte conversion logs and at the end it breaks it down by actions. Can you help me identify from your logs which actions were faster with handbrake.
From my logs the "conversion" time was about 5% faster in ffmpeg (at -q 2).
Is that the oppostite for you? Are there other areas whcih are faster?


May 2, 2014 at 6:25 PM
Also I saw that some files caused handbrake to choke and crash. (it's a known bug with handbrake which they are working on fixing)


May 2, 2014 at 9:26 PM
Once again you are correct some encode files using handbrake are choppy and breakup.