Keeping only 1 audio track in TS Unprocessed

May 9, 2014 at 8:22 PM
Hi

I'm having problems playing my HD videos in Media Center and WMP12, the videos are OK but there is no audio, someone suggested that they could be using the wrong audio stream so I have used the following profile to copy the video and the primary audio stream to a new file, however, the new video is heavily pixilated. Any idea?

[MP4 Unprocessed]
Description=Creates MP4 files by copying the video directly. It does not resize, remove black bars, deinterlace your videos or select audio language. Use this if you have high quality HD recordings which don't need processing.
order=copy,ffmpeg
copy-remuxto=.mp4
copy-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vcodec copy -map 0:a -map 0:v
ffmpeg-audio=-acodec copy
ffmpeg-audioac3=-acodec copy
ffmpeg-ext=.mp4
ffmpeg-audiodelay=skip
FixedResolution=true
SkipCropping=true
May 9, 2014 at 8:58 PM
Just notice this from the Remuxing H264 post.

NOTE: Some H264 videos's contain aac_latm audio codecs which are not supported by the MP4 and MKV specifications. This may cause the audio/video to be garbled/distorted.

So I am wondering if this is the problem will try the recommended .TS profile and get back.
May 9, 2014 at 10:06 PM
The TS Unprocessed profile is copying the video and audio cleanly but I am back to the problem of having multiple audio streams, according to the ffmpeg docs I should be able to use -map 0:a:0 to select the first audio stream but this does not seem to work.

Any ideas on where I am going wrong?

Thanks
Coordinator
May 10, 2014 at 12:42 AM
Remove the map commands completely from the profile (-map 0:a -map 0:v) and select the option for let encoder choose best audio track in the settings page.

This will let the encoder choose the best audio track or mcebuddy will choose it if there are any defective audio tracks.

I hope you are using 2.3.15 for this


May 10, 2014 at 7:19 PM
I've tried it without the -map and with best track selected but got the same results, I really need to find a way to strip out the two tracks I don't want and just keep the one I do.

Any ideas?
Coordinator
May 10, 2014 at 8:08 PM
There is NO way it can copy more than 1 audio track without the -map command. You might be using some other profile or encoder.
Upload your conversion log and post hte link here to analyze.
May 10, 2014 at 9:22 PM
I've run it again just to check, still 3 audio streams

https://drive.google.com/file/d/0B0c_ymiNgQNJaVBoN19lbmF6U0E/edit?usp=sharing
Coordinator
May 10, 2014 at 9:30 PM
Edited May 10, 2014 at 9:32 PM
just as I thought you aren't using ffmpeg. See your profile:
order=copy,ffmpeg
Your first converter is COPY converter and not ffmpeg hence it just copies the remuxed video as it.

Change the to:
order=ffmpeg
And it should solve your problem.

The -map command should be removed (which you have) to keep only 1 audio track.
Marked as answer by rboy1 on 5/10/2014 at 2:31 PM
May 10, 2014 at 9:35 PM
It's a supplied profile!

I'll let you know what happens
Coordinator
May 10, 2014 at 9:46 PM
True, the profile is designed to support multiple audio tracks (it's called TS Unprocessed, because it doesn't modify anything). Hence you need to customize it to keep only 1 audio track (which is technically modified)
May 10, 2014 at 9:54 PM
OK that worked - thanks again for your help

Unfortunately it didn't solve the underlying problem with playing the file in Media Center but at least I have removed one possible cause.
Coordinator
May 10, 2014 at 11:03 PM
What is the underlying problem?


May 11, 2014 at 12:08 AM
The video is paying fine in WMP12 and Media Center (W7) but I am getting no audio. I've previously had a problem a problem with WMP12 selecting the wrong audio track but this has previously been OK in MC, but I couldn't rule it out until I had a file with just the video and one audio track in it, so I am now reasonably convinced that it is because the audio is AAC_LATM, however, this should be supported in W7.

My system is quite old 4-5 years and has had codecs installed and removed from it, I've checked what MC is using and reset everything to Microsoft with no effect.

I've done several searches by most of the posts about this problem date back to when W7 was originally released so a lot of the solutions are out of date. There is some suggestion that MC only supports AAC_LATM in a WTV container, however, this doesn't make sense to me as underlying video and audio are still in the same format as I am using.

I could move my tuner to my MC machine, but I am loathe to do so as Media Portal provides streaming facilities that I make use of plus it would mean having another machine switched on most of the time, I normally only have the MC up when we are watching TV.
Coordinator
May 11, 2014 at 12:31 AM
that's correct AFAIK MC only support AAC_LATM in WTV.
However I've managed to get AAC_LATM to play in other format by installing FFDSHOW.

The other option is just modify the profile to just recode the audio from AAC_LATM to AAC or AC3


May 11, 2014 at 5:27 PM
I've run a quick test and was able to re-encode the AAC to AC3 without having to touch the H.264 and without losing synchronisation, so it looks like the way to go.

Thanks for your help.