This project has moved. For the latest updates, please go here.

WTV profile - XBOX no video

May 9, 2014 at 9:23 PM
Hello - thanks for an excellent piece of software. I have seen that the latest donator version has fixes for the issue of xbox not playing video but has audio only. (Issue# 1786). However I have tested both the 32 and 64 bit versions (2.3 Beta 15 - 2014-05-04 under early access) but I only get audio and no video.
I have tested both WTV profile and WTV un-processed profile and yield the same result. Also there is a jitter in the video when I play it on WMC7.
Note that I am also using the latest comskip donator version.
Before I open an issue ticket, want to make sure I am not doing something wrong.

Snippet from mcebuddy.log (I cant figure out how to upload logs here)
INFORMATION> --> Windows OS Version -> Microsoft Windows NT 6.1.7601 Service Pack 1 (WIN_7_2008_SERVER_R2, Professional)
INFORMATION> --> Windows Platform -> 64 Bit
INFORMATION> --> MCEBuddy Build Platform -> 64 Bit
INFORMATION> --> MCEBuddy Build Version : 2.3.15.0
INFORMATION> --> MCEBuddy Build Date : 05/04/2014 18:15:42
INFORMATION> --> MCEBuddy Running as Service : True

thanks.
Coordinator
May 10, 2014 at 1:47 AM
I would suggest first try a clean install (see documentation FAQ). Sometimes there are artifacts from old versions left over.

Then after the conversion zip the log file and upload it to the mcebuddy server (see readme before posting sticky thread for instructions) to us to analyze.

Also if you can use the file splitter on the mcebuddy server to cut the first 30mb of the CONCERTED WTV file and upload the first chunk only to the server (chunk000). Post back here with the names of the files uploaded. We will look into it and let you know.

The only issue we have seen so far is if some 3rd party codecs interfere with WMC and WMP. There is a sticky thread for that you may want to see if you have installed any.

Coordinator
May 10, 2014 at 1:48 AM
Btw does the concerted file play back on your windows machine through WMP?

Does the original playback on your xbox?

Coordinator
May 10, 2014 at 3:09 PM
Also try the WTV Legacy profile (if you don't see if upgrade to the latest build), some old extenders don't support h.264 in WTV and only support mpeg2video in WTV.
May 10, 2014 at 3:26 PM
rboy1 wrote:
I would suggest first try a clean install (see documentation FAQ). Sometimes there are artifacts from old versions left over. Then after the conversion zip the log file and upload it to the mcebuddy server (see readme before posting sticky thread for instructions) to us to analyze. Also if you can use the file splitter on the mcebuddy server to cut the first 30mb of the CONCERTED WTV file and upload the first chunk only to the server (chunk000). Post back here with the names of the files uploaded. We will look into it and let you know. The only issue we have seen so far is if some 3rd party codecs interfere with WMC and WMP. There is a sticky thread for that you may want to see if you have installed any.
Thanks for the tips. I will try a new install when I get back home(however one of the machines was new and didn't even have shark/ffdshow and the mcebuddy installer put them on). I will either try and do a new windows install on a new machine or do a cleanup as you suggested.
May 10, 2014 at 3:28 PM
rboy1 wrote:
Also try the WTV Legacy profile (if you don't see if upgrade to the latest build), some old extenders don't support h.264 in WTV and only support mpeg2video in WTV.
  1. Yes the converted file plays on WMP. Strangely, on WMC the playback is not as smooth as the original.
  2. Yes the original plays on the xbox extender.
I will try the wtv legacy and report back after a clean install.
Note: I realized the title may be a little ambiguous; I use the xbox as an extender to wmc7 for WTV playback.
Recordings are done via the hauppauge HD-PVR and hauppauge colossus.
May 19, 2014 at 3:37 PM
Hi there - Sorry it took me a while to rebuild the PC and run the tests.
  1. The original recording plays well both the WMC7 and xbox extender.
  2. The WTV legacy profile - mpeg2 worked both on the PC (WMC7/WMP) and on the xbox extender.
  3. WTV Unprocessed and WTV profiles -
    XBOX - only audio plays. no video
    PC/WMC7 - Video freeze on FWD/REV. causes audio and video out of sync.
I have uploaded the first chunk of output and logs to the ftp server (/UPLOAD/discussion_544866).
Coordinator
May 20, 2014 at 3:23 AM
Thanks looking into it, meanwhile try this test partial profile and let me know if it works:
[WTV Legacy H.264]
Description=This is primarly for some Media Extenders which don't support b-frames h.264 in WTV. Recodes the video to creates high quality WTV (h.264/AC3) files.
order=ffmpeg
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -crf 20 -x264opts cabac=0:ref=3:bframes=0:weightp=0:8x8dct=0:trellis=0:subq=6:me=hex:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384K -map 0:a
ffmpeg-ext=.wtv
ffmpeg-audiodelay=skip
PreConversionCommercialRemover=true
Also try this one more thing (I think AVIDemux may be playing havoc with your WTV file with h.264).
Open profiles.conf and in your WTV Unprocessed profile, add this line to the last line of the profile.
CommercialMergeTool=ffmpeg
Now see if the profile works for you. (and please upload the log if it doesn't).


As for the freezing on WMP/WMC, it plays back fine and skips fine all my test machines. Do you have any codec packs installed? I think your codecs may have something to do with that.
Coordinator
May 20, 2014 at 3:28 AM
Also can you upload hte original WTV file (Hunt of the red october), since the chunk file you uploaded is not playing I suspect the original file may have something I would like to analyze and replicate here.
May 20, 2014 at 3:01 PM
rboy1 wrote:
Also can you upload hte original WTV file (Hunt of the red october), since the chunk file you uploaded is not playing I suspect the original file may have something I would like to analyze and replicate here.
Uploaded first chunk of original - under the folder discussion_544866. File name: Original_The Hunt for Red October_IFCHD_2014_05_14_01_43_00.wtv.chunk001
I will work on the other 2 profile changes you suggested and report back. Thanks.
Coordinator
May 21, 2014 at 3:14 PM
This recoded video plays backs fine on a Windows 7 MCE (no codecs installed) with the WTV and WTV Legacy profiles. The Unprocessed profiles isn't playing which I'm looking into.

I suspect it may have something to do with some codecs installed on your machine for teh WTV profile.


May 21, 2014 at 4:28 PM
rboy1 wrote:
This recoded video plays backs fine on a Windows 7 MCE (no codecs installed) with the WTV and WTV Legacy profiles. The Unprocessed profiles isn't playing which I'm looking into. I suspect it may have something to do with some codecs installed on your machine for teh WTV profile.
Thanks. The only codecs installed are Microsoft ones and the ones that could have come with the Hauppauge tuner - Arcsoft Total Media.
Additionally I see ffdshow (installed via mcebuddy) and Haali. I can upload the codec report as more eyes always help. I agree the codec hell is the worst thing to debug and has caused me many a heart ache in the past! Any ideas welcome.

Thanks for looking at the unprocessed profile as this would help me immensely as I have several TB worth recordings and unprocessed is the most efficient for most videos while maintaining quality.
Coordinator
May 21, 2014 at 5:39 PM
Why not just use mp4 or mkv or TS unprocessed?

try uninstalling ffdshow or disabling mpeg4 in ffdshow. Haali won't impact this.

May 21, 2014 at 6:18 PM
My WMC7 box serves as the media hub and I use the XBOX as extender. I lose most of the organization features when I convert to a format other than wtv. I am re-building the machine with just win 7 and mcebuddy now (Should have taken an image last time) and not going to install hauppage drivers. I will test with ffdshow disabling once its back up.
Coordinator
May 25, 2014 at 8:47 PM
Try this for the xbox extender, in the expert settings uncheck write metadata, if that makes the unprocessed profile playback.
Also any luck changing the CommercialMergeTool=ffmpeg
May 27, 2014 at 2:58 PM
No joy with CommercialMergeTool=ffmpeg addition. I will run a test with the write metadata change next.