This project has moved. For the latest updates, please go here.

quick sync fail

May 25, 2014 at 5:42 AM
Edited May 25, 2014 at 5:50 AM
I am testing a haswell i7-4790 with intel hd 4600 graphics and when I try to encode it looks like it processes 100% with quick sync then I see in the log that it failed and reprocesses with software encoding. I love the speed that it gives but I have no idea why it is failing. Can you please look at the log and tell me what you think? For reference I am including a successful quick sync on the same machine with a short 3 minute movie and the same encoder settings. Also I did try 3 different 1 hour wtv files and they all failed with similarar results.

https://www.dropbox.com/s/c7clvj247i33zqh/failed%20quick%20sync.log
https://www.dropbox.com/s/ayce2gbkrejlcfb/success%20with%20qs%203%20minute%20movie%20clip.log


Thanks and have a nice weekend.
Coordinator
May 25, 2014 at 3:37 PM
That's because handbrake is crashing right at the end.

Try downloading the latest nightly build of CLI handbrake and replacing it in the handbrake directory.
http://handbrake.fr/nightly.php

Download the 64bit CLI (if that doesn't work, try 32bit - it should not make a difference but it happens sometimes).
Coordinator
May 25, 2014 at 3:44 PM
Did you try updating your intel drivers? Number 1 reason for crashing handbrake is old drivers/broken drivers. Since the encoding is done in the driver, a crashing driver crashes handbrake.
Coordinator
May 25, 2014 at 3:46 PM
Also try using 10.18.10.3412 driver or 10.18.10.3574 driver.
May 25, 2014 at 3:55 PM
Edited May 25, 2014 at 4:13 PM
The first thing I did was get the latest (non beta) driver from Intel the version is 15.33.18.64.3496 (10.18.10.3496) dated 3/11/2014. I will try the other 2 if the nightly build does not work

There are 2 downloads on the nightly builds for handbrake I assume the version I want that is 64 bit is HandBrake-6205svn-x86_64-Win_CLI.zip

I will download and let you know. Thanks for your help.
Coordinator
May 25, 2014 at 4:54 PM
yes the other drivers are also from the intel website, one is a BETA and other is a slightly older. I've seen issues with some drivers so I try a fwe different ones could of versions up/down to see which one works best. I will need to get back to you on the version that I've tested with and it works fine.



May 25, 2014 at 9:33 PM
Edited May 25, 2014 at 9:44 PM
Ok i tried the beta driver (10.18.10.3574) and the nightly 64bit download. It worked fine the first time (no fallback to software encoding) but failed the next 2 times (stops after 99% complete on the encoding and then falls back to software and reencodes). I used the same source file on vidcoder (uses the handbrake engine), replicated the settings as close as I could and it worked fine with hardware encoding 3 times in a row.

I absolutly love your product but I am at a loss as to what to do about this. A few thoughts in comparing the output files from Vidcoder and MCEBuddy with Mediainfo:

Level
main@4.1 (vc)
high@3.0 (mce)

CABAC
off (vc)
on (mce)

Ref frames
2 (vc)
3 (mce)

Also it took about 13 min to complete on vidcoder and 26 on mce which is no big deal for me since mce does other things besides just encoding.

Let me know if you have any additional thoughts or would like more information and again thanks for all you do. I am willing to supply you with log files from each encode, source files or whatever else you would like if you are interested. FYI this is on a new machine with a fresh install and all updates applied of windows 8.1.1.
Coordinator
May 25, 2014 at 10:15 PM
Do you know what build of handbrake is used in vidcoder?

Try the older driver also. Alternatively change to the profile settings to match vidcoder and see if that works

Coordinator
May 27, 2014 at 3:54 AM
Can you upload a copy of your WTV file (original and full) which is crashing to the MCEBuddy server for analysis:
COPY AND PASTE URL in WINDOWS EXPLORER: ftp://mcebuddy:mcebuddy@files.mcebuddy2x.com/upload
You can upload and download files by dragging and dropping them. Alternative you can use a FTP client like FileZilla to upload the files.


Thanks
Coordinator
May 28, 2014 at 5:45 AM
There is a file called hb.dll with your vidcoder, can you right click on it and tell me which version it is.


May 29, 2014 at 1:51 AM
Sorry I had no idea that you had responded to this. I have spent many hours testing and I think I have a working solution for now. It would seem with the beta intel driver and the nightly build that it works most of the time. When it does stop working I just close the program and open it and start the next conversion and it would seem that most of the time it works ok.

I have also experienced 2 times where it doesn't fallback to software conversion and gets stuck at 99% and just keeps writing to the log file. At that point I have to tell mcebuddy to stop and I just restart.

Overall your program is flexible, fast, feature rich and makes a great solution move and convert files away from the WMC interface. I really don't think I could have made the switch without your program because it would have been a daily grind to do everything. The only thing that I would say is it would be nice to have better documentation but I understand that would take away from your development time.

Thank you for your help and I will let you know if this strange problem gets any worse since I have only been testing for a few days and it is a random problem. If you would still like me to check the version and upload files let me know and I will do that.
Coordinator
May 29, 2014 at 6:27 AM
Yes it would be great if you can upload one original file that causes issues and also the version of vid coder that works for you to help fix this. From your description it sounds like a driver issue (random rather than consistent) but the above would help.

May 30, 2014 at 8:45 PM
I have converted about 30 shows since you made the request and I have not had one failure. As soon as one fails I will upload the file and information for you to take a look at. Sorry this is taking so long.
Coordinator
May 30, 2014 at 11:42 PM
Don't know whether to be happy or disappointed

Coordinator
Jun 5, 2014 at 2:35 AM
The stable driver we are using here is 10.18.10.3379
Marked as answer by rboy1 on 6/11/2014 at 4:14 PM
Jun 5, 2014 at 7:20 PM
Thank you, I am testing it now.