This project has moved and is read-only. For the latest updates, please go here.

Large log files and audio problems

Jun 1, 2014 at 4:40 AM
I have converted about 60 wtv files to mp4 with minimal problems but all of a sudden with my last set of conversions I am having a problem I can't seem to fix. Normally all I have to do is reboot and restart but for whatever reason the problem does not go away. I am attaching a log file to hopefully help nail this down. It has happened with about 31 different wtv files. FYI the file does convert to mp4 but it is unwatchable because the audio is way out of sync.

Thanks and have a nice Sunday.
Jun 1, 2014 at 3:57 PM
That's because your original files appears to have some corruption:
2014-05-31T22:12:12 MCEBuddy.AppWrapper.FFmpeg --> [mpegts @ 000000000a52b560] Non-monotonous DTS in output stream 0:1; previous: 117526, current: 113022; changing to 117527. This may result in incorrect timestamps in the output file.

Try checking the box in experts settings for skip remuxing, see if that fixes your issue (make sure you are using donator version of comskip or shownanlyzer).

If it still does not work, try upload about 150M of the original WTV file (use the file splitter on the mcebuddy server) to the mcebuddy server (chunk001) for us to analyze.

Jun 1, 2014 at 6:25 PM
Thank you for looking at this...I tried the skip remux and it did not work and I do have the donator version of comskip. I also tried not using comskip. Normally I would just skip the file but it is happening with about 30 of them and it was not happening before. Maybe I just have a bunch of corrupt files and I should delete them but the originals play fine in wmc. I uploaded the first 150 of one of the files it is happening on under rumred85\ file with audio sync issues. The log file I posted above should be the same.

Jun 1, 2014 at 10:07 PM
There is some issue with ffmpeg and the source video. For now, open your profile and add this line:


This makes MCEBuddy use DirectShow Streams extraction instead of ffmpeg and should fix your issue (the sample file uploaded works fine with this). Will investigate further and get back on ffmpeg.

Marked as answer by rboy1 on 6/12/2014 at 6:08 PM
Jun 1, 2014 at 10:12 PM
Edited Jun 1, 2014 at 10:13 PM
I hate to sound stupid here but since I am adding a line, I am not sure where to place it. Do I add that line at the top of profiles.conf or under mp4 Normal at the top of the handbrake section?

Thank you for your time.
Jun 2, 2014 at 1:16 AM
It needs to be added to the profile section that you are using. So if you are using MP4 Normal, find the section [MP4 Normal] and add it anywhere in the section. Placement within a section does not matter.

Jun 3, 2014 at 2:00 AM
I tried it and the audio is much better. Still out of sync but watchable and no subtitles. Please let me know if you figure out why ffmpeg is doing this to some of my wmv files.
Jun 3, 2014 at 2:39 AM
The files are corrupted (from a standards point). Anyway if it's static shift (it the sync gap is constant) you can use the audio delay function to correct it.

Marked as answer by rboy1 on 6/12/2014 at 6:08 PM