This project has moved and is read-only. For the latest updates, please go here.

Long Conversion causing computer to crash/BSOD

Jun 2, 2014 at 12:28 PM
I am running MCEBUDDY 2.3.15 release and I keep having an issue converting a wtv file. It has worked great in the past but each time I try to convert this it will appear to get to the final steps in the conversion process and then fail hourglass my pc and then ultimately reboot the pc and cause a check disk. I am running with a solid state drive and it has no issues outside of this file. I think there is a leak somewhere or an issue with 2hr long shows. This was a reality show that was 2+ hours in record time. I will provide what log files I have and place the show on your server if you would like. The original show is 12.5 GB so don't know if you have the space or not. let me know how to proceed.
Jun 2, 2014 at 2:20 PM
First of all MCEBuddy CANNOT cause a computer to crash. It is an application, no matter how big the memory leak (which I doubt) it CANNOT cause the computer to crash.

The crash is because of a faulty driver on the system (it is the only piece of code privileged enough to cause a bug check). At most an application can cause itself to crash where as kernel mode driver (badly enough written) can cause a bug check.

Most likely it is either your video driver (if you are using an Intel chipset) or faulty hardware which under stress is exposing the flaw. MCEBuddy can be quite stressful on the system so keeping good hardware and drivers is paramount.

To isolate the root cause of the bug check you will need a software like WinDBG to analyze the kernel memory dump created by windows in the windows\minidump directory. This will tell you which driver caused the panic and why (big check code).

Regarding how MCEBuddy may be stressing the system drivers enough to cause the faulty one to panic, the most likely candidate is the video driver. If you are using an intel chipset turn off the hardware encoding option (which uses the intel quick sync driver). If the panic no longer happens then you have a faulty intel driver. Update the driver and it should solve your issue.

Marked as answer by rboy1 on 6/4/2014 at 7:36 PM
Jun 2, 2014 at 7:19 PM
I will check on the hardware encoding but believe I already have it turned off. This has not presented itself up until this one episode. I had a similar issue with past beta's but were resolved after you took the logs and video file. Think it had something to do with a profile string but cannot remember. Ill double check my settings and drivers. it is an intel based chipset for the computer but I believe my video card is either ATI or NVIDIA. It has been awhile since I have checked. Thanks for your response as I will begin checking these areas. The equipment I am running this on is a 2nd Gen i5 with 12GB of memory and a solid state drive running windows 8.1. Hardware wise it hasn't been too taxed by the system but for some reason this particular show will run through most of the steps and then fail and freeze up the system where the mouse works but that is about it. Eventually it will just reboot and then have to run checkdisks. I will also try to get the bug check code to see what is going on if it helps at all. If there is any other suggestions you have I am up to try it out. Thanks
Jun 2, 2014 at 7:36 PM
If the profile is using handbrake try changing the order to ffmpeg and see if it still happens. If it doesn't then it's handbrake but again handbrake can only block up resources it's some driver that's panicking the system due to lack or resources or due to like I had mentioned a bug causing the crash.

Jun 3, 2014 at 11:49 AM
OK think I found where the issue is at. Thanks for the help. I disabled the auto restart on the bug check to allow me to see where the issue was. Turned out the error was related to memory or HDD. Tested the memory and it was fine. Tried it again this time pointing to the mechanical drive in the system and it went through without issue. Pointed the job back at the SSD and it bugchecked again. What is weird is shows up to at least an hour long has no issues on the SSD. Only 2+ hour shows does the bugcheck. I'll try updating the firmware on the SSD in hopes to resolve the issue. Again thanks for your help.
Marked as answer by rboy1 on 6/4/2014 at 7:35 PM
Dec 8, 2014 at 1:15 PM
For future reference you can also just upload your crash minidump file to this website and it'll tell you which driver caused the crash:

Goto C:\Windows\MiniDump
You'll find the crash dump files there, take the latest one (You will need to right click, select properties, Security -> Change ownership to yourself otherwise it won't let you access it) and upload it to the above link and you'll have your answer.