PostCustomCommand User

Aug 14, 2014 at 2:08 AM
Edited Aug 14, 2014 at 2:09 AM
I'm trying to run filebot on my completed files using the PostCustomCommand on 2.3.15. When I run the filebot command manually from the windows command prompt it works fine. When it runs via the PostCustomCommand in MCEBuddy I get a failure in filebot for not having permission to move the file to the mapped network drive. Is MCEBuddy running the PostCustomCommand as a different user? Does anyone know how to fix this?

profiles.conf:
[Nolans Custom MKV High Quality to Filebot]
Description=High profile, high quality 2 pass MKV (H.264/AC3). This can helpful for source videos with low quality, takes the most time and produces the best results.
2pass=true
order=handbrake,ffmpeg,mencoder
mencoder-general=-ss 3 -vf pullup,softskip,yadif=0:-1,hqdn3d,harddup
mencoder-video=-ovc x264 -x264encopts bitrate=1800:me=hex:trellis=2:subq=8:partitions=all:8x8dct:ref=5:rc_lookahead=50:keyint=25:keyint_min=20:bframes=3:weight_b:level_idc=40:b_pyramid=normal:direct_pred=auto:mixed_refs:deblock=-1,-1:nofast_pskip:nodct_decimate:b_adapt=2:threads=auto
mencoder-audio=-oac lavc -lavcopts acodec=ac3:abitrate=192
mencoder-audioac3=-oac lavc -lavcopts acodec=ac3:abitrate=384
mencoder-ext=.avi
mencoder-remuxto=.mkv
mencoder-audiodelay=skip
ffmpeg-general=-threads 0
ffmpeg-video=-ss 3 -vf yadif=0:-1:1,hqdn3d -vcodec libx264 -b 1800k -x264opts me=hex:trellis=2:subq=8:partitions=all:8x8dct=1:ref=5:rc-lookahead=50:keyint=25:min-keyint=20:bframes=3:weightb=1:level=4.0:b-pyramid=normal:direct=auto:mixed-refs=1:deblock=-1,-1:no-fast-pskip=1:no-dct-decimate=1:b-adapt=2:threads=auto -map 0:v -sn
ffmpeg-audio=-acodec ac3 -ab 192k -map 0:a
ffmpeg-audioac3=-acodec ac3 -ab 384k -map 0:a
ffmpeg-ext=.mp4
ffmpeg-remuxto=.mkv
ffmpeg-audiodelay=skip
handbrake-general=--decomb --denoise="weak" --loose-anamorphic --verbose=2 -T -f mp4 -4
handbrake-video=--start-at duration:3 -e x264 -b 1800 -x me=hex:trellis=2:subq=8:partitions=all:8x8dct:ref=5:rc-lookahead=50:keyint=25:keyint-min=20:bframes=3:weight-b:level-idc=40:b-pyramid=normal:direct-pred=auto:mixed-refs:deblock=-1,-1:nofast-pskip:nodct-decimate:b-adapt=2:threads=auto
handbrake-audio=-E ffac3 -R auto -B 192 -D 0 -a 1,2,3,4,5
handbrake-audioac3=-E ffac3 -R auto -B 384 -D 0 -a 1,2,3,4,5
handbrake-ext=.mp4
handbrake-remuxto=.mkv
handbrake-audiodelay=skip
PreConversionCommercialRemover=true
PostCustomCommandPath=C:\Windows\System32\cmd.exe
PostCustomCommandParameters=/C filebot -script fn:amc --output "Z:/" --log-file amc.log --action move --conflict override -non-strict "%convertedfile%" --def clean=y pushbullet=v1Qxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxyyyy xbmc=127.0.0.1 plex=192.168.1.11 music=n artwork=y
PostCustomCommandHangPeriod=0
PostCustomCommandCritical=false

Here is the filebot amc log for those interested. This error is commonly referenced on the filebot forums as a permission error.

Fetching episode data for [Rick and Morty]
[MOVE] Rename [E:\Recorded TV\Converted\Rick and Morty\Rick and Morty-S01E04-M. Night Shaym-Aliens!.mkv] to [Z:\TV Shows\Rick and Morty\Season 01\Rick and Morty - S01E04 - M. Night Shaym-Aliens.mkv]
[MOVE] Failed to rename [E:\Recorded TV\Converted\Rick and Morty\Rick and Morty-S01E04-M. Night Shaym-Aliens!.mkv]
java.io.IOException: Failed to create folder: Z:\TV Shows\Rick and Morty\Season 01
Clean clutter files and empty folders
Finished without processing any files
Failure (°_°)
Coordinator
Aug 14, 2014 at 4:10 AM
Did you enter the network credentials in MCEBuddy? This topic has been addressed many times, MCEBuddy runs in Session 0. Network drives/mapping and authentication from user sessions are not valid and it needs to be reauthenticated via MCEbuddy.
Marked as answer by rboy1 on 8/13/2014 at 9:19 PM
Coordinator
Aug 14, 2014 at 4:21 AM
Look at the documentation page under Common Issues here: Search for authentication:

https://mcebuddy2x.codeplex.com/wikipage?title=MCEBuddy%20Common%20Issues
Marked as answer by rboy1 on 8/13/2014 at 9:22 PM
Coordinator
Aug 14, 2014 at 4:22 AM
This thread answers your question also:

https://mcebuddy2x.codeplex.com/discussions/532159
Marked as answer by rboy1 on 8/13/2014 at 9:22 PM
Aug 14, 2014 at 1:23 PM
Thank you, that did the trick. For those having the same problem, make sure you do not use a network mapped drive in your PostCustomCommand parameters. Instead, use the UNC path such as: \192.168.1.10\video

Also, as rboy1 stated be sure to configure the network credentials in the MCEBuddy expert settings.

Sorry I couldn't find this in the forums/documentation. There is so much information in so many places, it is overwhelming.
Marked as answer by rboy1 on 8/14/2014 at 9:06 AM