This project has moved and is read-only. For the latest updates, please go here.

Problem with new version

Sep 22, 2014 at 6:41 PM
I have many conversion tasks that I run depending on the file type. For whatever reason after I updated to the beta version 2 of my conversion tasks are not working properly. As an example I have a conversion task for just pulling metadata, renaming the file and moving it to the proper location. For whatever reason when I place a file in the folder for rename and move it does pull the metadata and renames the file but it does not move it to the proper location, it places it in the same folder it is currently in and throws an error in the history file with no explanation.

I can play the same file in a convert to mp4 folder and it pulls the date renames and moves the file to the proper location after the file conversion.

I have been using the non beta version for months with no problems and I have tried everything I can think of but no luck. I will include the log file for your review. Thanks.

log file of rename and move which is not moving the file and not working correctly

log file of convert rename and move which is working fine
Sep 23, 2014 at 7:35 AM
You need to give MCEBuddy write access to your \\DISKSTATION\Video\MCE Rename move tv folder.
That's why it's failing (it's trying to rename the file in the original location before moving it). And this is happening because you've asked MCEBuddy not to copy the file locally before renaming it.

Skip Copying Original File for Backup -> True

Error : System.UnauthorizedAccessException: Attempted to perform an unauthorized operation.

Sep 23, 2014 at 5:53 PM
My problem is that as you can see in the second log file, everything is working fine and skip copying original file is true on that one as well and it writes to the diskstation. I am using the exact same username and password to give access to the diskstation and it works on one and does not work on the other. Everything was working before I upgraded to the beta. I changed nothing after the upgrade but for whatever reason it is not working now.
Sep 23, 2014 at 10:54 PM
Edited Sep 23, 2014 at 10:56 PM
Ok I ran another test using the exact same conversion task, the ONLY difference is I ran one task with the "Rename without converting" checked and the other with the "Rename without converting" not checked. The one with the converting checked worked properly and the other did not. My best guess is this is some kind of bug in the beta version. To be clear when it was not checked it renamed and moved the file to the proper location. When it was checked it did rename the file but left it in the same location.



Please let me know what you think.
Sep 24, 2014 at 2:41 AM
It's not a bug as I had explained earlier, when you check the option for Skip copying the original file it tries to rename the file on the server which fails because you haven't given write permissions.

When you' converting and renaming it creates a local copy to work with and hence it's able to rename it.

The solution is either give MCEbuddy write access to your remote server or UNCHECK the Skip copying original file option while renaming without converting.

Sep 24, 2014 at 3:25 AM
Edited Sep 24, 2014 at 3:36 AM
What I am trying to explain is the only change I made to the conversion task was the rename without converting. If I allow it to convert the file then it renames and copies it to the server because I have given it access on the conversion task but when I don't allow it to convert first it does not copy the file. There is no other change to the conversion task the skip copying the original file is checked it is only rename without converting that is checked or unchecked. If rename without converting is checked it does not copy the file to the remote server. If it is not checked it does copy the file to the remote server. On top of all that everything was working before I installed the beta version. Now all of my conversion task work and send files to the server except the ones that have rename without converting checked.

It seems like when rename without converting is checked it is not passing the user name and password to the server and when it is unchecked it is passing the user name and password because the only change I am making to the task is unchecking rename without converting
Sep 24, 2014 at 3:46 AM
Let me try this again, to you it's "just" a single check box. To MCEBuddy it's a whole different world. Once check box changes the entire logic and flow of the software.

So when you don't check that single check box, it remuxes the file locally, converts it renames it and puts it on the server it has write access to.

When you check the single box, now it tries to rename the file directly while on the server which fails because you haven't given it permissions to edit the original file.

So again, when MCEBuddy warns you about using the option to skip coping original take it seriously. It can have unexpected consequesnces as you have come to see.

Sep 24, 2014 at 3:58 AM
Edited Sep 24, 2014 at 4:21 AM
I do appreciate that the check box can have cascading events it still does not explain why before the beta the conversion tasks were working properly with the skip copying original file checked. I must stress that I made NO changes to my conversion task after I installed the beta version. In addition why would it work if I have the skip copying original checked and rename without converting unchecked. The file is being converted on the server and moved to the folder on the server.

I also checked the 2 most recent logs I sent you and only the one that is checked skip conversion comes up unauthorized even though the file is in the exact same place on the server as the one that is not checked skip conversion.
Sep 24, 2014 at 2:43 PM
Can you attach or upload the log with the older version (or 2.3.15) which shows it works. Not saying it doesn't but will help get to the bottom of this

Sep 24, 2014 at 4:58 PM
When I did the upgrade it erased all my old logs but fortunately I had a backup.


Thank you for looking into this
Sep 25, 2014 at 12:57 PM
Okay that was helpful. Recently there was a workaround added to retain the destination folder security permissions after a file has been converted (due to a windows limitation that keeps the original when moving a file within the same volume).
This is what is causing it to fail, MCEbuddy isn't able to set the permissions on the final file.

Will look into it, it should give a warning instead of fail. Meanwhile just give MCEBuddy full access to the folder and it should solve your issue for now.

Thanks for reporting this.

Sep 25, 2014 at 4:22 PM
Thank you for finding the problem. I am unclear how to give more permission to MCEBuddy than I have given. It already has full read and write access to the synology server.
Sep 30, 2014 at 4:37 PM
It needs permissions to change permissions.
Sep 30, 2014 at 5:06 PM
I guess I am at a loss as to how to do that. It still makes no sense to me that it does work when converting the file but does not work when renaming the file. What is the way to return to the 3.15 version without losing my settings? I do not see anything in the readme file for that.
Sep 30, 2014 at 5:56 PM
A recent change, when trying to move files on the same volume Windows does not inherit the permissions of hte destination folder. MCEBuddy tries to fix that by changing the permissions of the moved file to match the destination folder. Anyways it will be fixed in the next today.
Marked as answer by rboy1 on 9/30/2014 at 9:56 AM
Oct 1, 2014 at 8:50 PM
The new version seems to have taken care of this. Thanks for your help.