This project has moved and is read-only. For the latest updates, please go here.

mcebuddy failure to convert Modern Family from MPEG2-TS OTA

Dec 15, 2014 at 2:57 PM
Hi, I use NextPVR to record various TV programs, including Modern Family. I've been using MCEBuddy to convert the MPEG2-TS stream to H264/MP4 (with comskip chapters) for consumption by AppleTV and other iOS devices.

All programs convert successfully, except Modern Family. Every week, I get the same error. I've tried both hardware accelerated (QuickSync) and software encoding. I'm using "M4V Apple Normal" profile. Interestingly, if I run Handbrake manually on the file, it converts just fine.

I'm not really sure exactly what the error is... from the log file, I see some interesting entries like

"2014-12-15T08:23:32 MCEBuddy.AppWrapper.Handbrake --> [08:23:32] hb_ts_stream_find_pids - end of file
2014-12-15T08:23:32 MCEBuddy.AppWrapper.Handbrake --> [mpeg2video @ 000000000232e8c0] Invalid frame dimensions 0x0.

The MPEG2-TS file plays fine in VLC.

The entirety of the log is here: Has anyone seen anything similar?

Dec 16, 2014 at 5:29 AM
Edited Dec 16, 2014 at 5:29 AM
  1. Use the latest 2.4.1 build of MCEBuddy - newer build of handbrake + fixes more issues
  2. It's your video driver causing the issue, you've enabled hardware encoding and your video driver is not functioning properly. See the FAQ on hardware encoding use a stable version of the intel video driver.
Marked as answer by rboy1 on 12/16/2014 at 5:52 AM