This project has moved and is read-only. For the latest updates, please go here.

Files not found during scan

Feb 14, 2015 at 1:59 PM
I am currently using the Early Release version and was wondering if anyone else is having issues with MKV files not being recognized during the scan for new files. In the log the extra files in the directory are being found, just not the main mkv file. I have attached the log file.

This is one file that was an issue:
2015-02-13T05:48:57 MCEBuddy.Engine.QueueManager --> File The.Blacklist.S02E11.Ruslan.Denisov.No.67.1080p.WEB-DL.DD5.1.H.264-NTb-NZBgeek.sfv

it found the sfv and 4 other non mkv files but there was a mkv file in the same location with the same name but was never found. I does not even show in the log that it found or scanned the file until I added it manually.

Here is another one:
2015-02-14T04:56:32 MCEBuddy.Engine.QueueManager --> File Gold.Rush.S05E17.1080p.WEB-DL.AAC2.0.H.264-NTb-NZBgeek.sfv

same as above, found the sfv but not the mkv.

Last one today:
2015-02-14T05:51:32 MCEBuddy.Engine.QueueManager --> File 12.Monkeys.S01E05.The.Night.Room.1080p.WEB-DL.DD5.1.H.264-BS-NZBgeek.sfv

same result


here is a link to the complete log.

MCE Log


Thanks in advance
Feb 14, 2015 at 5:07 PM
If the files are locked by another process the MCEBuddy will ignore them, they won't show up in the list. Try a program called Unlocker to see which process is locking them
Feb 14, 2015 at 6:37 PM
I downloaded the Unlocker program cause it failed to find 2 more mkv files, I ran the program and it said "No Locking Handle Found", but when I rescan it does not find the file. Nothing new in the log either.

Any ideas or information you need?
Feb 14, 2015 at 6:55 PM
Am trying to see if it's the file it something.

Can you give me the file names or search the log for the file names.
Also try adding them manually by dragging and dropping them on the App and see they queue up.

Feb 14, 2015 at 7:00 PM
When I drag and drop them they add to the Queue but they add under both Conversion Tasks I have setup. The current filename that will not work is "Hawaii.Five-0.S05E15.720p.WEB-DL.DD5.1.H.264-KiNGS-NZBgeek" the other names that did not work before are listed in the first post.

Thanks
Feb 15, 2015 at 4:21 AM
Thanks for bring this to our notice, I need to deep dive into this. I need a little help here to recreate. I see you have a very complex and vast file system. I have your log file which will give me the settings I need, however what I need is one more thing, you file system structure.

Can you do a:
dir /s > list.txt
From the command prompt and me the list.txt file to mcebuddy2x@yahoo.com (I understand you may not want to post it here). I would like to recreate the structure and see if I can find out what's going on.

thanks,
Feb 15, 2015 at 4:21 AM
This is starting from your root video folder
D:\Watch Folder
Feb 15, 2015 at 6:53 PM
I have sent the information to your email, as requested. Let me know if you need anything else.
Feb 20, 2015 at 10:34 PM
Any update?
Feb 20, 2015 at 10:39 PM
Haven't forgotten you about you:)
No sorry been a little backed up with some other stuff, will get it soon. We need time for this issue since we need to recreate the file system with the same names and that's a big task

I could request you to try one things if you have the time, install VMWare player and install your OS within it, a fresh copy, no other software installed just MCEBuddy and then point it to your file system and see if it happens again (log file please). That'll help a lot and be much faster to diagnose than us trying to replicate your filesystem.

Feb 21, 2015 at 1:43 PM
Not totally familiar with VMWare, if I can't figure it out can I load a clean version of Win7 on a NUC I have and try it out?
Feb 21, 2015 at 2:06 PM
yes that the idea. VMWare player is a app that allows you to run an OS within Windows. Failrly easy to install and use. You install VMWare Player app, click on new virtual machine, point to your ISO or DVD Drive where your OS you want to install resides and it install it for you (it resides on your harddisk as a BIG file). You can also do a clean install and try it.

Feb 24, 2015 at 3:29 PM
I did not have time to set this up last weekend but I did find something interesting, if the file is not found during the initial scan and I do not Drag N Drop the file onto MCEB then after about 5-6 hours MCEB finds the file and starts the conversion. Not sure what the delay may be, I have the internal delay set to 0. Just wanted you to know.
Feb 25, 2015 at 5:06 AM
This is interesting and explains the picture better.
If it picks i up eventually after a few hours then the file is locked for that duration.

How MCEBuddy works is like this:
1. It scan the monitored directory and subdirectory (if configured) for a list of files, then it check the accessibility for each file. If the file had a read lock on or write lock on it then it prints a message in mcebuddy.log that the file is inaccessible (JUST ONCE to avoid overloading the log). Then it goes away for 5 minutes and then retries the entire process again.
2. It also checks if the file scanned has an entry in the history log. So you added the file manually before (drag and drop) that creates an entry in the history log. MCEBuddy will ignore files that have a history (hence to reconvert a file, the entry from the history log has to be removed using the history button).

This explains exactly what you said. Now a point to note, MCEBuddy makes an API call to get a list of all files in the directory, if windows doesn't report the file with the API call then there's nothing MCEBuddy can do (not sure if the file has a read lock on it for X hours or if it isn't showing up in the API). The way to tell is look at the log, if the log says the file is locked or inaccessible than that's the answer and if it doesn't mention the file for X hours then windows is not reporting the file.

The only other thing to confirm, which you said you have checked, is to confirm that the age/delay in the settings page is set to 0.

Marked as answer by rboy1 on 2/25/2015 at 6:49 PM