This project has moved. For the latest updates, please go here.

Audio out of sync just ever so slightly

Apr 12, 2015 at 7:46 PM
Well the discussion was down for awhile and I had great help thru email from somebody @ mcebuddy. Whoever helped me out was great and we figured out that my recorded files were just no good. Now I have that taken care of I have some slightly out of sync audio with my video, I am using the latest version 2.4.2 and setting are for MP4 Normal. I have uploaded a log

The King of Queens_KASWDT_2015_04_11_20_58_21.wtv-Convert to MP4-2015-04-11T21-30-01.2346201-07-00

I am also having issues with commercial not getting cut out but that i can deal with for now.

any help greatly appreciated. Thanks
Coordinator
Apr 13, 2015 at 2:54 AM
Glad to know it worked out. Do let us know which of the solutions finally worked for you.

Coming to your current issues, I checked out your log file and it looks like somehow handbrake thinks your video format keeps changing:

2015-04-11T22:11:27 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 63.14 % (22.17 fps, avg 18.61 fps, ETA 00h09m42s)[22:11:27] 663.111755s: Video -> Film
2015-04-11T22:11:28 MCEBuddy.AppWrapper.Handbrake --> Encoding: task 1 of 1, 63.16 % (22.17 fps, avg 18.61 fps, ETA 00h09m42s)[22:11:28] 663.345337s: Film -> Video


It changes between Film and Video, which has an impact on the frame rate consequently it has an impact on the audio sync.

A quick fix would be to use the Audio offset parameter in the Expert Settings page to correct the audio sync (assuming the audio sync is off by a constant figure).

The longer term solution would be figure out why handbrake thinks the format is changing.
Try this, open the profile and change the order to ffmpeg first instead of handbrake. Let me know how that goes and if the audio sync is still off then please upload the log file.

If that fixes the issue, then just try downloading the latest nightly build of handbrake and replacing the one in the mcebuddy installation directory and see if that works.

Quite a bit here for you to check out :)

Marked as answer by rboy1 on 4/28/2015 at 12:34 PM
Apr 14, 2015 at 6:35 AM
Edited Apr 14, 2015 at 3:50 PM
changed the ffmpeg order and its looks like my logs still keep showing the change from video and film, I have uploaded the file

The Originals_KASWDT_2015_04_13_18_58_00.wtv-Convert to MP4-2015-04-13T20-07-54.4562657-07-00

i will try replacing the handbrake in mcebuddy and see what happens.

Well i was going to upload it but I cant connect, is it down?
Looks like its up this morning, file has been uploaded
Apr 17, 2015 at 6:10 AM
rboy

Can you look at my latest log file? I did as you say replacing the handbrake in the mcebuddy directory.

The Vampire Diaries_KASWDT_2015_04_16_18_58_00.wtv-Convert to MP4-2015-04-16T20-06-28.8153472-07-00

Thanks for all your help. I think I am so close to to having this convert all my shows for use on other devices.
Coordinator
Apr 18, 2015 at 11:00 PM
yes I see that from the logs. your source file isn't perfectly encoded it has duplicate packets but much better than before.

Did you try using the audio offset compensation in the expert settings to correct the sync?